Galv Message Styles w/ Galv Message Busts

Discussion in 'Javascript/Plugin Support' started by IAmJakeSauvage, Nov 4, 2017.

  1. IAmJakeSauvage

    IAmJakeSauvage Veteran Veteran

    Messages:
    417
    Likes Received:
    669
    Location:
    Hamilton, ON
    First Language:
    English
    Primarily Uses:
    RMMV
    Hey guys,

    EDIT: I've noticed it only happens when I don't use a 'pop'/plugin command to show the message so that's an easy enough workaround.

    I wish I could take a screen of what's happening but it happens too quick. Basically, these two plugins were built for compatibility with one another (this also happens in a clean project) but what happens is sometimes when the 'bust' graphic transitions out it fades to where the face would be shown in a 'regular' window. In the screenshot below you can see where the 'bust' is placed - but if this scene transitions out, her face flashes on the bottom where it would be in a vanilla text box.

    I have busts installed under styles - as it gets wonky if it's the other way around, and I use a wait command after each message to ensure a smoother transition, so I'm not sure...

    Plugins:
    Message Styles: https://galvs-scripts.com/2016/03/31/mv-message-styles/
    Message Busts: https://galvs-scripts.com/2015/11/01/mv-message-busts/
    Screen10.png
     
    Last edited: Nov 4, 2017
    #1
  2. Galv

    Galv Veteran Veteran

    Messages:
    1,179
    Likes Received:
    1,115
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    N/A
    It sounds like you might be displaying a pop message and then instantly a normal message after? If so, try adding some wait time so the pop message box closes, bust vanishes and then display the normal message
     
    #2
  3. IAmJakeSauvage

    IAmJakeSauvage Veteran Veteran

    Messages:
    417
    Likes Received:
    669
    Location:
    Hamilton, ON
    First Language:
    English
    Primarily Uses:
    RMMV
    If I just use pop commands it doesn't happen - but it still happens with the wait commands, and it happens until I reload the map which is super weird.
     
    #3
  4. Galv

    Galv Veteran Veteran

    Messages:
    1,179
    Likes Received:
    1,115
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    N/A
    Ahh, I see now. Seems I must have broke compatibility during updates somewhere.

    As a temporary solution I have updated my bust plugin to version 2.8:
    https://galvs-scripts.com/2015/11/01/mv-message-busts/

    I added a fade out speed setting. Change this to 255 to make the busts fade instantly so that the bust doesn't appear where it shouldn't during window close. I'll do a real fix later when I get some time.
     
    #4
    IAmJakeSauvage likes this.
  5. IAmJakeSauvage

    IAmJakeSauvage Veteran Veteran

    Messages:
    417
    Likes Received:
    669
    Location:
    Hamilton, ON
    First Language:
    English
    Primarily Uses:
    RMMV
    Thanks for your help! I really appreciate the quick solution. :)
     
    #5

Share This Page