Galv's Character Effects BUG -please help-

Discussion in 'RGSSx Script Support' started by Klaykrow, Aug 29, 2019.

  1. Klaykrow

    Klaykrow masochistfox Member

    Messages:
    28
    Likes Received:
    1
    First Language:
    English
    Primarily Uses:
    RMVXA
    everything was working fine until now for some reason and im not sure how to fix it

    scripts i have-

    Galv's character effects

    Galv's region effects

    ももまる's full screen

    khas's awesome lighting effects

    Galv's message busts

    Non-Combat Menu v1.04a​

    now when i play test i get this-

    upload_2019-8-28_16-33-48.png
    upload_2019-8-28_16-36-58.png

    it happened last when I saved (above) and also when i tried to go into a different room (which worked fine before)

    upload_2019-8-28_16-36-4.png

    upload_2019-8-28_16-36-29.png

    any help will be greatly appreciated! thank you!
     
    #1
  2. Wavelength

    Wavelength Pre-Merge Boot Moderator

    Messages:
    4,511
    Likes Received:
    3,766
    Location:
    Florida, USA
    First Language:
    English
    Primarily Uses:
    RMVXA

    I've moved this thread to Script Support. Please be sure to post your threads in the correct forum next time. Thank you.

     
    #2
  3. Klaykrow

    Klaykrow masochistfox Member

    Messages:
    28
    Likes Received:
    1
    First Language:
    English
    Primarily Uses:
    RMVXA
    -EDIT-
    Ok so, i deleted " eval(script)" from the spot where i was getting an error and it did fix the error

    problem now is my script for my message busts arent working

    they show up in game, but the script call to flip them isnt working :<
     
    Last edited: Aug 29, 2019
    #3
  4. Thefirelion

    Thefirelion Veteran Veteran

    Messages:
    49
    Likes Received:
    11
    First Language:
    Spanish
    Primarily Uses:
    RMVXA
    I'm not a scripter, but I can give you some of how to raise the problem so they can help you:

    1) Describe your problem in the most detailed way you can.

    2) Post a screenshot of the events in which the problem is created.

    3) If you have problems with scripts, you must provide the scripters, writing the links of the scripts in your post

    4) Did you really delete the "eval (script)" ?, you have NOTHING to look for in the base scripts, and much less in the Game Interpreter, this does not help you fix the problems, rather, IT TELLS YOU that there is a trouble with a script sequence.
     
    #4
  5. Shaz

    Shaz Veteran Veteran

    Messages:
    37,917
    Likes Received:
    11,586
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    wow - if you don't know what you're doing, the last thing you want to do is start deleting things randomly! You've just broken every script call in your game!

    Put that eval(script) back, and add a line above it with this:
    p script

    That will at least tell you, when the game crashes, what the script call is that caused it to crash (in case you didn't already know). You need to play with the console enabled.

    Getting back to the original problem, either index or @cw in that line is a null value. This means you either didn't pass something in that was required, or it's using something that isn't set up properly. Please show your script call (screenshot or copy/paste from the script call - do not just retype it here) and provide a link to the full script (do not copy and paste it into your post).

    I also suggest you refrain from using the word BUG in your thread titles. That implies the creator of the script has done something wrong, so it sounds accusing. It's more often the user of the script who has done something wrong. You can usually determine this by how many other people using the script are reporting the same issue - probably zero in this case.
     
    #5

Share This Page