Galv's Layer Graphics (fogs, parallaxes, mapping)

Palkia

Warper
Member
Joined
Jun 29, 2016
Messages
1
Reaction score
0
First Language
Spanish
Primarily Uses
I want to make a map that has cloud shadows in it without moving, but when I go to map and move around, it moves around like the camera (which is annoying). Anyone can help me by giving command or explanation?


very much appreciated.
 

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,227
Reaction score
1,412
First Language
English
Primarily Uses
RMMZ
Do you mean as though the shadows are stuck to the map?


Make the XSHIFT and YSHIFT number 0 to have the layer move with map.


Check out the help documentation for examples and descriptions. Grab the demo and look in the events for working examples.
 
Last edited by a moderator:

Tiwany

Warper
Member
Joined
Aug 17, 2016
Messages
2
Reaction score
0
First Language
Italian
Primarily Uses
Hey I just downloaded this plugin because it looks amazing but I cant make it work, even when turning all the others off


Lets say I have a map called "025:Church" and I want to add a static layer that I made called "churcheffects.png", so the plugin would be:


LAYER_S 025 2 churcheffects 0 0 110 0 1


But when I enter the map it doesnt show


This is how it should be on the map


Screenshot 2016-08-17 11.38.22.png


But


Screenshot 2016-08-17 11.39.23.png


Am I doing something wrong?
 

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,227
Reaction score
1,412
First Language
English
Primarily Uses
RMMZ
Some possible causes.


1. Make sure you call the plugin command before you enter the map (or use the LAYER REFRESH plugin command if you create the layer while on the same map).


2. You Z value is 0, which might make it appear underneath other map objects. Try making it a larger number (eg. 10)


3. For the map ID, you can just use 25 instead of 025


4. Try changing the blend mode to 0 to test it's actually showing up.


See the demo for examples.
 
Last edited by a moderator:

YuiDemonia

Veteran
Veteran
Joined
Apr 13, 2016
Messages
61
Reaction score
9
First Language
English
Primarily Uses
Hi Galv~


I would like to thank you for this awesome plugin! I use this for parallax mapping and it works great for my smaller maps, however, I encountered something and I hope you can help me out on this one. I created a sample map with 41x30 size. I created my ground parallax layer and overlay parallax layer for it. Now what happens is, as soon as I load the game, the ground parralax layer wont show up, not until I go to the top section of my map. Then as soon as I go down approx. 4-5 grid, the ground parallax layer disappears. It goes back if I go to the top of the map again. 


Thanks in advance! :D


*EDIT*


here's the vid
 
Last edited by a moderator:

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,227
Reaction score
1,412
First Language
English
Primarily Uses
RMMZ
Are you changing layer settings with an event anywhere on the map and using the same layer id?


Do you have map looping turned on?


Have you tested if another plugin is conflicting with it?


I can't think of why else that would happen unless it's a bug that has popped up with the latest MV updates. Have you updated MV to latest 1.3.1?
 

YuiDemonia

Veteran
Veteran
Joined
Apr 13, 2016
Messages
61
Reaction score
9
First Language
English
Primarily Uses
Hi Galv, thanks for replying back.


I tried both, the map notetag and by event. However, I managed to fix it by changing the layer ID and priority of the image to a different number. Thanks again! :D
 

Nomi

Veteran
Veteran
Joined
Dec 16, 2014
Messages
156
Reaction score
48
First Language
German
Hi Galv,

is multiply still bugged or is it just me?


It doest seem to load the img when I set the blendmode to 2.
 

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,227
Reaction score
1,412
First Language
English
Primarily Uses
RMMZ
Multiply works for me since pixi was updated - make sure you've copied over all the right files after updating to MV 1.3.1.
 

Nomi

Veteran
Veteran
Joined
Dec 16, 2014
Messages
156
Reaction score
48
First Language
German
Hmm, I got the steam version - expected it to be doing everything automatic.


It's version 1.3.1 so, but maybe I need to change something by hand?


I get a black ingame screen as soon as I use the blend option 2. Option 0 and 1 work...but look terrible >.< Sadly :D
 

Nomi

Veteran
Veteran
Joined
Dec 16, 2014
Messages
156
Reaction score
48
First Language
German
Hmmm... okay, but wont that reset all my changes to database?
 (actors, weapons, spells, items etc.)
 

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,227
Reaction score
1,412
First Language
English
Primarily Uses
RMMZ
Don't copy those files... backup your project first!


I'm sure there's gotta be info on how to do this somewhere on the forum, you shouldn't have to learn about this from this plugin thread
 

KanaX

Just being a sleepy
Veteran
Joined
Apr 3, 2013
Messages
1,455
Reaction score
1,294
First Language
Broken English.
Primarily Uses
N/A
Can I place layers below parallaxes? That would be really helpful.
 

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,227
Reaction score
1,412
First Language
English
Primarily Uses
RMMZ
I believe if you make the z value negative numbers it should go below parallax, yep
 

KanaX

Just being a sleepy
Veteran
Joined
Apr 3, 2013
Messages
1,455
Reaction score
1,294
First Language
Broken English.
Primarily Uses
N/A
It didn't though! And I wasn't subtle about it, I tried big negative numbers.
 

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,227
Reaction score
1,412
First Language
English
Primarily Uses
RMMZ
Hmm, darn - perhaps they don't. Perhaps you could use a layer instead of the parallax
 

KanaX

Just being a sleepy
Veteran
Joined
Apr 3, 2013
Messages
1,455
Reaction score
1,294
First Language
Broken English.
Primarily Uses
N/A
Thought about that, but I have several plugins targeted towards parallaxes, so I cannot move my parallaxes without working from scrap.
 

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,227
Reaction score
1,412
First Language
English
Primarily Uses
RMMZ
Having a quick look it looks like the parallaxes are not part of the z layers because they are created separately to the map sprites. I did not want to change how they worked in case it conflicted with other parallax related plugins.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Some local cursed and attacked me because I said children should learn copyright....
I spent a lot of time creating it.
Follow up new work.
With every new day I'm working on more and more exciting stuff, how can I even control my own hype?
Angry kitten at the vet tries to sound scary but not doing a very good job of it.

Forum statistics

Threads
103,127
Messages
997,481
Members
134,600
Latest member
officework123
Top