Galv's Layer Graphics (fogs, parallaxes, mapping)

Papillon

Veteran
Veteran
Joined
Feb 22, 2017
Messages
59
Reaction score
8
First Language
English
Primarily Uses
RMMV
Really fantastic plugin, but I'm getting a weird error. Whenever I use a layer graphic inside a battle and the battle ends the game crashes and I get "TypeError: Cannot read property 'graphic' of undefined". Disabling the layers before the battle ends gets the same result.
I'm not quite sure why this is happening.
 

Eliaquim

Raze: The Rakuen Zero's Guardian!
Veteran
Joined
May 22, 2018
Messages
1,339
Reaction score
591
First Language
Portuguese - Br
Primarily Uses
RMMV
didi you try to use the plugin command to remove the battle layers before the battle ends?
Not sure if I can help you, but I think this error is related to the name of the file layer graphic. It is case-sensitive.
Make sure if everything is correct and if you use plugin commands if you don't do any typos.
Send a screen of the console when the error happens, also helps(press f8 or f12 when the error occurs).
 

Papillon

Veteran
Veteran
Joined
Feb 22, 2017
Messages
59
Reaction score
8
First Language
English
Primarily Uses
RMMV
didi you try to use the plugin command to remove the battle layers before the battle ends?
Not sure if I can help you, but I think this error is related to the name of the file layer graphic. It is case-sensitive.
Make sure if everything is correct and if you use plugin commands if you don't do any typos.
Send a screen of the console when the error happens, also helps(press f8 or f12 when the error occurs).

I'm not quite sure what's causing it.
I've double-checked the script calls to make sure everything is spelled correctly and all the files are correct.
As far as I'm aware there's no conflicts.
It doesn't happen when testing troops in the editor but when a battle finishes in a playtest the game just crashes, so I'm assuming something is happening in the transition from battle to map.
 

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,188
Reaction score
1,148
First Language
English
Primarily Uses
N/A
Does it happen in the demo or fresh project?
 

Papillon

Veteran
Veteran
Joined
Feb 22, 2017
Messages
59
Reaction score
8
First Language
English
Primarily Uses
RMMV
Does it happen in the demo or fresh project?
Same thing is happening in a fresh project so I assume at this point I'm getting the syntax wrong.




 

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,188
Reaction score
1,148
First Language
English
Primarily Uses
N/A
Ah I see - I never tested removing layers in battle. This is indeed a bug and one day (if I ever have time) I will look into it. Immediate solution is not to remove layers mid-battle, they can be added and removed outside of battle
 

Papillon

Veteran
Veteran
Joined
Feb 22, 2017
Messages
59
Reaction score
8
First Language
English
Primarily Uses
RMMV
Ah I see - I never tested removing layers in battle. This is indeed a bug and one day (if I ever have time) I will look into it. Immediate solution is not to remove layers mid-battle, they can be added and removed outside of battle
That's a shame to hear, but thank you for the response and assisting me.
I'll have to find some away around this, but calling layers outside the battle still seems to trigger the same error.
 

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,188
Reaction score
1,148
First Language
English
Primarily Uses
N/A
Hmm, can't get it to happen when modifying layers outside of battle. There's an example of that in the demo.

Edit: (Specially removing layers)
 

Papillon

Veteran
Veteran
Joined
Feb 22, 2017
Messages
59
Reaction score
8
First Language
English
Primarily Uses
RMMV
Hmm, can't get it to happen when modifying layers outside of battle. There's an example of that in the demo.

Edit: (Specially removing layers)
Actually, disregard my last post. That only seems to be a conflict with a plugin I'm using for testing purposes. It works fine otherwise.
 

Chazareth

Veteran
Veteran
Joined
Jul 18, 2016
Messages
134
Reaction score
22
First Language
English
Primarily Uses
RMMV
I was getting an error from the plugin when attempting to transfer the player to another map. I have noticed that this error only occurs when transferring the player using variable coordinates; direct designation transfers work fine. I have only encountered this error recently, so I'm still trying to figure out what changed to cause it now. Any know why variable transfers are causing this?

Edit: It seems like the problem occurs when transferring the player using variable coordinates but the variable designating which map to transfer to is 0. So all I really have to do is just find out why/how that variable is getting set to 0.
 
Last edited:

Eliaquim

Raze: The Rakuen Zero's Guardian!
Veteran
Joined
May 22, 2018
Messages
1,339
Reaction score
591
First Language
Portuguese - Br
Primarily Uses
RMMV
@Chazareth your image has not been attached. Please send a screenshot of the console error and your event with this transfer using the variable.
 

Chazareth

Veteran
Veteran
Joined
Jul 18, 2016
Messages
134
Reaction score
22
First Language
English
Primarily Uses
RMMV
@Chazareth your image has not been attached. Please send a screenshot of the console error and your event with this transfer using the variable.
I took down the screenshot, as I've figured out what the problem was. The plugin wasn't at fault, it was just a messed up variable on my end.
 

Uranium

Game Dev, Pixel Artist
Veteran
Joined
Jan 13, 2017
Messages
89
Reaction score
24
First Language
English
Primarily Uses
RMMV
Hey has anyone have the issue with the layers flickering on screen when you press "z"?

I tried moving tghe plugin order every way possible but still all my layers flicker when using

I am thinking there is a compatibly issue with Mog_ChronoEngine. As the layers from galv's plugin flicker when Attacking/using Tools.
 

Uranium

Game Dev, Pixel Artist
Veteran
Joined
Jan 13, 2017
Messages
89
Reaction score
24
First Language
English
Primarily Uses
RMMV
Compatibility Fix: Galv_LayerGraphics + Mog_ChronoEngine

If you are using this plugin along side Mog_ChronoEngine you may experience your LAYERS from Galv's plugin flickering when using tools,attacking etc.. I believe changing the layer to a higher position, it should fix the issue.

I was having this happen to any layers which I had set to "4" in the note box.

I just double checked and it is 100% fixed! :eswt2:
 

Galv

Veteran
Veteran
Joined
Oct 1, 2012
Messages
1,188
Reaction score
1,148
First Language
English
Primarily Uses
N/A
Also, to add - you can use decimal numbers for the z value.
 

hyperjelly

Warper
Member
Joined
Oct 11, 2019
Messages
3
Reaction score
7
First Language
English
Primarily Uses
RMMV
Is it bad practice that I use this plugin exclusively for all of my mapping? None of my maps are big (max size in my project being 25 x 25 MV tiles, and can't see them getting much bigger than that at all) and I've generally limited myself to around 5 layers p/map.

I just wondered if anyone has any experience of being heavily penalized - performance wise - for just using images for all maps (or any downside, for that matter).
 

Poladead

Villager
Member
Joined
Dec 19, 2018
Messages
29
Reaction score
7
First Language
Italian
Primarily Uses
RMMV
I have 2 questions:

First why does the overlay level (The shadows) offsets by one pixel??? it's set as 0 0 in the map notes.

LAYER_S 2 TwinsHouseOL 0 0 255 5 0 0 0 0 0 this is what I have set in the map notes btw

Second, if the parallax background has ! before the name, shouldn't that stop it from tiling? and yet as you can see it's start tiling on the edges, can anyone help me?
 

Attachments

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Is it strange that dropping acid is improving my game development?
I'm starting to wonder if I should go the Half Minute Hero route with my game. The character's main weapon is logistically way too strong. So I can't really let the player continuously grow it.... But if they had to build it up each time like HMH, that could work. Also it lets me take advantage of my randomly generated maps so much more. Hmm... This could work! :LZSexcite:
std::vector, std::map and std::string. Three reasons why I'd take C++ over C. :D
Today, 1,932 RPG Maker fans died from being too wow'ed. May they rest in peace.

Forum statistics

Threads
99,199
Messages
962,944
Members
130,782
Latest member
rafane
Top