Galv's Region effects glitching??

Discussion in 'RGSSx Script Support' started by The007who, Dec 17, 2016.

Thread Status:
Not open for further replies.
  1. The007who

    The007who Call me double 0s Veteran

    Messages:
    119
    Likes Received:
    80
    First Language:
    Italian
    Primarily Uses:
    RMVXA
    Hi, so I was basically using Galv's region effects and it would start glitching(I think)with modern algebra - fix picture and yanfly - parallax lock.


    Is there any way to fix this? Thanks for reading.


    -The007who
     
    #1
  2. Dreadshadow

    Dreadshadow Lv 38 Tech Magician Moderator

    Messages:
    3,840
    Likes Received:
    2,489
    First Language:
    Greek
    Primarily Uses:
    RMMV


    Yeah, well look. If someone makes a script she or he can not imagine what EVERY other script out there would do and break it. Someone makes a script, designed to be as compatible as possible, but most of the time, some scripts just can NOT coexist. Putting three different scripter's scripts together raise the odds of incompatibilities occuring.


    A script is glitching, when it works wrong alone.


    Thus this is probably not a glitch at all. It is just script incompatibility.


    Did you tested it alone?


    Edit:


    Most of the time people do not make fixes for every possible combination. But if someone actually does make one, it is in a form of a script.
     
    Last edited by a moderator: Dec 17, 2016
    #2
  3. Kes

    Kes Global Moderators Global Mod

    Messages:
    20,970
    Likes Received:
    10,663
    First Language:
    English
    Primarily Uses:
    RMVXA
    I've moved this thread to RGSSx Script Support. Please be sure to post your threads in the correct forum next time. Thank you.



    Links to the particular scripts would make it much easier for people to help you, as would a fuller description of what 'glitch' means.  Is that an error message?  If so, what does it say?  Does the game continue, but with inaccurate data?  Does one prevent the others from working at all?  Or...?


    I use the Yanfly and Modern Algebra scripts you mention, alongside a number of Galv scripts without problems.  I have the Yanfly and MA scripts above all the Galv ones.  Order can be important.  Have you tried changing the order?
     
    #3
  4. The007who

    The007who Call me double 0s Veteran

    Messages:
    119
    Likes Received:
    80
    First Language:
    Italian
    Primarily Uses:
    RMVXA
    Yes, I changed the order but it's still occurring.

    Sorry for my incompetence
     
    #4
  5. Dreadshadow

    Dreadshadow Lv 38 Tech Magician Moderator

    Messages:
    3,840
    Likes Received:
    2,489
    First Language:
    Greek
    Primarily Uses:
    RMMV
    Never had any intention to insult you or make you feel that way mate.


    I just state some facts that  unfortunately ALL of us, including me, learned the hard way. :)


    I couldn't find a good combination of scripts myself on start.


    Sorry if I sounded rude, English is not my native language.
     
    #5
  6. The007who

    The007who Call me double 0s Veteran

    Messages:
    119
    Likes Received:
    80
    First Language:
    Italian
    Primarily Uses:
    RMVXA
    Well, I guess is a 'graphic' glitch.

    No, it's fine :)








    Here's what's happening....
     
    #6
  7. Sixth

    Sixth Veteran Veteran

    Messages:
    2,130
    Likes Received:
    800
    First Language:
    Hungarian
    Primarily Uses:
    RMVXA
    Those are not properly disposed sprites.


    This most probably happens because a script overwrites the method which would trigger the disposal/update method for these sprites.


    I haven't seen a link to the scripts you use, so it might be a good idea to share those links with us now.
     
    #7
  8. Galv

    Galv Veteran Veteran

    Messages:
    1,176
    Likes Received:
    1,115
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    N/A


    My guess would be as some have said above - a script conflict.


    First step is for you to confirm this. Back up your project and test your game removing each script and testing until it works. The last script you removed might be the conflicting one.
     
    #8
  9. Sharm

    Sharm Pixel Tile Artist Veteran

    Messages:
    12,615
    Likes Received:
    10,301
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    The007who, please avoid double posting, as it is against the forum rules.  If you have more to add, use the edit button, if you want to quote multiple people hit the plus button.  I've merged your posts for easier viewing. You can review our forum rules here. Thank you.
     
    #9
  10. The007who

    The007who Call me double 0s Veteran

    Messages:
    119
    Likes Received:
    80
    First Language:
    Italian
    Primarily Uses:
    RMVXA
    I've tried and it seems that the Victor Engine - Anti Lag was the problem.


    Thanks so much!


    -The007who
     
    #10
  11. mlogan

    mlogan Global Moderators Global Mod

    Messages:
    13,847
    Likes Received:
    7,651
    Location:
    Texas
    First Language:
    English
    Primarily Uses:
    RMMV
    This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.
     
    #11
Thread Status:
Not open for further replies.

Share This Page