42ndPotato

Warper
Member
Joined
Dec 2, 2021
Messages
2
Reaction score
2
First Language
English
Primarily Uses
N/A
So a friend of mine has started using MV. She made a test project to see if it could export properly. The game ran okay on her computer. She sent me the game files, but on my computer the Game.exe would not open at all, and I'd get a debug.log file that reads

[1202/004513.039:ERROR:main_dll_loader_win.cc(145)] Failed to load NW DLL from D:\Harry\The Orange World\65.0.3325.146\nw.dll: The specified module could not be found. (0x7E)

Is this a known problem and is there any way to fix it?

I've included a download link to the game files if needed (It won't contain a virus, I swear!):
 
Last edited:

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,647
Reaction score
15,738
First Language
English
Primarily Uses
RMMV

I've moved this thread to MV Support. Thank you.



Are you both using the same OS?
 

zzmmorgan

I've used punchcards
Veteran
Joined
Jul 10, 2020
Messages
168
Reaction score
278
First Language
English
Primarily Uses
RMMZ
Looks like the game folder is missing some files including nw.dll.
Here's what a build folder looks like for me:
Looking in those folders you have I see a lot of other things that are probably missing as well as I see no tilesets unless the map was made without them..
I'd recommend asking them to try to do another build.
And as Shaz mentioned the deployment works best if going from Windows to Windows or Mac to Mac. If you try to target Mac from Windows or the other way around things may not work well.
Also if your friend isn't on the forums here invite them and we can help :)

1638407964794.png
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
3,207
Reaction score
1,894
First Language
English
Primarily Uses
RMMV
Also, just to put it out there, it can reportedly mess things up to use file paths that don't adhere to networking rules.

So have your friend try deploying into a folder that doesn't have spaces in it.
 

42ndPotato

Warper
Member
Joined
Dec 2, 2021
Messages
2
Reaction score
2
First Language
English
Primarily Uses
N/A
[move]MV Support[/move]

Are you both using the same OS?
Yup, we were both using Windows.

Also, just to put it out there, it can reportedly mess things up to use file paths that don't adhere to networking rules.

So have your friend try deploying into a folder that doesn't have spaces in it.
She removed the spaces, and it works now! Files that were missing in the previous version like nw.dll are no longer gone.
 

Latest Threads

Latest Profile Posts

At work.
Co: "This bug drove me insane. I tried a lot of things to debug, it just stuck".
Me: "How did you debug it?"
Co: *shows a complicated debugging method using breakpoints and everything*
Me: "What about ... " *casually prints a stack trace in the try/catch exception
Co: "Wait, you can do that??"
Totally original and unique OC
Harold.png
So after completing the Mass Effect Trilogy the first time as a Vanguard, I decided to replay the trilogy as a Soldier. Thus far, I've just finished the Horizon mission in ME2, and I'm already exhausted from ME2's f**k-awful enemy design.
Yeah, now Yes !!!! "boom boom "
"Fire the monsters, guards!!!"

index.php
I can't stop buying resource packs I'll never use, or engines for that matter, or free resources as my two terabyte external will attest. I am a digital hoarder I guess. Some people get drunk off the silly juice when they are bored, I just buy shiny digital nonsense I don't need.

Forum statistics

Threads
118,651
Messages
1,117,571
Members
155,753
Latest member
Esteblad
Top