Game Scene Stabilizer - Version 7.0.3

TenTranVN

Veteran
Veteran
Joined
Apr 13, 2017
Messages
164
Reaction score
17
First Language
Vietnam
Primarily Uses
RMMV
I have a question ?
If I install the plugin normally, I don't use the plugin command command in the maps, will this plugin help?
For example, I just downloaded the plugin and dropped it into my project and let it be ON normally! Does it give better game performance?
 

Eliaquim

Raze: The Rakuen Zero's Guardian!
Veteran
Joined
May 22, 2018
Messages
957
Reaction score
388
First Language
Portuguese - Br
Primarily Uses
RMMV
I have a question ?
If I install the plugin normally, I don't use the plugin command command in the maps, will this plugin help?
For example, I just downloaded the plugin and dropped it into my project and let it be ON normally! Does it give better game performance?
Yes it will do.
You can notw thw difference putting a autoplay bgm in the map properties.
Then load that map with the plugin and without the plugin to see
 

Oscar92player

Veteran
Veteran
Joined
Jul 26, 2012
Messages
450
Reaction score
199
First Language
Spanish
Primarily Uses
RMMV
@chaucer I was here to say how amazing is the improvement of this plugin with the recent updates, and how admirable was the evolution since the firsts versions. I was using the 3.0.2 version of this plugin on my project, but I recently updated it to v5.5.0 to test it.

With 3.0.2, menus and maps loaded correctly, but with the latest version, they load even better than before. And not only that, the images are not flickering anymore when calling them, and the BGM audio loads noticeably fast.

Thanks for making this!
 

chaucer

Veteran
Veteran
Joined
Aug 6, 2014
Messages
265
Reaction score
407
First Language
English
Primarily Uses
RMMV
@TenTranVN This plugin does not boost performance, it just handles uploading assets to the GPU, which, I guess can help performance on startup times, since the images will be uploaded before the scene starts, instead of after.

Also this plugin will work without calling any preload flags.

By default, all assets that a map needs to run, will be preloaded, I.E. tileset sheets, parllaxes, window skins. However things like faces, pictures, and animations, that will be used through an event, can't be accounted for, and that's where the note tags come in, they allow you to preload( and pre-upload ), resources that aren't automatically loaded into memory.

In battles, it's the same thing, enemies, actors( if using sv battle system ), battleback images, windows, they're all preloaded( and pre-uploaded ), automatically, so there's no need to use note tags for these. Also as an added bonus, I've written in code, that scans every actor/enemy's skills, and preloads( and uploads ), them as well! So no need to preload skills either! However, if you're planning to show an animation that isn't attatched to a skill an enemy/actor has through an event, or plan on showing a face/picture, planning to change the battle backs mid fight, or something of that nature, well, these images would not be preloaded, and that's where the preload note tags would come in. :)

@Eliaquim thanks for notifying me about not updating the title brother ^^; sorry it took me so long to get to it, it's done now though. :D
 

Eliaquim

Raze: The Rakuen Zero's Guardian!
Veteran
Joined
May 22, 2018
Messages
957
Reaction score
388
First Language
Portuguese - Br
Primarily Uses
RMMV
@chaucer hi!
Well, i was using the 5.4.2, so I download the latest version now, and it shows me in the plugin that is the 5.5.0.
I can see that the help file was changed! But i'm not sure if the plugin is the version 5.5.1 yet xD
But thanks anyway!

[EDIT 1 - Solved] There is a way for me to check in the console if the image is preloaded?
Found it! Just type in the console
"ImageManager._imageCache._items"

[EDIT 2]Hi again @chaucer!
That problem that i'm talking with you another day about my custom scene transitions, its happening again. But now it's not with my scene.
It is in a transition between Scene_title to Scene_options or Scene_load in the title commands.

When i disable the plugin, everything is ok.

I made a project for you give a look.
Only your plugin(5.5.0) and Community Basic that i change the cache limit and resolution(1280x720).
Also i change the resolution in package.json to.
Nothing has changed in the core plugins.

Maybe if someone here can test it, it's fine too. Just for me and you to be sure if it is a plugin thing or my computer xD

https://www.dropbox.com/sh/fua7hb2zk8xvrie/AACFkL540kM5XTfzDFQShX57a?dl=0
 
Last edited:

chaucer

Veteran
Veteran
Joined
Aug 6, 2014
Messages
265
Reaction score
407
First Language
English
Primarily Uses
RMMV
@Eliaquim I apologize brother, I'm away at the moment, and won't be back for a while, but when I get back, I'll be sure to check this out.
 

Oscar92player

Veteran
Veteran
Joined
Jul 26, 2012
Messages
450
Reaction score
199
First Language
Spanish
Primarily Uses
RMMV
@chaucer Sorry to bother you, but I need to ask you something about the preload of resources regarding audio files.

It seems that everything is working fine on my computer, when running my project on test mode, and even after deploying it. But, for some reason, when I tried to make it work on another computer (a friend's computer), it seems like the game stucks on a looped loading screen when the preload of those audio files are supposed to happen (when changing maps, or entering a battle, through the notetags).

There's only an error log on the console (I don't recall all what it says) pointing to the "index.html" file, something regarding the audio load. If I turn OFF your plugin, the error dissapears, and the game works fine (excepet for the preload of resources, of course...).

I'm using the latest version of RPG Maker MV, 1.6.2. Like I said, it's an strange issue, since it doesn't happen on my computer, and it's the first time I see an error log pointing directly to the "index.html" file regardind the load of an audio file.
 

kako05

Veteran
Veteran
Joined
Sep 11, 2017
Messages
108
Reaction score
7
First Language
Australian
Primarily Uses
RMMV
Opening various menus stutter them with this plugin making transitions look bad.
 

chaucer

Veteran
Veteran
Joined
Aug 6, 2014
Messages
265
Reaction score
407
First Language
English
Primarily Uses
RMMV
@Oscar92player I'll look into this issue, however If oyu could get me a screenshot of the error that appears on your friends console, that would make things a lot easier for me ^^, if not I'll have to do some experimenting with it.

@kako05 I'm not sure I understand what you mean? Are you saying that menu's stutter when using my plugin? That's rather interesting, I'm unsure what's causing this, as the point of this plugin was to remove the stutter between transitions due to on the fly loading of resources. What version of the game engine are you using? and what version of my plugin as well. I'll Look into this when I have time, unfortunately I'm pretty backed up with various other things at the moment, so I'm unsure when I'll be able to take a look into these issues my apologies. :(
 

kako05

Veteran
Veteran
Joined
Sep 11, 2017
Messages
108
Reaction score
7
First Language
Australian
Primarily Uses
RMMV
Maybe it could be a plugin conflict with galvs preloader? 1.6.2 mv, and I just downloaded the plugin from this thread a few days ago. I've deleted it since then, so not sure what version it was, but should have been the newest one I think.
When I did try opening the menus, the game just froze for a very brief time, milliseconds and instantly the menu was open. There was no transition between the opening, felt sluggish like menu stutters, not smooth. Once I disabled the plugin, the problem was solved.

Could be a plugin incompatibility issue. I use quite a lot.
 

Oscar92player

Veteran
Veteran
Joined
Jul 26, 2012
Messages
450
Reaction score
199
First Language
Spanish
Primarily Uses
RMMV
@Oscar92player I'll look into this issue, however If oyu could get me a screenshot of the error that appears on your friends console, that would make things a lot easier for me ^^, if not I'll have to do some experimenting with it.

@kako05 I'm not sure I understand what you mean? Are you saying that menu's stutter when using my plugin? That's rather interesting, I'm unsure what's causing this, as the point of this plugin was to remove the stutter between transitions due to on the fly loading of resources. What version of the game engine are you using? and what version of my plugin as well. I'll Look into this when I have time, unfortunately I'm pretty backed up with various other things at the moment, so I'm unsure when I'll be able to take a look into these issues my apologies. :(
Thanks for the quick answer, @chaucer, I've been able to take an screen capture of the console when using my friend's computer today, so here you got:


As you can see, this error log points directly to the index.html file, which is a bit curious, because I've never seen that kind of error before. The project runs on RPG Maker MV v1.6.2, with the latest core versions, too.

About the computer, he's using Windows 7 64bit, with all GPU and Sound card drivers updated to the latest version.
 

AdamSakuru

[Null_Value]
Veteran
Joined
Mar 14, 2014
Messages
314
Reaction score
170
First Language
English
Primarily Uses
N/A
Is it possible to add in a plugin command to clear specific images/the whole folder from "system"?
PHP:
command : clear_system FILENAME
Currently it's not in there as a plugin command.
 

chaucer

Veteran
Veteran
Joined
Aug 6, 2014
Messages
265
Reaction score
407
First Language
English
Primarily Uses
RMMV
@Oscar92player thanks for the info brother, although I was wrong in assuming it'd help me debug this as it's only one line ^^; but it does give me some insight into the problem based on the error itself, so that's a +.

@kako05 It may be I'll have to look into this when I get some time, I'll hopefully be able to put out a more well rounded version soon ^^;

@AdamSakuru, when I have time I'll do my best to implement this feature ^^;

Thanks for the feedback and all the replies guys, I'll do my best to get a more stable version out soon.
 

AdamSakuru

[Null_Value]
Veteran
Joined
Mar 14, 2014
Messages
314
Reaction score
170
First Language
English
Primarily Uses
N/A
@chaucer
No problem.
Does this plugin work properly on MV Version 1.6.2?
 

Oscar92player

Veteran
Veteran
Joined
Jul 26, 2012
Messages
450
Reaction score
199
First Language
Spanish
Primarily Uses
RMMV
@chaucer
No problem.
Does this plugin work properly on MV Version 1.6.2?
From my own experience, I can say this plugin works very fine on the latest version of RPG Maker MV, even with a high quantity of plugins installed (Yanfly's, Victor Sant, SumRndmDde, Moghunter, Galv's...), without incompatibilities.

You only have to make sure that all the important files you want to be preloaded are set through notetags on the map properties or even characters (those specially if you want to preload animations, graphics, SE, or special effects for the battles, it will save you from the lag and frame spikes when using animations).
 

AdamSakuru

[Null_Value]
Veteran
Joined
Mar 14, 2014
Messages
314
Reaction score
170
First Language
English
Primarily Uses
N/A
@Oscar92player
The reason I'm asking is because since upgrading my project to Version 1.6.2., I have had some issues with caching.

The first thing I noticed was that the script call I was using to remove specific items currently in the cache no longer seems to function. It kept producing errors because when I would try to call items they would return null (despite being in the cache.) After asking around a bunch without finding an answer, I realized I could use Chaucer's plugin commands to clear things from the cache.
This was the script call I'm referring to:
PHP:
ImageManager.cache._inner["img/pictures/ACCESS.png:0"].free()
I think I noticed that when switching scenes, the cache seems to clear out things from previous scenes. Like I'd have a bunch of pictures cached during a story cutscene, and then a battle during it, and then when it goes back to the story cutscene, when I change one of the images into another image there's a 'flicker' showing that the previously cached image wasn't cached.

There's an invisible non-target-able enemy that hides off to the side in every battle so it can do event related things. I also used Chaucer's note-tag commands to cache some images. This worked fine in previous versions of MV, but on 1.6.2. it seems to cache the images properly right when the battle scene boots up, but then clears those cached things as turn 0 happens. (I tested this out by caching a resource that had nothing to do with the battle scene. The resource would show up when I checked the cache the first time, but not the second time after the player can control the battle menu.)
 

chaucer

Veteran
Veteran
Joined
Aug 6, 2014
Messages
265
Reaction score
407
First Language
English
Primarily Uses
RMMV
@AdamSakuru is Auto Cache Clear disabled in the plugin settings? by default it should be disabled, the only time the cache should clear on scene change( from my plugin ), is when this value is set to true, however, it wouldn't cause the next scenes resources to unload, and they said 1.6.2 was only to match the japanese version, and there was no code change, so perhaps either auto cache clear parameter is on, and not working as I intended it to, which I'll have to look into if that's the case, or there may be a plugin conflict.
 

AdamSakuru

[Null_Value]
Veteran
Joined
Mar 14, 2014
Messages
314
Reaction score
170
First Language
English
Primarily Uses
N/A
@AdamSakuru is Auto Cache Clear disabled in the plugin settings? by default it should be disabled, the only time the cache should clear on scene change( from my plugin ), is when this value is set to true, however, it wouldn't cause the next scenes resources to unload, and they said 1.6.2 was only to match the japanese version, and there was no code change, so perhaps either auto cache clear parameter is on, and not working as I intended it to, which I'll have to look into if that's the case, or there may be a plugin conflict.
Auto Cache clear was never turned on. It's likely an incompatibility, but the question is: why is there only an incompatibility on Version 1.6+ when none of these issues ever occurred on 1.5.2.?

Would you be interested in looking at a copy of my game build so you can see for yourself?
 

chaucer

Veteran
Veteran
Joined
Aug 6, 2014
Messages
265
Reaction score
407
First Language
English
Primarily Uses
RMMV
Yeah, if you could send me a demo, cause I'm not having any issues with this in 1.6.1 myself. if the problem is visible in the demo you send me, then that'd be enough to help me rectify any incompatabilies. :)
 

AdamSakuru

[Null_Value]
Veteran
Joined
Mar 14, 2014
Messages
314
Reaction score
170
First Language
English
Primarily Uses
N/A
Yeah, if you could send me a demo, cause I'm not having any issues with this in 1.6.1 myself. if the problem is visible in the demo you send me, then that'd be enough to help me rectify any incompatibilities. :)
Hey, thanks. I really appreciate that. I imagine this may get a bit complicated, but in any case since you're offering to fix it/troubleshoot for me, I will have to pay you. If it takes more work, I can give you more for it.

I'll DM you later tonight with a copy of my project files. I'll set things up so you can test easily. Keep in mind that when you bring up the console during the battle scene the game is going to SEVERELY LAG, it also seems to lag the console a bit too. (this is because of the number of battle related plugins that I have, however this lag is only an issue on 1.6.2, never occurred with my project on 1.5.2)
 

Users Who Are Viewing This Thread (Users: 0, Guests: 3)

Latest Threads

Latest Profile Posts

I just noticed the minigame challenge. Now considering...
My project just started lagging during battle and I haven't been able to figure out why...
Oh, Google is now warning users against installing extensions on Edge Chromium
on my plate today- animation.
"Your service has been identified as part of an outage. This is expected to be restored by 7pm IN SEVEN DAYS!!!" Guess I won't be around as much over the next week :(

Forum statistics

Threads
94,465
Messages
921,132
Members
124,306
Latest member
vlzvl
Top