Fasoldgames

Veteran
Veteran
Joined
Nov 9, 2016
Messages
147
Reaction score
115
First Language
Dutch
Primarily Uses
Hi,

I have a strange problem. When I start to play test my game, it runs fine at first. The menu opens and closes without delay, and the events run smooth as well.

But then, after some time, the menu starts to open and close with a delay, and a general delay seems to creep into the game play as well.

I did not have this problem earlier, could it be my new videocard I installed recently? Also, I updated to RPG Maker MV version1.5.

Any help would be greatly appreciated! This lag/delay is really annoying!

Best regards,

Fasold
 
Last edited:

Poryg

Dark Lord of the Castle of Javascreeps
Veteran
Joined
Mar 23, 2017
Messages
4,147
Reaction score
10,708
First Language
Czech
Primarily Uses
RMMV
Game Maker version 1.5? But this forum is about rpg maker...
 

Fasoldgames

Veteran
Veteran
Joined
Nov 9, 2016
Messages
147
Reaction score
115
First Language
Dutch
Primarily Uses
Ah, sorry, typo. I meant RPG Maker MV...
 

gstv87

Veteran
Veteran
Joined
Oct 20, 2015
Messages
2,465
Reaction score
1,475
First Language
Spanish
Primarily Uses
RMVXA
make a new map without events and check the performance there.
if it doesn't lag, then you're having too many events running at once, or a parallel event somewhere you didn't check.

if it still lags, there can be a code function running in the background.
drop all the plugins and run a stock game.
if it still lags, it might be your computer.
 

Fasoldgames

Veteran
Veteran
Joined
Nov 9, 2016
Messages
147
Reaction score
115
First Language
Dutch
Primarily Uses
Thanks. I tried everything, but nothing, alas. I find it very strange. It starts allright, but slowly becomes more laggy, especially the menu opening and closing....like something is leaking away...
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,935
Reaction score
14,767
First Language
English
Primarily Uses
RMVXA
Any plug-ins? Someone reported that Yanfly's latest plug-ins uses the wrong command to remove sprites recently (the one they use is supposedly bad at memory leaking), and if that is true, that could be the cause of the memory leak.
 

Fasoldgames

Veteran
Veteran
Joined
Nov 9, 2016
Messages
147
Reaction score
115
First Language
Dutch
Primarily Uses
Tried it on a different computer, no luck. New project, clean room without events, disabling all plug-ins, nothing. Could it be that the 1.5 update has problems?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,692
Reaction score
8,495
First Language
German
Primarily Uses
RMMV
What is your project core version?
You said that your editor is 1.5, but that is not always the same as the version Humber oft your projects core files.

And your description sounds like a memory leak that was fixed with core 1.3 or 1.4 long ago...
 

Fasoldgames

Veteran
Veteran
Joined
Nov 9, 2016
Messages
147
Reaction score
115
First Language
Dutch
Primarily Uses
I apparently did not update properly. Did it now though, and there is still lag. Also, several plugins have now been broken...

I don't suppose there is a way to download and install RPG Maker MV 1.4?
 

Latest Threads

Latest Profile Posts

Sneak peak of my upcoming update! Who's holding her, you may ask? Find out tonight!
10.PNG
BCj
Finished another GUI! Turn indicator wasn't made by me.

ff981f8dc50b03cf58038c644334b454.jpg


3cb092fdc00087acfa0a190fd891f0ed.jpg
Added a small refining scene to my game.

It makes sense that you try to focus on the squishy mages at the back of the party first, right? If the mage can out-DPS the enemy DPS before the latter can kill the tank in front, the fight becomes boring.

Forum statistics

Threads
115,248
Messages
1,088,356
Members
149,847
Latest member
Diskidd
Top