Status
Not open for further replies.

Tsukihime

Veteran
Veteran
Joined
Jun 30, 2012
Messages
8,564
Reaction score
3,912
First Language
English
Whenever I hit test play the game takes a fairly long time to load.

Is this normal? Unlike Ace, where it starts like 2-3 seconds, I'm waiting probably up to 6-7 seconds.
 
Last edited by a moderator:

Necromus

Veteran
Veteran
Joined
Mar 14, 2012
Messages
490
Reaction score
64
First Language
German
Primarily Uses
Yeah, it is normal on Win 7 afaik.

It was always horible slow for me, but i've seen videos where even VX is fast, most likely on XP, maybe Vista (tho i really doubt that lol).
 

Tsukihime

Veteran
Veteran
Joined
Jun 30, 2012
Messages
8,564
Reaction score
3,912
First Language
English
It's pretty much the same for me on XP and Vista as well.

Oh well, guess there's another reason why Ace is better lol
 

Necromus

Veteran
Veteran
Joined
Mar 14, 2012
Messages
490
Reaction score
64
First Language
German
Primarily Uses
Thats definitely the first thing you really notice yeah, its a major difference.

But it is fast for some people on XP, its not always slow.

Check GubiD's RGSS videos on youtube, when he playtests, it feels like Ace.
 

Indinera

Indie Dev
Veteran
Joined
Mar 13, 2012
Messages
2,303
Reaction score
1,052
First Language
French
Same experience for me, VX games take forever to load. XP ones don't do that though. :D
 

RyanA

Happy Cat
Veteran
Joined
Jun 28, 2012
Messages
2,423
Reaction score
230
First Language
English
Primarily Uses
Aye I noticed that, I assumed it was something wrong with my taplop since it didn't do it anywhere else, at least I know I don't need to scrap it x3
 

Necromus

Veteran
Veteran
Joined
Mar 14, 2012
Messages
490
Reaction score
64
First Language
German
Primarily Uses
Same experience for me, VX games take forever to load. XP ones don't do that though. :D
Win XP, not RPG Maker XP, RMXP was fast too yea.

Just VX seems (for some people) to run fast on Win XP, but its slooooooow on Win 7.
 

Mr. Bubble

Makes stuff.
Member
Joined
Mar 1, 2012
Messages
853
Reaction score
164
I'm using Win7 as well.

I'd imagine at least part of the reason is because VX forcibly initializes MIDIs on start up (you don't have the choice not to). I know that in Ace, whenever "Initialize MIDI on startup" is checkmarked under the Systems tab in the database, loading the game takes significantly longer than if the box is not checkmarked.
 

Necromus

Veteran
Veteran
Joined
Mar 14, 2012
Messages
490
Reaction score
64
First Language
German
Primarily Uses
Oh good catch, even the tooltip in Ace confirms that.

"It will take some time with OSes from Windows Vista and later if this is enabled"
 

Ocedic

Dog
Veteran
Joined
Jul 13, 2012
Messages
396
Reaction score
67
Primarily Uses
Yeah the MIDI initialization is a big problem. There's an FMOD script somewhere and in the future if I make another game with MIDI's, I would use FMOD instead to avoid the startup issue. Now I'm deep in my project so I don't want to use a different audio system.
 

Tsukihime

Veteran
Veteran
Joined
Jun 30, 2012
Messages
8,564
Reaction score
3,912
First Language
English
If I remove all of the midi's from the project would it still try to initialize midi's?
 

Mr. Bubble

Makes stuff.
Member
Joined
Mar 1, 2012
Messages
853
Reaction score
164
Most likely. Ace doesn't have MIDIs in its RTP (thank goodness), but still requires significant time to load when MIDI initialization is checked.

Edit: They both use the same MIDI synthesizer, DirectMusic.
 
Last edited by a moderator:

PixelPusher

Villager
Member
Joined
Jun 17, 2014
Messages
5
Reaction score
2
First Language
english
Primarily Uses
I hope I'm not out of line posting here in a very old thread. Since my concern is about the topic I'd like to chime in.

I am using Win7 x64 and my game started taking 20-30 seconds to load the title screen. (it loaded very quickly normally) The last recent time I tried it took over 1 minute, litteraly.

I did some checking and the project was being loaded from the cloud and it appears that's why it was taking so long. I then deleted my cloud data and the game started up, and saved quite speedy. So, in my case running the game from the Cloud caused the slow loading of my game.

But now for some reason only after importing a few tilesets the games very laggy. That's another topic.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
36,299
Reaction score
9,704
First Language
German
Primarily Uses
RMMV
@PixelPusher:


If you have a problem, please start a new topic. What you have said here has nothing to do with the original topic, because there is no steam version or cloud saves for VX.


This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.
 
Last edited by a moderator:
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

Made this simple Training Dummy :D

obraz_2022-07-01_095700524.png
I'm still undecided weather or not I should add minor swearing to my game. Like I'm going for an all ages demographic... but the idea of a cartoon character saying dammit, hell, or crap in normal conversation is really funny to me.
If we assume an Elf's strong suit is Dexterity (AGI) & Intellect (MAT), I imagine Strength (ATK) & Constitution (DEF) would be among their lowest stats. But I'm having a hard deciding which should be lower, Strength or Constitution?
I'm really sorry to have to do this, but I'm going to have to start blocking those who repeatedly put up sexual content and offer absolutely nothing (that I've seen) related to what this community is supposedly created for.
Don't take it personal. I'm a rape victim with permanent injuries who can never enjoy 'it' ever again, so it's the last thing I want to have put in my face. :(
Check out my side project! It's a survival dungeon crawler! https://voidmoon-studio.itch.io/depths-of-delmora

Forum statistics

Threads
123,215
Messages
1,154,978
Members
161,599
Latest member
Yochar
Top