Game Title Issues

Samael589

Villager
Member
Joined
Jan 8, 2020
Messages
15
Reaction score
0
First Language
English
Primarily Uses
RMMV
Greetings and Salutations all.

I am pretty new to using RPG Maker MV, so have been mostly following along where I need to
from YouTube videos and finding answers in forums like this one. But I have come across an
issue I can't really find a reason for. My title when I load a play test every time his choppy,
not all there and regardless if I change the font or even the name, it remains having this issue.
I am not running any plungins, never knew how those work so only have the two that came
with my RPGMaker MV version.

Any advice for a greenhorn? My best fwend and I are sorta doing this just for something decent
to try our hands at :rswt
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,354
Reaction score
14,060
First Language
English
Primarily Uses
RMVXA

I've moved this thread to MV Support. Please be sure to post your threads in the correct forum next time. Thank you.

 

Samael589

Villager
Member
Joined
Jan 8, 2020
Messages
15
Reaction score
0
First Language
English
Primarily Uses
RMMV
[MOVE]MV Support[/MOVE]
Gratitude because I went through the list of places to post and couldn't
for the life of me figure out where to put it :aswt:
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,709
Reaction score
7,365
First Language
German
Primarily Uses
RMMV
we can't help you without more info.
can you give us a screenshot of your title screen so that we can see what you're talking about?

please use alt-prtscrn for the screenshot, no need to see your entire desktop...
 

Samael589

Villager
Member
Joined
Jan 8, 2020
Messages
15
Reaction score
0
First Language
English
Primarily Uses
RMMV
Title Issues.png
Your hotkeys didn't work on my laptop but here's the printscreen/screenshot as you asked.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,709
Reaction score
7,365
First Language
German
Primarily Uses
RMMV
At first guess I would say that this is a problem with the font file - what happens if you go back to the default font?
 

Samael589

Villager
Member
Joined
Jan 8, 2020
Messages
15
Reaction score
0
First Language
English
Primarily Uses
RMMV
Ironically I thought that too, but changing it back does nothing.
I was using the original font until I just relearned how to change
it and succeeded. Changing it back literally has the same result
and error.
 

gstv87

Veteran
Veteran
Joined
Oct 20, 2015
Messages
2,216
Reaction score
1,190
First Language
Spanish
Primarily Uses
RMVXA
the font should be the same for the menu and the title, so if one has a problem, the other should as well....

judging by the fact that some of it cuts "behind" the background, it looks like an alpha problem.

try changing it not to the default font but to something else, preferably a default system font, which should be certified to work (Arial, Tahoma, Times, System, etc)
just grab a .TTF file from your system's Font folder, copy it over to your game folder, and change it via code.

I believe I've seen this particular problem before (very likely in MV as well) but I can't remember what it was.
I do see this often in 3D modelling, when two faces overlap in the same space.... but I don't know how that can relate to this, other than maybe two overlapping instances of the title?
if changing the font doesn't do anything, then the actual block drawing the title must be the problem, because the menu looks fine
 

Samael589

Villager
Member
Joined
Jan 8, 2020
Messages
15
Reaction score
0
First Language
English
Primarily Uses
RMMV
the font should be the same for the menu and the title, so if one has a problem, the other should as well....

judging by the fact that some of it cuts "behind" the background, it looks like an alpha problem.

try changing it not to the default font but to something else, preferably a default system font, which should be certified to work (Arial, Tahoma, Times, System, etc)
just grab a .TTF file from your system's Font folder, copy it over to your game folder, and change it via code.

I believe I've seen this particular problem before (very likely in MV as well) but I can't remember what it was.
I do see this often in 3D modelling, when two faces overlap in the same space.... but I don't know how that can relate to this, other than maybe two overlapping instances of the title?
if changing the font doesn't do anything, then the actual block drawing the title must be the problem, because the menu looks fine
Aye I've seen it in some RPGs I have gotten from other developers to
play and downloaded, it happens sometimes but the menu as you saw
has no issue nor does any other text. I tried that TTF file extension
but it doesn't apply, because none of the text font files even the one
with the systems are TTF the are instead OTF.

I have no experience coding at all, it's something I have yet to try
my hand at and probably won't succeed in as whilst I am tech inclined,
my skills for code are as of yet, zero from what I know.

If you wish I can still try it out with the TTF file from my system fonts,
but they are all from what I recall the same OTF extention, always have
been- wait ah no no they're not. :aswt:

The menu in game has no issues nor do any of the scenes I have thus far
tried including battling scenes, so I am unaware of the issue as I said but
I can always try....

And that is a negative on that working. It has the exact same error as the
other fonts I used.

1578526752121.png
 

gstv87

Veteran
Veteran
Joined
Oct 20, 2015
Messages
2,216
Reaction score
1,190
First Language
Spanish
Primarily Uses
RMVXA
then the error is an overlay or a render issue.

double check that you don't have a duplicate call to draw that title.
look for drawGameTitle, or gameTitleSprite.bitmap.drawText

>Quicker than that: what happens if you disable the background picture?
 

Samael589

Villager
Member
Joined
Jan 8, 2020
Messages
15
Reaction score
0
First Language
English
Primarily Uses
RMMV
then the error is an overlay or a render issue.

double check that you don't have a duplicate call to draw that title.
look for drawGameTitle, or gameTitleSprite.bitmap.drawText

>Quicker than that: what happens if you disable the background picture?
And where would a greenhorn like myself find these things please?
I am truly not that far into my indroduction to this software or even
game development :aswt:
 

gstv87

Veteran
Veteran
Joined
Oct 20, 2015
Messages
2,216
Reaction score
1,190
First Language
Spanish
Primarily Uses
RMVXA
go into the database and remove the background picture.

for the code, use a code editor like notepad++ and do a wide search for those strings within the whole set of .js files.
three results should come up: the definition for drawGameTitle, the call to drawGameTitle, and the call to gameTitleSprite.bitmap.drawText (itself, *within* drawGameTitle)
more than that, would be duplicated.
 

Samael589

Villager
Member
Joined
Jan 8, 2020
Messages
15
Reaction score
0
First Language
English
Primarily Uses
RMMV
And how does one use a code editor :aswt: see I am unaccustomed to not
knowing at least a little but this, this is all new ground to me. I checked
the games .js files folder however, found none of those title things, no
drawGame Title, no call to draw, or the gameTitleSprite, but then its
probably in the code and now I just have to figure out how to find that.

I just downloaded notepad++ so now I am really a greenhorn.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,709
Reaction score
7,365
First Language
German
Primarily Uses
RMMV
it might also be a driver problem.
can you test the project on a different computer? If it works at another computer you'll have to check the drivers on this computer. If the other computer has the same problem it's unlikely to be a driver problem (unless both computers are identical, for example purchased from the same production series).
 

Samael589

Villager
Member
Joined
Jan 8, 2020
Messages
15
Reaction score
0
First Language
English
Primarily Uses
RMMV
it might also be a driver problem.
can you test the project on a different computer? If it works at another computer you'll have to check the drivers on this computer. If the other computer has the same problem it's unlikely to be a driver problem (unless both computers are identical, for example purchased from the same production series).
That's unlikely, one's a six year old Toshiba and the other is a newer HP.
I did try that theory but doesn't seem to help it from what I recall. Had
this issue months ago when I first began, only picking it up and trying
game creation again now because I got the time and nothing else to do
save talking to my Lieutenant, my best fwend I spend near enough every
day talking with.

If I can learn to code or figure out how that works, it could be quite
useful though. I wish I had a coder's mind but I am more suited to other
parts of computer work :aswt:

New information:

I think it's another issue I am not aware of. I just tested the game after
removing the background image and it's still not perfect:

1578530790856.png
 

gstv87

Veteran
Veteran
Joined
Oct 20, 2015
Messages
2,216
Reaction score
1,190
First Language
Spanish
Primarily Uses
RMVXA
still not what I had expected, but still keeps me looking towards an overlay problem.

the only difference between the game title and the menu, is that the game title is a simple sprite.
but, at it's core, the menu window ALSO is a sprite, so if it was a sprite problem, both should have it.
even more, the window should doubly have it because the cursor is a transparent sprite.

try this:
find this block in rpg_scenes.js, and add that single line as it is.

nuevo-1.jpg

if it still fails, then I'm clueless.
it might still have duplicated calls, so, do a search like I told you and make sure that call to drawGameTitle is the only one.
if nothing turns up, and that Z change doesn't fix it, it might be a video driver problem.
which, is weird, because the same video card is rendering the same objects across the screen and one is failing and the other is not.
 

Samael589

Villager
Member
Joined
Jan 8, 2020
Messages
15
Reaction score
0
First Language
English
Primarily Uses
RMMV
I just added the line in exactly as you posted above, so now just to test it..
Wow now it's back to the old error it had before :aswt2:

see for yourself down below

1578540428279.png
as you can see below I did everything you told me to

1578540451573.png

Originally it didn't have that gameTitleSprite before I put the .z = 200. So I am at
a loss. The first time I tried out this thing, it never had a single issue, then there
was a font issue and now it doesn't like font point blank apparently as concerns
the title.

As concerns the drawGameTitle, those two are the only ones in the entire .js file
of scenes.
 
Last edited:

gstv87

Veteran
Veteran
Joined
Oct 20, 2015
Messages
2,216
Reaction score
1,190
First Language
Spanish
Primarily Uses
RMVXA
Wow now it's back to the old error it had before :aswt2:
indeed, and that could mean something, but my brain is running on fumes right now.
if an error repeats, it's a pattern, and if it's a pattern it can be tracked.

@Poryg might know something about MV's graphical section, maybe?
 

Samael589

Villager
Member
Joined
Jan 8, 2020
Messages
15
Reaction score
0
First Language
English
Primarily Uses
RMMV
There's no real rush honest. All I am attempting to do is learn what does
what, because my Lieutenant and I had the idea of a game where you can
capture almost anything available within reason :biggrin: :aswt: if I can
figure out how to create an item that can be used in place of a pokeball,
or even change one of those and the entire capture thing, then it'll be
progress but you gotta walk before you can fly :smile:
 

Poryg

Dark Lord of the Castle of Javascreeps
Veteran
Joined
Mar 23, 2017
Messages
4,122
Reaction score
10,614
First Language
Czech
Primarily Uses
RMMV
Please hit F2 in game and see the small FPS window that pops out. At the bottom of the window there should be "Canvas mode" or "WebGL mode". Screenshot_152.png
If you see WebGL mode, please go to the plugin manager in the editor (F10) and inside Community basic plugin change the render mode from "auto" to "canvas". If that fixes the text, then it's clear your GPUs don't support WebGL well enough. Considering the age of your computers I'm leaning towards this as a possibility.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

12 done, 4-5 started. Now that the weekend is over, things will sloooowwwww down again proabably.
when you're completely done with someone's crap lol...
Ami
--- Survival For RPGist Part 3 ---

F.Healer: Here it is,I made the Simple Sandwich
Survivalist
: it's so Delicious!
Chef: Here you Go! My Gourmet Steak.
Survivalist: It's Super Delicious,Too!
F.Mage: I Made it for you!
F.Healer: Uhh...Charcoal?
F.Mage No,It's a Toast!
Chef: Did you Let it in 10 Minutes?
F.Mage: Maybe?

Forum statistics

Threads
103,032
Messages
996,810
Members
134,507
Latest member
juegostudios
Top