Games no longer load as of just now

JohnDoeNews

Mod on Steam (MV/MZ)
Veteran
Joined
Apr 25, 2017
Messages
1,539
Reaction score
1,138
First Language
Dutch
Primarily Uses
RMMV
I always have auto updates turned off. When a new update comes out, I always wait a day or too, and if there is still no reports of major problems, I update manually. I remember the problems back in MV. 1.6.1 if I'm not mistaken.

Updating manually also prevents the software to update when I just want to use it. I don't want to wait.
 

Synchromystic

Make RPG's Great Again
Veteran
Joined
Mar 22, 2018
Messages
71
Reaction score
22
First Language
English
Primarily Uses
RMMZ
That worked for me too, thanks everybody! I've seen more mentions about it in the comments on the Steam page as well, so I'm sure they'll get to work on fixing it soon.
 

JohnDoeNews

Mod on Steam (MV/MZ)
Veteran
Joined
Apr 25, 2017
Messages
1,539
Reaction score
1,138
First Language
Dutch
Primarily Uses
RMMV
There too I told people to roll back. I'm surprised not more people thought of this, since we had a similar problem with MV back then. Anyhow, I'm glad it solves the issue for most people.
 

SeaPhoenix

Veteran
Veteran
Joined
May 14, 2015
Messages
400
Reaction score
508
First Language
English
Primarily Uses
RMMV
So I saw on Steam that the developers released 1.6.1 that rolls back NW.js to the earlier version. However, because 1.6.0 works for me (I'm on Windows 10 too), I was wondering if my deployed game using 1.6.0 would work for those who had problems with it.

I made a new project using 1.6.0 and uploaded it to Itch, so if those of you on Windows (@GreenerPastures, @Gong77, @tinkie99 and anyone else) would like to test it and let us know if it loads and whether you can start a new game, that might be useful information.
https://seaphoenix.itch.io/testrmmz

The password is "rmmz" without the quotation marks.

Thanks!
 

JohnDoeNews

Mod on Steam (MV/MZ)
Veteran
Joined
Apr 25, 2017
Messages
1,539
Reaction score
1,138
First Language
Dutch
Primarily Uses
RMMV
So I saw on Steam that the developers released 1.6.1 that rolls back NW.js to the earlier version. However, because 1.6.0 works for me (I'm on Windows 10 too), I was wondering if my deployed game using 1.6.0 would work for those who had problems with it.

I made a new project using 1.6.0 and uploaded it to Itch, so if those of you on Windows (@GreenerPastures, @Gong77, @tinkie99 and anyone else) would like to test it and let us know if it loads and whether you can start a new game, that might be useful information.
https://seaphoenix.itch.io/testrmmz

The password is "rmmz" without the quotation marks.

Thanks!
Why not just upgrade to 1.6.1, though? That should fix it all, for all your players.
 

SeaPhoenix

Veteran
Veteran
Joined
May 14, 2015
Messages
400
Reaction score
508
First Language
English
Primarily Uses
RMMV
@JohnDoeNews Because I think more information could be useful - for example, is it the newer version of NW.js itself that's the issue, or the editor's interaction with NW.js. In addition, for people who update NW.js on their own and the game works on their computer but they find out it doesn't for some people but have no idea why, this may be a useful point for troubleshooting.
 

GreenerPastures

Villager
Member
Joined
Jun 27, 2021
Messages
8
Reaction score
7
First Language
English
Primarily Uses
RMMZ
So I saw on Steam that the developers released 1.6.1 that rolls back NW.js to the earlier version. However, because 1.6.0 works for me (I'm on Windows 10 too), I was wondering if my deployed game using 1.6.0 would work for those who had problems with it.

I made a new project using 1.6.0 and uploaded it to Itch, so if those of you on Windows (@GreenerPastures, @Gong77, @tinkie99 and anyone else) would like to test it and let us know if it loads and whether you can start a new game, that might be useful information.
https://seaphoenix.itch.io/testrmmz

The password is "rmmz" without the quotation marks.

Thanks!

Gave it a shot, and no dice on loading this test game.

Did just pick up the new MZ version, though, and it looks like the issue is rectified for me. Hopefully the same goes for everyone else who had trouble. Appreciate y'all helping out in the interim!
 

Synchromystic

Make RPG's Great Again
Veteran
Joined
Mar 22, 2018
Messages
71
Reaction score
22
First Language
English
Primarily Uses
RMMZ
So where can we find the 1.6.1 release? I'm still not seeing anything beyond 1.6.0
 

Synchromystic

Make RPG's Great Again
Veteran
Joined
Mar 22, 2018
Messages
71
Reaction score
22
First Language
English
Primarily Uses
RMMZ
Hmm... Wonder if they handle Mac separately, because it's not available for me.
 

caethyril

^_^
Global Mod
Joined
Feb 21, 2018
Messages
4,338
Reaction score
3,375
First Language
EN
Primarily Uses
RMMZ
I hunted around a bit and turned up something in the release notes for NW 0.59.1 about it fixing a "not launching on some systems" bug. Apparently it was related to a dependence on an MSVC (a.k.a. Microsoft Visual C++) redistributable:
No idea if 0.69.1 had a similar problem, but I thought I'd mention it here since SeaPhoenix has put together a test case.

Edit: that test case runs OK for me, but like auradev, I also had no issues with MZ 1.6.0.
 
Last edited:

auradev

Veteran
Veteran
Joined
Feb 11, 2021
Messages
38
Reaction score
16
First Language
German
Primarily Uses
RMMZ
So I saw on Steam that the developers released 1.6.1 that rolls back NW.js to the earlier version. However, because 1.6.0 works for me (I'm on Windows 10 too), I was wondering if my deployed game using 1.6.0 would work for those who had problems with it.

I made a new project using 1.6.0 and uploaded it to Itch, so if those of you on Windows (@GreenerPastures, @Gong77, @tinkie99 and anyone else) would like to test it and let us know if it loads and whether you can start a new game, that might be useful information.
https://seaphoenix.itch.io/testrmmz

The password is "rmmz" without the quotation marks.

Thanks!
I was able to run it. However, I also had no issues with 1.6.0.
Very disappointing to hear that the solution for 1.6.1 was to downgrade nwjs again.

I could also deliver a manually upgraded nwjs but that won't make sense as long as the original problem persists.
 

SeaPhoenix

Veteran
Veteran
Joined
May 14, 2015
Messages
400
Reaction score
508
First Language
English
Primarily Uses
RMMV
Thanks for testing and providing your feedback, @GreenerPastures, @caethyril and @auradev! Since the test game didn't work on @GreenerPastures's computer, it definitely sounds safer to revert back to the original version of NW.js (i.e., upgrade to 1.6.1). Hopefully, this also helps those who are thinking of updating NW.js manually to weigh the pros and cons of doing so.
 

Synchromystic

Make RPG's Great Again
Veteran
Joined
Mar 22, 2018
Messages
71
Reaction score
22
First Language
English
Primarily Uses
RMMZ
Here we are a day later, and I still don't see a version 1.6.1 anywhere... Just to clarify for myself:
Is it supposed to be in the Update Corescript menu after we go back to the 1.6.0 Beta? I don't see it there, or in the Open Beta, and I don't know where else to look...Screen Shot 2022-12-09 at 9.59.18 AM.png
 

caethyril

^_^
Global Mod
Joined
Feb 21, 2018
Messages
4,338
Reaction score
3,375
First Language
EN
Primarily Uses
RMMZ
v1.6.1 is the current version:
  • Steam Library -> RPG Maker MZ -> right-click -> Properties -> Betas -> None.

You can check the editor version via Help -> About from the editor's menu bar.

MZ 1.6.1 uses the same core scripts as v1.6.0. The only difference is that it uses NWJS v0.49.4 rather than v0.69.1 for playtest and Windows/Mac deployment.
 

Synchromystic

Make RPG's Great Again
Veteran
Joined
Mar 22, 2018
Messages
71
Reaction score
22
First Language
English
Primarily Uses
RMMZ
Kind of figured it out myself just a second before seeing your response... But I still would've been confused, because judging from that update menu option, it looks to me like I'm still on 1.6.0, except for the fact that it's working for me now.
 

Attachments

  • EZJmA9TXsAIOk4A.jpg
    EZJmA9TXsAIOk4A.jpg
    68.1 KB · Views: 1
Last edited:

JohnDoeNews

Mod on Steam (MV/MZ)
Veteran
Joined
Apr 25, 2017
Messages
1,539
Reaction score
1,138
First Language
Dutch
Primarily Uses
RMMV
I hunted around a bit and turned up something in the release notes for NW 0.59.1 about it fixing a "not launching on some systems" bug. Apparently it was related to a dependence on an MSVC (a.k.a. Microsoft Visual C++) redistributable:
No idea if 0.69.1 had a similar problem, but I thought I'd mention it here since SeaPhoenix has put together a test case.

Edit: that test case runs OK for me, but like auradev, I also had no issues with MZ 1.6.0.

Ah. So, even though some devs got so angry at the RPG Maker team (on steam), it wasn't even their mistake.

Glad it had been solved.
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
6,947
Reaction score
4,789
First Language
English
Primarily Uses
RMMV
Ah. So, even though some devs got so angry at the RPG Maker team (on steam), it wasn't even their mistake.
Well, I wouldn't say that people should be getting angry over things like this. Mistakes in updates happen and it was fixed very quickly.

However, the devblog that caethyril linked to is a year old, so it's not exactly an unknown issue if you're doing work with the software.
 

Latest Threads

Latest Posts

Latest Profile Posts

Now that I have linklists on large trees and cars, is there any theme that would interest you?
Debugging multiplayer issues... I'm having fun, right?
yay_streaming.jpg

For just starting streaming on the 10th... Definitely not the worst. :LZScheeze:

Granted I need 333.34 hours a month on average to achieve money. So I don't really expect that, but it sure has helped my game dev go much faster.
Proud on how this map turned out.

FnmhDLIXgAAOvIC
I just finally fixed a huge problem that wouldn’t let my game load and would crash it.. I thought that I was gonna have to trash the project and start over lol

Forum statistics

Threads
128,328
Messages
1,193,648
Members
168,813
Latest member
jasper1hu
Top