glitch related to image change

busbuzz

Veteran
Veteran
Joined
Jun 17, 2021
Messages
164
Reaction score
34
First Language
English
Primarily Uses
RMMZ
i don't know if this is the right place but i can't find where to ask this about rpg maker mz.

so... when i'm eventing and use the "set movement route" of an event to "change the image" of the event so that i can have animated stuff there is a 1 frame glitch that shows to the upper left side of the event. Is there a way to fix this?

the glitch happens exactly when the image changes and it sometimes happens and sometimes it doesn't happen.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,313
Reaction score
15,147
First Language
English
Primarily Uses
RMMV

Moving to MZ Support



I think this might need a bit of troubleshooting & testing, before we assume it's an MZ bug. Also here it will be seen by people more quickly, as there is only one person who approves the feedback posts.

If it were a bug I'd expect it to happen consistently. When you say sometimes but not others, is there any pattern? Does it always happen at certain times, or with certain sprites? Is there anything you can do to make it happen reliably, even on a single event? If so, please tell us about the image you're switching to and show us a screenshot of your event with the command visible.

Is there a lot of stuff going on when it happens? Does your frame rate drop at these times? Are you using default sprites or imported/custom sprites?

What do you mean by "a 1 frame glitch that shows to the upper left side of the event"? Does it look like a frame that is in another row or column of the spritesheet that is being used, either before or after the image change? Can you show us the spritesheet and highlight which images you are seeing? I wonder if it's because of the direction your character is facing when you execute this command ...
 

busbuzz

Veteran
Veteran
Joined
Jun 17, 2021
Messages
164
Reaction score
34
First Language
English
Primarily Uses
RMMZ
Thank you shaz.

I'm using custom tiles and character sprites.

When I say it sometimes happens is because even in the same part of the cutscene it may not happen. So my guess is that it's some kind of loading problem. It happens too quickly to screenshot.

For just about a frame, when I switch from one spritesheet to another I can see a part of the sheet appearing to the upper left side of the event changing. Just before changing to the correct sprite.

I have no idea how to test frame rate
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,313
Reaction score
15,147
First Language
English
Primarily Uses
RMMV
Hitting F2 will show your frame rate in the top left corner.

Can you take a video?
 

busbuzz

Veteran
Veteran
Joined
Jun 17, 2021
Messages
164
Reaction score
34
First Language
English
Primarily Uses
RMMZ
Ok I did my best for the video. Sorry for the low quality
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,313
Reaction score
15,147
First Language
English
Primarily Uses
RMMV
Yeah, I see it. Can you share the sprite, and show the event? Include the whole event window, not just the event commands. Make sure the move route is visible too.

Or you can zip up your project and send it to me and I'll take a look.
 

busbuzz

Veteran
Veteran
Joined
Jun 17, 2021
Messages
164
Reaction score
34
First Language
English
Primarily Uses
RMMZ
how can i send it privately?
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,313
Reaction score
15,147
First Language
English
Primarily Uses
RMMV
zip up your project and find somewhere to load it online (dropbox, whatever). Then send me a pm with the link.
 

busbuzz

Veteran
Veteran
Joined
Jun 17, 2021
Messages
164
Reaction score
34
First Language
English
Primarily Uses
RMMZ
Ok, so your solution to the problem did work. But, it's still a bug. there is one frame glitch when there is a change from one sprite sheet to another one. There is a way around it, but the bug is still there. What Shaz told me to do is not to use individual spritesheets and have an 8 sprite sheet instead so that it doesn't load a new sheet and that does avoid the glitch. My problem solved. Thank you so much
 

Latest Threads

Latest Posts

Latest Profile Posts

Noriko_Human.png
Worked on some face-sets. Need to finish up the lot and cut some out of the game. She's looking pretty cute.
Even though I'm not going for the first time in...ten years or something...ordered my Gen Con dice!
Will be focusing on map making today and adding locked chests :LZSsmile:Screenshot 2021-09-16 095316.png
It's hard to stay consistent for at least a week
new enemies for the game I'm working on...

Forum statistics

Threads
115,106
Messages
1,087,257
Members
149,571
Latest member
remmy
Top