glitch related to image change

busbuzz

Veteran
Veteran
Joined
Jun 17, 2021
Messages
168
Reaction score
36
First Language
English
Primarily Uses
RMMZ
i don't know if this is the right place but i can't find where to ask this about rpg maker mz.

so... when i'm eventing and use the "set movement route" of an event to "change the image" of the event so that i can have animated stuff there is a 1 frame glitch that shows to the upper left side of the event. Is there a way to fix this?

the glitch happens exactly when the image changes and it sometimes happens and sometimes it doesn't happen.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,415
Reaction score
15,214
First Language
English
Primarily Uses
RMMV

Moving to MZ Support



I think this might need a bit of troubleshooting & testing, before we assume it's an MZ bug. Also here it will be seen by people more quickly, as there is only one person who approves the feedback posts.

If it were a bug I'd expect it to happen consistently. When you say sometimes but not others, is there any pattern? Does it always happen at certain times, or with certain sprites? Is there anything you can do to make it happen reliably, even on a single event? If so, please tell us about the image you're switching to and show us a screenshot of your event with the command visible.

Is there a lot of stuff going on when it happens? Does your frame rate drop at these times? Are you using default sprites or imported/custom sprites?

What do you mean by "a 1 frame glitch that shows to the upper left side of the event"? Does it look like a frame that is in another row or column of the spritesheet that is being used, either before or after the image change? Can you show us the spritesheet and highlight which images you are seeing? I wonder if it's because of the direction your character is facing when you execute this command ...
 

busbuzz

Veteran
Veteran
Joined
Jun 17, 2021
Messages
168
Reaction score
36
First Language
English
Primarily Uses
RMMZ
Thank you shaz.

I'm using custom tiles and character sprites.

When I say it sometimes happens is because even in the same part of the cutscene it may not happen. So my guess is that it's some kind of loading problem. It happens too quickly to screenshot.

For just about a frame, when I switch from one spritesheet to another I can see a part of the sheet appearing to the upper left side of the event changing. Just before changing to the correct sprite.

I have no idea how to test frame rate
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,415
Reaction score
15,214
First Language
English
Primarily Uses
RMMV
Hitting F2 will show your frame rate in the top left corner.

Can you take a video?
 

busbuzz

Veteran
Veteran
Joined
Jun 17, 2021
Messages
168
Reaction score
36
First Language
English
Primarily Uses
RMMZ
Ok I did my best for the video. Sorry for the low quality
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,415
Reaction score
15,214
First Language
English
Primarily Uses
RMMV
Yeah, I see it. Can you share the sprite, and show the event? Include the whole event window, not just the event commands. Make sure the move route is visible too.

Or you can zip up your project and send it to me and I'll take a look.
 

busbuzz

Veteran
Veteran
Joined
Jun 17, 2021
Messages
168
Reaction score
36
First Language
English
Primarily Uses
RMMZ
how can i send it privately?
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,415
Reaction score
15,214
First Language
English
Primarily Uses
RMMV
zip up your project and find somewhere to load it online (dropbox, whatever). Then send me a pm with the link.
 

busbuzz

Veteran
Veteran
Joined
Jun 17, 2021
Messages
168
Reaction score
36
First Language
English
Primarily Uses
RMMZ
Ok, so your solution to the problem did work. But, it's still a bug. there is one frame glitch when there is a change from one sprite sheet to another one. There is a way around it, but the bug is still there. What Shaz told me to do is not to use individual spritesheets and have an 8 sprite sheet instead so that it doesn't load a new sheet and that does avoid the glitch. My problem solved. Thank you so much
 

Latest Threads

Latest Profile Posts

Working on a characteeer! (Why is it so hard to color hair?) ;-;
Silly-Sketches.png
Just finished eventing a couple simple puzzles in RMMV, for my very first game "Sample Quest." Just messing around, throwing things together, and calling it a story XD On a non-RM note, got my hair cut today!
I feel the need to inform everyone on the forums NOT to go with Web Hosting Canada for your hosting needs. It is by far the worst customer service and just overall experience I have ever had with hosting and I am Canadian...
BCj
Got another eye surgery monday. Hope I'll recover quick and all's well. A bit tired of surgeries. On a happy note, working on the next chapter of Escalia so hope I can continue soon :)
Celebrating the arrival of autumn in the Northern Hemisphere :)

Forum statistics

Threads
115,368
Messages
1,089,315
Members
150,057
Latest member
kotfwing
Top