Graphical problems with Victors animated battlers script

Discussion in 'RGSSx Script Support' started by BlackRoseMii, Jun 3, 2016.

  1. BlackRoseMii

    BlackRoseMii Veteran Veteran

    Messages:
    651
    Likes Received:
    590
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMVXA
    I've had this problem for a while, but I put it away, because it's not a game breaking problem.


    The problem I have is about the bow animation. While the animation of my archer attacking works perfectly, the animation when damaging an enemy is still the "hit physical". But I want it to be "pierce physical".


    I know that this seems to be a common problem and that you might already be tired of hearing this, but I've literally tried everything to get rid of this problem. But nothing works. I have been at least able to erase the animation completely.


    Okay, here are the things you might need to have to solve this problem:



    This is under all three modes: charset, kaduki and unspecific settings.
     


    This is the screenshot of the weapon used:
    [​IMG]


    Here's the original, unedited script: https://drive.google.com/file/d/0B0cSp2lASM9wdjMwNEMtMFlkR1k/view


    I hope somebody can help with this, I've searched everywhere and nothing helped. TT.TT
     
    Last edited by a moderator: Jun 23, 2016
    #1
  2. BlackRoseMii

    BlackRoseMii Veteran Veteran

    Messages:
    651
    Likes Received:
    590
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMVXA
    bump
     
    #2
  3. Dark_Metamorphosis

    Dark_Metamorphosis What a horrible night to have a curse. Veteran

    Messages:
    2,194
    Likes Received:
    382
    Location:
    Sweden
    First Language:
    Swedish
    You could try and use no animation whatsoever in the database, and then add the animation ID in the notetag instead and see if that works.
     
    #3
  4. BlackRoseMii

    BlackRoseMii Veteran Veteran

    Messages:
    651
    Likes Received:
    590
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMVXA
    It isn't working either. Maybe it's because I don't know how I should write it in the notetags. I've tried different things like <anim: id 013>, <animation: id 013>, <anim id: 013> and so on. Is there a certain way I have to write it? (I really have not a single clue about how scripts work, unfortunately^^°)
     
    #4
  5. Dark_Metamorphosis

    Dark_Metamorphosis What a horrible night to have a curse. Veteran

    Messages:
    2,194
    Likes Received:
    382
    Location:
    Sweden
    First Language:
    Swedish
    Try write it without the zero and the <> as in:


    anim: id 13; 


    hopefully that should solve it.


    Also, Victor has a good manual with every command that you can use found here:


    Seems like many people have this issue when it comes to the bow setup, other weapons works fine to show altered animations but not the bow. Not sure if It's gonna help to tell the pose to use that animation on the targets, but give it a try :/
     
    Last edited by a moderator: Jun 9, 2016
    #5
  6. BlackRoseMii

    BlackRoseMii Veteran Veteran

    Messages:
    651
    Likes Received:
    590
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMVXA
    I've already looked through that manual, but haven't found anything.


    Also, adding anim: id 13; doesn't help, still no animation at all.
     
    #6
  7. BlackRoseMii

    BlackRoseMii Veteran Veteran

    Messages:
    651
    Likes Received:
    590
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMVXA
    bump
     
    #7
  8. BlackRoseMii

    BlackRoseMii Veteran Veteran

    Messages:
    651
    Likes Received:
    590
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMVXA
    bump
     
    #8

Share This Page