'Height' problems with yanfly's SV Animated Enemies!

Discussion in 'Javascript/Plugin Support' started by Moist__Lord, Oct 14, 2017.

Thread Status:
Not open for further replies.
  1. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    #1
  2. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    I've also individually placed every single note tag inside the notes of the actor enemy I'm using to test it, so I don't see what's wrong.
     
    #2
  3. Shaz

    Shaz Veteran Veteran

    Messages:
    37,807
    Likes Received:
    11,517
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    Did you start a new game after setting up the actor enemy? Or did you resume a saved game?
     
    #3
  4. padr81

    padr81 Guy whose game is taking too long. Veteran

    Messages:
    642
    Likes Received:
    640
    First Language:
    english
    Primarily Uses:
    N/A
    You're the second person with that very problem tonight. I'd suggest sending Yanfly a blank project ala the instructions from his thread. Has to be a bug in the plugin update.
     
    #4
  5. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    Nope, I'm testing it in the troop battle testing.
     
    #5
  6. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    12,310
    Likes Received:
    12,524
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    You must test it in new game. Most plug-ins do not work in troop testing, as that feature doesn't always load all the plug-ins properly. Try it in a new game (do not load an old save, that will also not work), and see if it works from there.
     
    #6
  7. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    New project or a new save? I didn't really catch what you were trying to say.
     
    #7
  8. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    12,310
    Likes Received:
    12,524
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    Neither. New Game. You know, the new game button you can hit when you first load up the project?
     
    #8
  9. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    Well I can only assume you meant a new project.
     
    #9
  10. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    Can you be more precise?
     
    #10
  11. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    12,310
    Likes Received:
    12,524
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    No. Its right there when you start your game. Read all three options that show up when you start your game, one of them will read New Game. I can't make it more precise without making it flashing Neon.
     
    #11
    Joy Diamond likes this.
  12. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    OH! That's what you meant.
    I did try that on a new game but it still wasn't working.
     
    #12
  13. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    12,310
    Likes Received:
    12,524
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    Ok, now we need details. Post a list of all of your plug-ins. A screenshot of them will be helpful. Afraid I won't know much about what will be the cause from here as I still use ACE, but that will let the others be able to assist.
     
    #13
    Joy Diamond likes this.
  14. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
  15. padr81

    padr81 Guy whose game is taking too long. Veteran

    Messages:
    642
    Likes Received:
    640
    First Language:
    english
    Primarily Uses:
    N/A
    Your plugin order is way off.

    Go to Yanfly's site and line your plugins up to match the way they are exactly. Then work the other plugins around them. Off the top of my head I know Sideview Animated Battlers should be above the Visual HP gauge and a few more. There might be some issue still with plugin conflicts but maybe try that.

    Plugin Order is very important.

    I would set those plugins up as follows:
    • YEP Core
    • VE Basic Module
    • ----------------------------------------
    • YEP Main Menu Manager
    • SRD Alt Menu Screen
    • ----------------------------------------
    • YEP Message Core
    • ----------------------------------------
    • YEP Battle Engine Core
    • SRD Timed Attack Core (I believe SRD no longer supports this so it may not work in newer MV updates)
    • SRD Timed Attack Circle
    • SRD Timed Attack Results
    • YEP Animated SV Enemies
    • YEP Visual HP Gauge
    • SRD Battle GUI Core
    • ---------------------------------------
    • All other Yanfly Plugins in Order of the website.
    • SRD Camera Core
    • SRD GameOverCore
    • SRD Video Wait
    • VE Fog and Overlay
    • VE Escape Codes
    • Galvs Plugins
     
    #15
    mae-neau and Joy Diamond like this.
  16. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    Thanks! I'll try that now.
     
    #16
  17. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    #17
  18. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    bump
     
    #18
  19. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    Started to look back into the problem that I stated here recently and I haven't gotten any luck to try & fix it.
    I've rearranged my plugin load order, turned off some plugins, and heck even tried using the plugins in a new project (which proves to me that none of the plugins in my current one are interrupting this one), to try and fix "Cannot read property 'height' of undefined". Both plugins required, (YEP_BattleEngineCore & YEP_X_AnimatedSVEnemies) and yet I still get the same error message. This ONLY happens when I use an SV Actor sheet for an enemy in the note tags! When I use the breathing effect from YEP_X_AnimatedSVEnemies there is absolutely no problem.
     
    #19
  20. OnslaughtSupply

    OnslaughtSupply Ssshhh... Veteran

    Messages:
    731
    Likes Received:
    762
    Location:
    Texas
    First Language:
    English
    Primarily Uses:
    RMMV
    What's the notetags you are using? Also try turning off VE plugins, then saving, then close your project, then open it back up and see if that works. Some of Yanfly's plugins act funny until you reopen your project after adding it to your game.
     
    #20
    Joy Diamond likes this.
Thread Status:
Not open for further replies.

Share This Page