'Height' problems with yanfly's SV Animated Enemies!

Discussion in 'Javascript/Plugin Support' started by Moist__Lord, Oct 14, 2017.

Thread Status:
Not open for further replies.
  1. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    Here's the note tags I'm using for the only enemy I have so far using the animated actor sheet:

    <Sideview Battler: dreamdistortion1>

    <Sideview Height: 144>

    <Sideview Width: 144>

    I disabled all of the VE plugins afterwards, saved, and opened the project back up, still to no avail.
     
    #21
  2. OnslaughtSupply

    OnslaughtSupply Ssshhh... Veteran

    Messages:
    731
    Likes Received:
    762
    Location:
    Texas
    First Language:
    English
    Primarily Uses:
    RMMV
    And just to test, have you removed the height and width notetags. Also just to double check your Sideview Enemies filename is exactly right. Finally its in the Sideview Actor's folder.
     
    #22
  3. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    1) It's been like this without the height/width note tags. I added them hoping it would fix it.
    2) Yep, my Sideview Enemies filename is EXACTLY as it should be named, here's a screenshot:
    [​IMG]
    3) I've placed the image inside my SV Actors folder & SV Enemies folder.
     
    #23
  4. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    I've even re-downloaded the two plugins to make sure they're at their most updated version to no avail.
     
    #24
  5. Andar

    Andar Veteran Veteran

    Messages:
    28,636
    Likes Received:
    6,576
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV

    @Moist__Lord
    , please avoid double posting, as it is against the forum rules. You can review our forum rules here. Thank you.


    If you have something to add and your own post is the last one, please editor that post instead of adding another post.
     
    #25
  6. OnslaughtSupply

    OnslaughtSupply Ssshhh... Veteran

    Messages:
    731
    Likes Received:
    762
    Location:
    Texas
    First Language:
    English
    Primarily Uses:
    RMMV
    Last idea, did you assign it a "dummy" side view enemy static image?
     
    #26
  7. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    What do you mean?
     
    #27
  8. OnslaughtSupply

    OnslaughtSupply Ssshhh... Veteran

    Messages:
    731
    Likes Received:
    762
    Location:
    Texas
    First Language:
    English
    Primarily Uses:
    RMMV
    You know in the database where you create your enemy and you click on the window for the static image, one has to be assigned even though the notetag will bypass this, the editor needs one assigned.
     
    #28
  9. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    I do have a static image assigned.
     
    #29
  10. OnslaughtSupply

    OnslaughtSupply Ssshhh... Veteran

    Messages:
    731
    Likes Received:
    762
    Location:
    Texas
    First Language:
    English
    Primarily Uses:
    RMMV
    I am out of ideas except for downloading YEP Action Sequence Packs 1-3 and placing them above the animated side view enemy plugin but below battle engine core.
     
    #30
  11. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    I’m going to try redownloading the files and testing the new files in a blank project. I’ll see if that gets me anywhere.
     
    #31
  12. OnslaughtSupply

    OnslaughtSupply Ssshhh... Veteran

    Messages:
    731
    Likes Received:
    762
    Location:
    Texas
    First Language:
    English
    Primarily Uses:
    RMMV
    Its strange, I have never had a problem using Animated Sideview Enemies, but I use alot of Yanfly's plugins, like core engine, message, save core, new game +, battle engine core, action sequences 1-3, STB, animated Sideview Enemies, it goes on and I am using slightly older (before the last update) versions. I am wondering if the action sequence packs need to be there, and I would highly recommend them anyways because it makes Sideview look so much better. Good luck.
     
    #32
  13. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    1) Opened up a new project, downloaded and tested out only the new versions of the battle core and animated SV enemies, didn't work.
    2) Downloaded the action sequence packs, put them into my plugin list, didn't work.
    Are you allowed to send me a link to those older versions of the plugins or no?
     
    #33
  14. Andar

    Andar Veteran Veteran

    Messages:
    28,636
    Likes Received:
    6,576
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    Please post a screenshot of the full error log in the console (F1) and screenshots of your current plugin manager (after you corrected the order li!e discussed above).
    Then we can continue to check for additional errors.
     
    #34
  15. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    Here's my plugin order for my main project:
    https://cdn.discordapp.com/attachments/223633695167348738/387785616403857408/unknown.png
    https://cdn.discordapp.com/attachments/223633695167348738/387785638939983883/unknown.png
    The error for my main project:
    https://cdn.discordapp.com/attachments/223633695167348738/387786542049001473/unknown.png
    The plugin order for the test project:
    https://cdn.discordapp.com/attachments/223633695167348738/387786840217878528/unknown.png
    The error for my test project:
    https://cdn.discordapp.com/attachments/223633695167348738/387787021290176512/unknown.png
     
    #35
  16. Shaz

    Shaz Veteran Veteran

    Messages:
    37,806
    Likes Received:
    11,511
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    I offered this to someone in the other thread, but nobody has responded, even though 3 others are having the same issue.

    Once Andar has taken a look at the above and confirmed that there are no issues with plugin order or missing plugins, if you are still having the problem, you could zip up your project (take out any unused resources - especially audio) and load it up to dropbox or something, and I may be able to spend some time debugging it tonight.
     
    #36
  17. Moist__Lord

    Moist__Lord Veteran Veteran

    Messages:
    66
    Likes Received:
    2
    First Language:
    English
    Okay, thank you. I forgot to mention Shaz, but when I send you this do you need everything in the project or just the plugins?
     
    Last edited: Dec 6, 2017
    #37
  18. OnslaughtSupply

    OnslaughtSupply Ssshhh... Veteran

    Messages:
    731
    Likes Received:
    762
    Location:
    Texas
    First Language:
    English
    Primarily Uses:
    RMMV
    I'm just thinking outside the box here but I am just wondering is your user folder perhaps "Mathew's Crap"?

    That naming convention isn't very network friendly and should be "mathewscrap". Normal network rules don't like special characters like ' and they don't like spaces. Windows tends to correct these issues but I am wondering if the way Yanfly is calling the image is throwing the error.

    Just a long shot.

    Edit to add, have you changed any settings in the plugin parameters?

    Also SRD has a tiny project to download for debugging purposes if you take shaz up on the offer.
     
    #38
  19. Shaz

    Shaz Veteran Veteran

    Messages:
    37,806
    Likes Received:
    11,511
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    Everything in the project, except the unused audio, to make the file size smaller. Please send me the NEW project you created, where you JUST put in what was necessary to test for the issue. I don't want the bigger project that you've been working on all along.

    However, please wait for Andar's response first, because he might see something straight away that could be causing an issue.
     
    #39
  20. Andar

    Andar Veteran Veteran

    Messages:
    28,636
    Likes Received:
    6,576
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    The stacktrace in the console only lists yanfly's plugin and core files as involved, that makes it very unlikely to be an incompatibility issue between plugins.
    And that means that in my opinion, there are only three possible causes left:

    1) you configured the plugin in a wrong way.
    Some notetags or plugin properties are wrongly set or missing, but I don't know enough about that plugin to check that for you. Read its instructions again to make sure everything is set as yanfly needs it.

    2) the version of the core files is incompatible with the version of the plugin.
    Best update everything to the latest versions. You can check the core version by opening any of the listed core files with notepad and check the number at the end of the title line.

    3) the engine has trouble reading the files, either because of the errors in the filepath (anything replaced with a %-number in the path listed in the console screenshot stands for a letter that is illegal under network deployment) or because the pictures themselves are coded wrong (that is unlikely, but if you're using an exotic image program for conversions it might be possible)
     
    #40
Thread Status:
Not open for further replies.

Share This Page