RMMZ Help With Shadows Not Work Parallax - Gimp/RPG Maker

Kaine_Kalos

Villager
Member
Joined
Jul 10, 2021
Messages
29
Reaction score
13
First Language
English
Primarily Uses
RMMZ
I'll try to describe this as best I can. I'm out of ideas on how to fix this problem, and would greatly appreciate anyone who can comment.

I'm using Galv's parallax layers plugin to do parallax mapping, but I'm running into a problem with the shadows, and I will include a photo of what it looks like in game after I'm done:

zzzzzzz2.jpg

After I'm finished setting up all my layers, I merge them to create my top layer and bottom layer separately.
I then cut out all the areas that the player will be walking under or behind, and paste them into a separate layer for my top layer.
At this point, in Gimp, everything looks great. I have my settings on RGB mode, and I save the files as PNGs in the appropriate folder.

When I start up the game, it looks like the image above. You can see where I have cut the images in the layer, and the assets themselves look great, but the shadows are always twice as dark. I am NOT overlay multiple iterations of the same image. I am CUTTING and pasting it into a new layer, so I'm not doubling anything to cause the extra shading.

Does anyone know what causes this problem? I've searched the internet high and low for days looking for an answer, and I'm completely out of options. o_O Thanks for any help you can give me.
 

Ellenor

Artist: Digital/Pixelart/3D
Veteran
Joined
Dec 2, 2012
Messages
32
Reaction score
87
First Language
Swedish
Primarily Uses
Other
Can you screenshot your layers in gimp?
It would maybe make it easier to see where the problem comes from.
 

Ellenor

Artist: Digital/Pixelart/3D
Veteran
Joined
Dec 2, 2012
Messages
32
Reaction score
87
First Language
Swedish
Primarily Uses
Other
By the way I think you maybe should post this somewhere else.
Like in general discussions or rpg maker mz support.
Your are not very likely to get help in the art section.
 

Kaine_Kalos

Villager
Member
Joined
Jul 10, 2021
Messages
29
Reaction score
13
First Language
English
Primarily Uses
RMMZ
Hi Ellenor, thanks for getting back with me; I really appreciate it. I try as hard as I can to pick the right place to post things, but so far, no matter what I do, I seem to do it wrong or break some rule, so I'm not sure when I'm going to hit a proverbial forum landmine. :wink:

I got the photos you requested; these are the two layers I'm using taken directly from Gimp.
zzzzzzz2.jpgzzzzzzz3.jpg
Any advice you can provide would be wonderful, and again, I really appreciate your time. Let me know if you need to view anything else. If I can't figure out anything in this section of the forum, am I allowed to repost this thread on another section? Like I said, I'm still getting familiar with the rules. o_O
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,647
Reaction score
15,742
First Language
English
Primarily Uses
RMMV

I've moved this thread to Plugin Support. Thank you.



(though I guess it could also go into Resource Support or Plugin Support)

Any reason why you don't just put all the shadows on the ground layer?

@Ellenor , please avoid double posting, as it is against the forum rules. You can use the "Edit" function on your posts to add additional information you've forgotten or respond to multiple people. You can review our forum rules here. Thank you.


(please just edit your post to add the extra info rather than posting twice in a row. thanks :) )
 
Last edited:

Kaine_Kalos

Villager
Member
Joined
Jul 10, 2021
Messages
29
Reaction score
13
First Language
English
Primarily Uses
RMMZ
[move]MZ Support[/move]

(though I guess it could also go into Resource Support or Plugin Support)

Any reason why you don't just put all the shadows on the ground layer?

[dpost]@Ellenor [/dpost]
(please just edit your post to add the extra info rather than posting twice in a row. thanks :) )
Thanks for the move.

The shadows are part of the original assets. Furthermore, putting the shadows on a higher layers allows them to show above the player, which creates more immersion, showing the player walking under the shadow of the tree.

Again, any advice is welcome; thanks everyone. :wink:
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,647
Reaction score
15,742
First Language
English
Primarily Uses
RMMV
I wonder if there's a blend mode at work on one of the layers you created, that isn't active on the other?

Can you put ALL the shadows on the same layer? Top layer, if you want them to appear over the player?
 

Ellenor

Artist: Digital/Pixelart/3D
Veteran
Joined
Dec 2, 2012
Messages
32
Reaction score
87
First Language
Swedish
Primarily Uses
Other
Do the shadow have the same % of transperency in gimp?
Sorry for the late reply.
 

LadyBaskerville

Hell-poodle
Veteran
Joined
Sep 12, 2016
Messages
706
Reaction score
615
First Language
German
Primarily Uses
RMMV
Aside from what the others have suggested, is there a chance that you might be adding the top layer twice in the engine? (E. g. once in the map settings, once via plugin command, ir calling a plugin command twice?) I haven't used the plugin you mention, so I'm not sure what exactly the options for adding layers are, but this just came to mind.
 

Kaine_Kalos

Villager
Member
Joined
Jul 10, 2021
Messages
29
Reaction score
13
First Language
English
Primarily Uses
RMMZ
I wonder if there's a blend mode at work on one of the layers you created, that isn't active on the other?

Can you put ALL the shadows on the same layer? Top layer, if you want them to appear over the player?
First of all, apologies to everyone for taking so long to get back with you. I was out of town for a couple of weeks. Thank you all so much for your responses.

Next, to respond: No, because the shadows are part of the original assets. I am copying/pasting assets into the image layers from a template of assets I have collected and created. Once the final product is complete, I simply cut the pieces I want the player to be able to walk behind, and paste them onto the project I'm working on.

In the end, I have a total of two layers, the bottom, which the player walks above, and the top, which the player walks behind.

I am not adding any shadows in this particular map; I am just copy/pasting the assets, which already have shadows on them. I know how to add a layer of my own shadows, but that's not what I'm trying to do here; I'm only using two layers for this map area.

If there was a blending issue, I do not know where it is coming from, and it would be baffling to me why the image looks perfectly normal in gimp, but once I load up the layers in game, it changes. I do agree that it looks like the top layer is being superimposed twice, but I have no idea how they would be the case.
Do the shadow have the same % of transperency in gimp?
Sorry for the late reply.
Good question. That's not what I'm doing. I'm not adjusting any transparency. The shadows are slightly transparent in the original assets. I am simply copy/pasting those assets into the map I'm creating. I am not adding any other shadows.
Aside from what the others have suggested, is there a chance that you might be adding the top layer twice in the engine? (E. g. once in the map settings, once via plugin command, ir calling a plugin command twice?) I haven't used the plugin you mention, so I'm not sure what exactly the options for adding layers are, but this just came to mind.
Another good question. I do not have any evidence to support that, but I would not rule it out (because I can be stupid sometimes). Here is the code I have inserted into the map area to use the Galv plugin:

LAYER_S 0 chpt2traye_docks_bot 0 0 255 0.5 10 0 0
LAYER_S 1 chpt2traye_docks_top 0 0 255 5 10 0 0

I copied that into this thread exactly as I have it written in the notes of the Map Properties. I've tried to play around with some of the number inputs, but nothing's changed. To be clear, I have not had any problems using this plugin for other map areas. The only time I seem to be having a problem is with partially transparent shadows after they are loaded into the game.

Thank you all for your input, it's a great help to me. :smile:


**********************

EDIT: I tried to play with Galv's options for blending, but nothing seemed to work. Interesting though, the "255" settings are the opacity. I tried to set the stop later at "130," and the shadows were perfect, but the rest of the trees on the top layer were transparent. This means that, somehow, the shadows are being doubled in opacity.

How and why on just the shadows? I have another map area where I have a cutscene, and I did parallaxing on it. I didn't do any cutting and pasting because it was just setup for a cutscene. It turns out, yes, the shadows were doubled on that as well. This means, as far as I can tell, it is NOT gimp. It has to be the plugin settings... but I can't figure out exactly what to do. Hmm...
 
Last edited:

Latest Profile Posts

Who wants to see me mock my brother's story? Brother story: thus he summoned a mighty twenty foot lizard. My Comment: Godzilla is attacking the city! As bad as these 4 are at shopping I wouldn't be surprised if Jun didn't proudly return with a chamber pot on her head. "Look at this helmet I got for 1,000 gold!"
Apparently I'm a grandpa now.

20220128_181216.jpg20220128_181227.jpg
Sales Goal of Learn RPG Maker MV at 64% now! :kaopride:
When I was in the hospital I did actually have a nurse that was funny, did all these extra nice things for me and said she liked me. So you know what that means. That will be the last time I'll hear from her.

Forum statistics

Threads
118,808
Messages
1,118,855
Members
155,988
Latest member
Lilrick0712
Top