ksaOfficial

Villager
Member
Joined
Jun 23, 2021
Messages
9
Reaction score
0
First Language
English
Primarily Uses
RMVXA
Here is the script that i modified:

Screenshot_14.png
And here at the small box, it didn't show up:
Screenshot_15.png

How can i make states show up and make it to the right angle.
Thank you
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,415
Reaction score
15,214
First Language
English
Primarily Uses
RMMV

I've moved this thread to RGSSx Script Support. Thank you.

 

kyonides

Reforged is laughable
Veteran
Joined
Nov 17, 2019
Messages
356
Reaction score
101
First Language
English
Primarily Uses
RMXP
Without a link to the original script, I think it's gonna be hard to fix it. For the meantime I can only ask you this: have you tried increasing STATES_Z value already?
 

ksaOfficial

Villager
Member
Joined
Jun 23, 2021
Messages
9
Reaction score
0
First Language
English
Primarily Uses
RMVXA
alright here is the link, well the website is down, but here is a txt file that has the state, and send me if u finished, btw the first layout is the same but red and no active, and i want to put my state in one box
 

Attachments

  • MOG_Hunter_Battle_EX.txt
    242.3 KB · Views: 1

Noamancy

Veteran
Veteran
Joined
Nov 3, 2014
Messages
34
Reaction score
3
First Language
English
Primarily Uses
RMVXA
Here is the script that i modified:

View attachment 197726
And here at the small box, it didn't show up:
View attachment 197727

How can i make states show up and make it to the right angle.
Thank you
Did this ever get resolved?

I use MOG_Hunter's Battle HUD. -- Those settings seem to be the default for it from the Master Demo; tell me - does your Status Icon show up ANYWHERE on the screen?

Double check to make sure you have a status icon setup for the state:
statesasa.PNG

Based on the above settings it should appear (at the very least unaligned).

Mind you, states should only show up when they are applied during the fight. I noticed it says 'Engage/Escape' - was this screen shot taken at the start of battle? Or did you pause it after the state was applied? I just noticed there doesn't appear to be any damage so It seems like the battle just started.

The box will remain empty until the state is applied, then the icon shows on the screen based on what you have the icon set too in the DATABase. If you don't want the box to be there when the state is not active, you must remove the box from the graphic itself in the Graphics/Hud folder.
 
Last edited:

ksaOfficial

Villager
Member
Joined
Jun 23, 2021
Messages
9
Reaction score
0
First Language
English
Primarily Uses
RMVXA
ok, then i will try my best to do that, engage it means fight, and escape it means escape, i took the shot after the enemy appear message, and it gave me the state, but it didn't show up, i double'd check every state, all the state that i have is iconset'd, and i did put the state, and here's the proof:
Screenshot_17.png
After the state applied, it didn't show up in the box, and i even tho, i put a script that show state when you applied them, and showed me the icon and the name.
i will try my best to solve this, i will let you know that
 

Noamancy

Veteran
Veteran
Joined
Nov 3, 2014
Messages
34
Reaction score
3
First Language
English
Primarily Uses
RMVXA
ok, then i will try my best to do that, engage it means fight, and escape it means escape, i took the shot after the enemy appear message, and it gave me the state, but it didn't show up, i double'd check every state, all the state that i have is iconset'd, and i did put the state, and here's the proof:
View attachment 199505
After the state applied, it didn't show up in the box, and i even tho, i put a script that show state when you applied them, and showed me the icon and the name.
i will try my best to solve this, i will let you know that

I'm going to test something later today when I get home - I haven't actually built new states in my game yet - I've been using default states, but I've only tested states like a few times. -- I'm going to create a new state tonight, and apply it to all characters at the start of battle the same way you did and see if it shows up for me -- if it doesn't, I'll let you know, if it does, I'll show you my setup and we'll compare.
 

Latest Threads

Latest Profile Posts

Working on a characteeer! (Why is it so hard to color hair?) ;-;
Silly-Sketches.png
Just finished eventing a couple simple puzzles in RMMV, for my very first game "Sample Quest." Just messing around, throwing things together, and calling it a story XD On a non-RM note, got my hair cut today!
I feel the need to inform everyone on the forums NOT to go with Web Hosting Canada for your hosting needs. It is by far the worst customer service and just overall experience I have ever had with hosting and I am Canadian...
BCj
Got another eye surgery monday. Hope I'll recover quick and all's well. A bit tired of surgeries. On a happy note, working on the next chapter of Escalia so hope I can continue soon :)
Celebrating the arrival of autumn in the Northern Hemisphere :)

Forum statistics

Threads
115,368
Messages
1,089,316
Members
150,057
Latest member
kotfwing
Top