I can't figure out why the Attack option is grayed out.

Status
Not open for further replies.

Tanarex

Scrub
Veteran
Joined
Sep 14, 2014
Messages
533
Reaction score
326
First Language
English
Primarily Uses
RMVXA
I don't know what I did but the basic attack option for my characters is no longer usable. I even tried copying it from a new game. Any help would be appreciated.
 

Attachments

  • actor.PNG
    actor.PNG
    75.4 KB · Views: 21
  • Class.PNG
    Class.PNG
    60.3 KB · Views: 22
  • Skill.PNG
    Skill.PNG
    66.7 KB · Views: 22
  • troops.PNG
    troops.PNG
    612.8 KB · Views: 22

Trihan

Speedy Scripter
Veteran
Joined
Apr 12, 2012
Messages
3,709
Reaction score
2,818
First Language
English
Primarily Uses
RMMZ
If you take all the notetags out does it work?
 

Wavelength

MSD Strong
Global Mod
Joined
Jul 22, 2014
Messages
6,081
Reaction score
5,751
First Language
English
Primarily Uses
RMVXA
Here are my Top 3 suspicions - #1 is the one I'd be most likely to jump at.
  1. Your Attack skill is given the skill type of "Combat Skill" which is not the default (the default is 'None' I believe). Make sure all of your Actors have a Feature on their Actor, Class, or Equips that allow them to use the "Combat Skill" skill type. Or, try changing Attack's type to None. Save, and try again.
  2. A script could be changing the conditions for a skill to be usable. Disable any script which deal with Skills, especially Skill Conditions, then Save and then try again.
  3. This is unlikely, but it's possible that your core script (something like Game_Battler or Scene_Battle), which contains a method to determine which skill is the 'Attack Skill', was changed accidentally. Maybe do a Search All (Ctrl + Shift + F I think) for attack and see if anything stands out as the method to define what skill is considered the "Attack" when used from the menu. Make sure it still returns 1, not some other number.
 

Tanarex

Scrub
Veteran
Joined
Sep 14, 2014
Messages
533
Reaction score
326
First Language
English
Primarily Uses
RMVXA
If you take all the notetags out does it work?
Nope. Tried that.
Here are my Top 3 suspicions - #1 is the one I'd be most likely to jump at.
  1. Your Attack skill is given the skill type of "Combat Skill" which is not the default (the default is 'None' I believe). Make sure all of your Actors have a Feature on their Actor, Class, or Equips that allow them to use the "Combat Skill" skill type. Or, try changing Attack's type to None. Save, and try again.
  2. A script could be changing the conditions for a skill to be usable. Disable any script which deal with Skills, especially Skill Conditions, then Save and then try again.
  3. This is unlikely, but it's possible that your core script (something like Game_Battler or Scene_Battle), which contains a method to determine which skill is the 'Attack Skill', was changed accidentally. Maybe do a Search All (Ctrl + Shift + F I think) for attack and see if anything stands out as the method to define what skill is considered the "Attack" when used from the menu. Make sure it still returns 1, not some other number.
Yeah, I tried switching it to none. Didn't change anything. I haven't added any new scripts in a long time. And this is a recent problem. I don't mess with the core scripts. The custom scripts are a big enough pain already. i used Ctrl + Shift + F but don't know anything about code. So I've added screenshots.
 

Attachments

  • Game Battler.PNG
    Game Battler.PNG
    48.9 KB · Views: 2
  • scene battle.PNG
    scene battle.PNG
    42 KB · Views: 2

Trihan

Speedy Scripter
Veteran
Joined
Apr 12, 2012
Messages
3,709
Reaction score
2,818
First Language
English
Primarily Uses
RMMZ
Are any of your scripts doing anything with attack_skill_id?
 

Tanarex

Scrub
Veteran
Joined
Sep 14, 2014
Messages
533
Reaction score
326
First Language
English
Primarily Uses
RMVXA
I have Yanfly Engine Ace - Weapon Attack Replace v1.01 in scripts. But it has DEFAULT_ATTACK_SKILL_ID = 1
 

Attachments

  • weapon replace.PNG
    weapon replace.PNG
    63.8 KB · Views: 2

Trihan

Speedy Scripter
Veteran
Joined
Apr 12, 2012
Messages
3,709
Reaction score
2,818
First Language
English
Primarily Uses
RMMZ
Have you added any new scripts to the game between now and the last time attack worked for you?
 

Tanarex

Scrub
Veteran
Joined
Sep 14, 2014
Messages
533
Reaction score
326
First Language
English
Primarily Uses
RMVXA
nope. I moved some files around.
 

Trihan

Speedy Scripter
Veteran
Joined
Apr 12, 2012
Messages
3,709
Reaction score
2,818
First Language
English
Primarily Uses
RMMZ
Assuming you're not using any paid scripts, are you able to zip the project up and upload it somewhere? If you're not well-versed in code it'd probably be quicker for me to just take a look myself and figure out where it's failing the enable test.
 

Tanarex

Scrub
Veteran
Joined
Sep 14, 2014
Messages
533
Reaction score
326
First Language
English
Primarily Uses
RMVXA
I have it uploaded on MEGA.nz. I can send you a PM with the link.
 

Trihan

Speedy Scripter
Veteran
Joined
Apr 12, 2012
Messages
3,709
Reaction score
2,818
First Language
English
Primarily Uses
RMMZ
The problem is weapon attack replace. Your character is equipped with a Crossbow, which has <attack skill id: 171> but 171 doesn't exist. The highest skill in your database is 150.
 
Last edited:

Tanarex

Scrub
Veteran
Joined
Sep 14, 2014
Messages
533
Reaction score
326
First Language
English
Primarily Uses
RMVXA
Oh, I forgot I replaced the basic attack. I just recently cut out some skills and put them in alphabetical order. It's working now so thank you.
You had that you are a scripter. Can you help me with another small scripting issue?
 

Trihan

Speedy Scripter
Veteran
Joined
Apr 12, 2012
Messages
3,709
Reaction score
2,818
First Language
English
Primarily Uses
RMMZ
I can certainly try, what do you need?
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,870
Reaction score
14,989
First Language
English
Primarily Uses
RMMV

I've moved this thread to RGSSx Script Support. Thank you.



You should have said right at the very start that you were using a script, and which one.

As this issue is resolved, I am going to close the thread. Please start a new thread for your other issue.
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

would i get in trouble if i didn't take out the computer icons on my fake computer screen i had Discord, Messanger, and rpg maker up
Auto-Adjust Text Outline, Run Common Events on Transfer | RPG Maker News #111

I sweep the floor. My brother, "You didn't do a good job. There are dust bunnies everywhere." He sweeps the floor weeks later. "I just swept. Why are there dust bunnies everywhere?" Me," Guess you didn't do a good enough job."
Today, I tortured my internet by downloading 20 files at once and then I played a guessing game as to which would finish their download first :kaojoy:
Oh god, just watched HawkZombie's stream of my game and realised that *none* of the branching scenes work properly. One has no character graphic, one soft locks due to a passability issue, and one doesn't have its autorun set to the right trigger. I've got first prize in the bag, baby.

Forum statistics

Threads
113,791
Messages
1,077,510
Members
147,837
Latest member
Fenrir_
Top