I have a problem with transparency and its getting old.

PumpKindOf

Warper
Member
Joined
Mar 4, 2021
Messages
4
Reaction score
1
First Language
English
Primarily Uses
RM2k3
My friend bought me RPG Maker 2003 a bit ago and I think I'm bout to scream because in the 5+ hours I've used it so far it's been just me trying to fix this issue, I may just be stupid but that's for y'all to decide when you help me fix this dumb issue.

First off the second layer, it's just bright pink, the only things that aren't are the objects I placed before using a custom tileset.
Pink.png
(FYI the only thing I changed on the tileset was the second layer's transparency to pink, this happens no matter what I change to the tileset!)

Second off the bottom layer is shrouded with a darker shade of the same pink, fantastic.
Worse_Pink.png
Just a heads up, I have googled every way of fixing this and I cant figure it out so if any of y'all have an answer...

Be my guest!

(Sorry if this sounds rude at all, I'm just really fed up with this and a stubborn POS lol)
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
41,867
Reaction score
14,521
First Language
English
Primarily Uses
RMMV
So it's the tiles from your custom tileset that are pink? When you import a tileset, there are options to select a transparent colour and a semi-transparent colour (at least I know there is in XP, and I think the earlier versions are the same). Did you do that? You need to left-click on one and right-click on the other in the import window.

The other option is to make your tileset with those areas transparent or semi-transparent, which is what the later engines do.

If your tileset images are actually NOT pink, then it may be that you've used the wrong colour indexing when creating it. I'm not the best to explain it, as I don't do much with creating my own tiles, so someone else might be able to clarify, or you might be able to look at how the default tiles are set up and make sure your new ones are the same.
 

PumpKindOf

Warper
Member
Joined
Mar 4, 2021
Messages
4
Reaction score
1
First Language
English
Primarily Uses
RM2k3
Sorry I should've clarified this better but yes I made the transparent color pink, the issue is that no matter what I change the color too or if I have nothing there at all it will make the screen that solid color when I launch the game.

I'm very new to this so I don't know much about indexing or the engine itself.

Edit: To understand better here's the best example of my issue.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
41,867
Reaction score
14,521
First Language
English
Primarily Uses
RMMV
The thread you linked to as a "best example of the issue" also gives the solution. Did you try it? What happened when you tried it?
 

RomVHS

NPC
Veteran
Joined
Feb 1, 2021
Messages
63
Reaction score
201
First Language
English
Primarily Uses
RM2k3
When uploading your tile or character sets, click on the color you want to be transparent. The color should blink when you select it, like this! Hopefully I'm understanding your problem correctly!


The second layer is supposed to be covered in transparency, and it probably thinks that the pink is transparent. When you're on the first layer, everything on the second layer becomes semi-transparent so you know what tiles are on which layer.

If it's a problem with color indexing, I pop my tilesets into MS Paint and re-export it. When saving the tileset, you can click on the dropdown under the file name and select the 256 Color Bitmap option, which is what RPG Maker 2003 takes! (Though sometimes, Paint can mess up your palette... I've heard that Gimp is a great free alternative for this, though I haven't used it myself.)


I hope this helps! If not, I hope you find a solution to your problem pronto!
 

PumpKindOf

Warper
Member
Joined
Mar 4, 2021
Messages
4
Reaction score
1
First Language
English
Primarily Uses
RM2k3
Oh my god I feel like an idiot, problem solved, I just didn't click on a transparency tile LMAO. Five hours down the drain for one click, thanks for the help y'all.
 

PumpKindOf

Warper
Member
Joined
Mar 4, 2021
Messages
4
Reaction score
1
First Language
English
Primarily Uses
RM2k3
The thread you linked to as a "best example of the issue" also gives the solution. Did you try it? What happened when you tried it?
Oh yeah forgot to reply to this, yes I tried every fix extreme or not, even updating my drivers. I can't believe that I just forgot to do a basic function of the program lol.
 

Latest Threads

Latest Profile Posts

For anyone interested in my project M - i finally made a gamethread about it :D

Yay. I turned 39 today. Another year older, another year closer to the grave.
I'm sure the latest post/thread in the sidebar used to have 5 posts. Was it always been like this?

Made it to the 10th video doing this! :kaocry:

renderTimingPixel.png
Made the "My Beating Mystery" board today:
3ENFLSC.png

in Grim Trigger episodes 3 & 4, the main characters play a Clue rip-off board game called "My Beating Mystery" (haha), so of course I had to draw the board for it. Can't decide if I wanna add blood or not

Forum statistics

Threads
110,407
Messages
1,053,064
Members
143,468
Latest member
oldj
Top