I just came back after a year and my RPG Maker MV doesn't launch anymore.

Discussion in 'Tech Support-All Makers' started by ruisu, May 26, 2019.

Thread Status:
Not open for further replies.
  1. ruisu

    ruisu Veteran Veteran

    Messages:
    56
    Likes Received:
    5
    First Language:
    English
    The splash screen comes up for 2 seconds and then disappears, nothing else happens.
    I tried installing it through Steam.
    I tried reinstalling it with and without Steam.

    I'm running Windows 8.1.
     
    #1
  2. Prescott

    Prescott argggghhh Veteran

    Messages:
    445
    Likes Received:
    284
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    This sounds stupid, but did you try running it by pressing the play button in Steam? At some point within the last few months RPG Maker MV stopped letting me launch it any other way. I'm guessing that's because of something Steam did.
     
    #2
    trakpichu likes this.
  3. Andar

    Andar Veteran Veteran

    Messages:
    28,004
    Likes Received:
    6,327
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    If the program vanishes within second of being started, then there are only two possible causes:

    1) the program file itself is damaged
    2) one of your background programs removes it from RAM.

    As for 1 - if your steam cache is damaged (happens randomly about one time per year) then even reinstalling will not repair it.
    You need to clear steam download cache through the steam support options, and reinstall it again only after that.

    As for 2 - could be anything from antivirus to a background video capture trying to automatically create a "Let's Play" for every steam-"Game" that is launched. And yes, that video capture program exists and caused some confusion a few years back.
    You need to check your installed programs to find out which one removed the MV editor and then tell it that it should not do it again. For example whitelisting RMMV in your antivirus if that falsely assumed MV is a virus.
     
    #3
    caethyril likes this.
  4. ruisu

    ruisu Veteran Veteran

    Messages:
    56
    Likes Received:
    5
    First Language:
    English
    Yes. Go to Steam > Library > Software > Rpg Maker MV > Play


    Ok, thank you for the possible solutions. It is much better than what tech support is doing right now. I'll go and try them.
     
    #4
  5. Switz

    Switz Veteran Veteran

    Messages:
    95
    Likes Received:
    67
    First Language:
    English
    Primarily Uses:
    RMMV
    Could try the ago old run as admin option. Antivirus these days are becoming more and more restrictive and automated.
     
    #5
  6. ruisu

    ruisu Veteran Veteran

    Messages:
    56
    Likes Received:
    5
    First Language:
    English
    Ok, I uninstalled anti-virus and reinstalled RPGMMV and nothing.
    Run as Administrator, nogo.
    Allowed permissions for RPGMV.exe on all users, nogo.
    I did a hard boot after every step.
     
    #6
  7. Andar

    Andar Veteran Veteran

    Messages:
    28,004
    Likes Received:
    6,327
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    I didn't suggest uninstalling the antivirus, I suggested whitelisting the editor in it. Because it is risky to be without AV.

    So if it wasn't the antivirus,what other background prograns do you have installed?
     
    #7
  8. Switz

    Switz Veteran Veteran

    Messages:
    95
    Likes Received:
    67
    First Language:
    English
    Primarily Uses:
    RMMV
    Could also think back past year ANY upgrades, changes or new programs you installed which may (or may not) be interfering.

    You could also try downloading someone's demo or project and try opening that and then make a new game from there. I do want to say every blue moon, my RPGM won't open from steam, but when I open the project I am working on it opens 100% of the time.
     
    #8
  9. ruisu

    ruisu Veteran Veteran

    Messages:
    56
    Likes Received:
    5
    First Language:
    English
    Just tried to open the game on Safe Mode and nogo.
    Customer service hasn't even responded to my tech support email.
     
    #9
  10. Prescott

    Prescott argggghhh Veteran

    Messages:
    445
    Likes Received:
    284
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    Did you try erasing your Steam cache? There have been times my roommates have games that don't load or crash when they try to load specific parts and doing so then reinstalling the game always helped.
     
    #10
  11. caethyril

    caethyril ^_^ Veteran

    Messages:
    954
    Likes Received:
    592
    Location:
    UK
    First Language:
    English
    Primarily Uses:
    RMMV
    Suggestions of things to try:
    • As Andar suggested, try clearing your Steam download cache if you haven't already (and then verify files or reinstall RPG Maker MV). Instructions can be found here: https://support.steampowered.com/kb_article.php?ref=3134-TIAL-4638

    • Make sure your graphics drivers are up-to-date. Integrated graphics should may update with the OS; dedicated graphics (e.g. Nvidia/AMD) generally have a separate updater application, which may be scheduled to run automatically. [Edit: see Andar's follow-up post below.]

    • Have the Task Manager open when attempting to launch RPG Maker MV and see if you can spot any unusual spikes in CPU/disk usage? This could help identify possible interfering applications.

    • Revert to an earlier version through Steam: Library > RPG Maker MV > right-click > Properties > Betas > (version). You can find the release dates of various editor versions here: https://forums.rpgmakerweb.com/index.php?forums/rpg-maker-mv-software-updates.171/&order=post_date
     
    Last edited: Jun 3, 2019
    #11
  12. Andar

    Andar Veteran Veteran

    Messages:
    28,004
    Likes Received:
    6,327
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    no, it depends on the mainboard/chipset manufacturer. For example even AMD has an integrated GPU in their CPU-Chipsets.

    Always check if the manufacturer has a driver before assuming windows takes care of it.
     
    #12
    caethyril likes this.
  13. Henryetha

    Henryetha Veteran Veteran

    Messages:
    387
    Likes Received:
    201
    Location:
    Germany
    First Language:
    german
    Mine won't launch through the steam direction (also happened after an update), so what I did, was moving the whole thing on my desktop, where it's working fine.
    I don't start from Steam, I only have Steam open.. and then launch it from the folder.
    It's important here to open steam first, or it might not launch.
     
    #13
  14. ruisu

    ruisu Veteran Veteran

    Messages:
    56
    Likes Received:
    5
    First Language:
    English
    Ok, so far I have tried:

    Uninstalling virus shield
    Running in Safe Mode
    Running the Steam version
    Clear Steam Download Cache
    Verify file integrity
    Reinstalling Steam version
    Reinstalling regular version
    Opening Steam but running regular version
    Going into Steam and presing the Launch button
    Going to the last 2 older versions
    Checking Graphics driver for updates

    I hard booted for every step I tried.
    I never had a game or software do this, so I don't have any experience to fall back on. It boggles my mind. Please help if you can.
     
    #14
  15. Andar

    Andar Veteran Veteran

    Messages:
    28,004
    Likes Received:
    6,327
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    can you give us a list of the background programs you have installed?
    everything points to a program blocking the launch, and if it isn't your antivirus it needs to be another one of your programs.

    if we get a list we can guess which one it might have been.

    and what is your graphics card, and how did you check it for updates?
     
    #15
  16. Henryetha

    Henryetha Veteran Veteran

    Messages:
    387
    Likes Received:
    201
    Location:
    Germany
    First Language:
    german
    And why haven't you tried changing the direction of the folder, RPGM is located in?

     
    #16
  17. Marsigne

    Marsigne Sephiroth Veteran

    Messages:
    1,805
    Likes Received:
    4,547
    Location:
    Jenova
    First Language:
    Other
    Primarily Uses:
    N/A
    Have you tried re-installing Windows completely? You might have gotten faulty drivers.
     
    #17
  18. ruisu

    ruisu Veteran Veteran

    Messages:
    56
    Likes Received:
    5
    First Language:
    English
    Hello everyone,

    Thank you for the suggestions. I updated from Windows 8.1 to Windows 10 and now I can use RPGMMv again.
    I hope that this helps lurkers out there. Thank you all for your suggestions.
     
    #18
    Amane Kagari and Marsigne like this.
  19. Kes

    Kes Global Moderators Global Mod

    Messages:
    20,169
    Likes Received:
    10,324
    First Language:
    English
    Primarily Uses:
    RMVXA
    @ruisu If your query is fully resolved please Report your opening post and ask for it to be closed.
     
    #19
    ruisu likes this.
  20. mlogan

    mlogan Global Moderators Global Mod

    Messages:
    13,608
    Likes Received:
    7,520
    Location:
    Texas
    First Language:
    English
    Primarily Uses:
    RMMV

    This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

     
    #20
Thread Status:
Not open for further replies.

Share This Page