I need help with a error with a resource product

Discussion in 'Javascript/Plugin Support' started by Rook47, Jan 17, 2018.

  1. Rook47

    Rook47 Veteran Veteran

    Messages:
    33
    Likes Received:
    2
    First Language:
    English
    Primarily Uses:
    RMMV
    I bought the KATAKURA HIBIKI'S LORDS OF DARKNESS resource pack from the rpgmaker website, downloaded it and put all the files in the correct spot. I go to test it so I make a battle event with one of the enemy options and get a error message it says type error: Cannot read property "height" of undefined I am unsure of what is causing this. When i looked at the files in the folders they have a black background to them while all other ones have white backgrounds, is this the cause of the error? How can i fix this issue? I hope someone can help me out here please
     
    #1
  2. Kes

    Kes Global Moderators Global Mod

    Messages:
    20,977
    Likes Received:
    10,677
    First Language:
    English
    Primarily Uses:
    RMVXA

    I've moved this thread to Javascript/Plugin Support. Please be sure to post your threads in the correct forum next time. Thank you.



    Putting in graphics does not usually result in that sort of error message, it sounds like a plugin error message.
    Could you try again and this time do a screenshot of the just the error message so that we know what all of it says.
     
    #2
  3. Rook47

    Rook47 Veteran Veteran

    Messages:
    33
    Likes Received:
    2
    First Language:
    English
    Primarily Uses:
    RMMV
    upload_2018-1-16_23-34-20.png

    I apologize for posting in the wrong part of the forum I am new to the forum and couldn't really figure out how to post things

    This is the error that comes up for Java scripts i have community basic, title command position, YEP_core engine (yan fly) and YEP_QuestJounral (yan fly quest journal
     
    #3
  4. Shaz

    Shaz Veteran Veteran

    Messages:
    37,816
    Likes Received:
    11,523
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    I am guessing that you are using Yanfly's Animated Battlers plugin.

    Can you please go into your project's js folder and open the core.js file. Let us know what the version number is at the top of the file (it'll be very obvious - if it's not there, on the first few lines, then you have version 1.0.0)

    Can you please hit F8 when you get that error, and give us a screenshot of what's on the console? That will tell us which script and which line is throwing the error.

    Another option is ... are you running Battle Test, from the Troops tab, or are you actually doing a proper Test Play where it launches the full game? Some plugins work when you play the game, but not when you do battle test, so once you have those plugins, you shouldn't use battle test anymore.

    When did you download MV, and did you get it from this site, or from steam?
     
    Last edited: Jan 17, 2018
    #4
  5. Rook47

    Rook47 Veteran Veteran

    Messages:
    33
    Likes Received:
    2
    First Language:
    English
    Primarily Uses:
    RMMV
    Ok so here is what i get when I do F8

    upload_2018-1-17_10-19-40.png

    I dont have yan fly animated battlers

    Downloaded game from steam 8 months ago

    have rpg core js 1.0

    am testing it through opening the play test button
     
    Last edited: Jan 18, 2018
    #5
  6. Shaz

    Shaz Veteran Veteran

    Messages:
    37,816
    Likes Received:
    11,523
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    Did you have the trial version of MV prior? 1.0 is a VERY old core.js file - the very first one that came out. If you only got it from Steam 8 months ago, I'm thinking it should be at least 1.4.

    When did you create this particular project?

    The console log did not identify any particular plugin responsible for this error, which surprises me.

    On checking my old versions, it looks like your core.js is 1.0 but your rpg_sprites.js is 1.1 - any chance you have a mash-up of versions by manually copying files around the place?

    I suggest you make sure your MV is up-to-date on Steam, start a brand new project, then copy your project across - everything except the index.html and default files in the js folder. Make sure all your plugins are up-to-date as well.
     
    #6
  7. Rook47

    Rook47 Veteran Veteran

    Messages:
    33
    Likes Received:
    2
    First Language:
    English
    Primarily Uses:
    RMMV
    Ya I bought it 8 months ago and started the project right away I've even made other game projects and those are 1.0 also how can i update these plugins?
    I never used a free trial version
     
    #7
  8. Shaz

    Shaz Veteran Veteran

    Messages:
    37,816
    Likes Received:
    11,523
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    Have you got Steam set to use a demo/specific version instead of the latest, and to not download updates?
     
    #8
  9. Andar

    Andar Veteran Veteran

    Messages:
    28,645
    Likes Received:
    6,584
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    First, you need to make sure that steam updated your editor to the latest version, you can do that in the editor yourself.
    After that, you need to manually update your project by copying the required files from a new project into your old project. You can find instructions for that on every update topic here in the forum, the latest is 1.5.1 and should be linked in the banner at top. Don't forget to backup your project before updating however.
     
    #9
  10. Shaz

    Shaz Veteran Veteran

    Messages:
    37,816
    Likes Received:
    11,523
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    no, it's not :( The link to the 1.6 beta is there. I had to go hunting for the 1.5.1 thread the other day.
     
    #10
  11. Rook47

    Rook47 Veteran Veteran

    Messages:
    33
    Likes Received:
    2
    First Language:
    English
    Primarily Uses:
    RMMV
    Ok so i tried to make a new project and transfer my stuff and that didn't work and rpg maker is 100% up to date what should i do?
     
    #11
  12. Shaz

    Shaz Veteran Veteran

    Messages:
    37,816
    Likes Received:
    11,523
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    When you created the new project and transferred your stuff, did you inlude the js files? You should not, because that's reverting your new project back to the old version again.

    If you create a brand new project and go straight in and look at core.js, what version is it?
     
    #12
  13. Rook47

    Rook47 Veteran Veteran

    Messages:
    33
    Likes Received:
    2
    First Language:
    English
    Primarily Uses:
    RMMV
    its was 1.5.1 and i transfered that rpg core engine to the current project i only transfered to the new one yan fly quest and core engine
     
    #13
  14. Shaz

    Shaz Veteran Veteran

    Messages:
    37,816
    Likes Received:
    11,523
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    So you're transferring from the new game into your current project, or the other way around?

    If going from the new project to the current, you need to copy index.html, the js folder except the plugins.js, and also the js/libs folder.
    If going from the current project to the new project, you need to copy everything BUT those files/folders.
     
    #14
  15. Andar

    Andar Veteran Veteran

    Messages:
    28,645
    Likes Received:
    6,584
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    Of course that didn't work, because that is the wrong way. As I said above you need to copy specific files from the new project into your project, NOT transfer your data. You shouldn't even touch the data files at all.

    Can you give us a screenshot of the beta tab in the steam program properties?
     
    #15
  16. Rook47

    Rook47 Veteran Veteran

    Messages:
    33
    Likes Received:
    2
    First Language:
    English
    Primarily Uses:
    RMMV
    Where can I find the beta tab in the steam program properties
     
    Last edited: Jan 18, 2018
    #16
  17. Andar

    Andar Veteran Veteran

    Messages:
    28,645
    Likes Received:
    6,584
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    Right-click on the program name in the steam client (in this case MV), then select properties and then select beta
     
    #17
  18. Rook47

    Rook47 Veteran Veteran

    Messages:
    33
    Likes Received:
    2
    First Language:
    English
    Primarily Uses:
    RMMV
  19. Andar

    Andar Veteran Veteran

    Messages:
    28,645
    Likes Received:
    6,584
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    OK, that means your editor is on the correct version - there are some beta options that might have caused problems here if selected.

    So what is now the status after you tried the correct way of updating again?
     
    #19
  20. Rook47

    Rook47 Veteran Veteran

    Messages:
    33
    Likes Received:
    2
    First Language:
    English
    Primarily Uses:
    RMMV
    I still get the error
     
    #20

Share This Page