Images, text, & hotspots sometimes do not appear?

ithimar

Villager
Member
Joined
Apr 30, 2020
Messages
14
Reaction score
0
First Language
English
Primarily Uses
VNM
I'm setting up a catalog for items that a player can find in my game. The catalog is several pages long. Each catalog page is its own scene. I am using 'show image' (arrows) with an 'add hotspot' connecting to the image for menu functionality. Normal stuff that I've been doing for nearly everything in the game and its functioned great... Until it doesn't?

When I test the game the hot spots and images work at first, but after clicking through the pages a few times, sometimes the images (and some of the 'show text' text as well) stop functioning. It eventually deteriorates to a point where none of them appear.
This seems totally random and I can't explain it. It's particularly strange that they would work fine the first time you view the chapter but but then become erratic when returning to it a few clicks later.

The individual code for the catalog are copy pasted so the code for each page is identical, except for the hot spots that link to different scenes, and other details that are irrelevant to the issue (the code for the actual pieces in the catalog, etc). All images, text, and hotspots are erased just before changing to the next scene so it doesn't make sense that there'd be any conflict there. The same issue appears whether I am testing within VN Maker's game test as well as exported versions.

I'm at a loss and I really need these pages to work reliably. I'm worried because I am also using image + hot spots for the items in the catalog. If they show the same unreliable behaviour in the catalog, that is going to be a huge issue. I can't imagine VNM would be released with such a big problem (images just not appearing in a visual novel? that's huge) so I'm sure I'm overlooking something but I can't seem to find it!
 

Attachments

ithimar

Villager
Member
Joined
Apr 30, 2020
Messages
14
Reaction score
0
First Language
English
Primarily Uses
VNM
I've spent all night trying a couple dozen different workarounds and I get the same results every time. I've been spending months working on a project assuming that VNM could reliably do this kinda basic stuff and it's super disappointing to see it not working reliably... That said I would love to be proven wrong here. VNM is a great program but if it doesn't produce a functional product what is the point.
 
Last edited:

ithimar

Villager
Member
Joined
Apr 30, 2020
Messages
14
Reaction score
0
First Language
English
Primarily Uses
VNM
Has this happened to anyone else? Would love some help here. Trying more things and still the same problem. If I can't get it to work I have to start over in another program.
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Yaaay! My second public script is out and approved! A VX Ace Final Fantasy IX styled Throw Script!

I look forward to all the constructive feedback I get but most importantly I hope everyone who ends up using it enjoys!

Yaaaay! Making scripts is fun lol. :D
When you're lost out therrrrre and you're alllll alone, ahwahwah waitin, to carry you hooooommmme, uhhheverywhere you look! (someone hit me with those backing vocals)
X.X cant focus... too many thing want do... help!
Day 2 of teaching MV, student can move cat across the map.
Got inspired and started writing a simple tower defence battle system last night :o

Forum statistics

Threads
100,525
Messages
976,813
Members
132,080
Latest member
nwr
Top