In-Game Manual

Oscar92player

Veteran
Veteran
Joined
Jul 26, 2012
Messages
497
Reaction score
219
First Language
Spanish
Primarily Uses
RMMV
Not to come off as necropost content (for obvious reasons) but when I recently finished working off an export I seem to have run into a major issue with this plugin. Not sure if it's related to other plugins or not (considering most of 'em are considered "priority critical" - obviously including this one - and the only potential issue being Orange Greenworks because of the nwjs upgrade it requires) but when I recently put my work through export it loads the manual properly yet still fails to account for the custom background even though it's in the proper place. Specifically, it's telling me that it can't find the background image (fieldguide.png in my case) even though I haven't changed where the image is located or messed with the plugin itself.

For the record, it still loads the manual as usual but the background is completely blank and fails almost immediately even despite that it's totally, 100% there... and then it hits me with the following message:

Failed to load: img/system/fieldguide.png

If it works better (in terms of procedure or whatever else) I can extend or move this to its own discussion but suffice to say that my experience with this issue has just recently started, and going without the background change didn't work either. That and I haven't done anything with manual.txt. A list of my active plugins can be provided on request if it helps to figure this out.
This may be due to the Manual Background being encrypted. I've tried on deployed projects with encryption and without encryption, and the plugin only works fine if the file is not encrypted.

Just copy the PNG image without encryption on your deployed project, within the img/system folder, and give it a try.
 

BreakerZero

Veteran
Veteran
Joined
Jul 8, 2018
Messages
853
Reaction score
349
First Language
English (USA)
Primarily Uses
RMMV
Thanks for the update. I was not using encryption for anything used by plug-ins (those are handled by my launcher app that I recently put together for which I use package files to load my confidential assets and which are cleaned up after the game session is over). But I will at least check for duplication in case there's anything caught in the way. (That said, I am pushing the file to where it belongs so I know it's not from that.)

EDIT: No dupe so I have no clue. It's there when I need it to be, however it still doesn't work. That's why I'm wondering if there is a difference in nwjs relative to the version required for Greenworks.
 
Last edited:

BreakerZero

Veteran
Veteran
Joined
Jul 8, 2018
Messages
853
Reaction score
349
First Language
English (USA)
Primarily Uses
RMMV
At this point I'm totally going to give up on this and completely rewrite the field guide mechanism for my project. With the absence of the OP and a lack of updates regarding my issue I am unfortunately going to move on and declare my request as unfulfilled, and in doing so I leave this conversation with a full public advisory that use of this plugin should be considered unsupported and potentially incompatible with some of the other available plugins by consequence of the issue at work in the case of my own inherent problems. Not saying this for certain but it is entirely possible and therefore should be approached with caution as there's no guarantee of compatibility with everything and with the OP gone that is unlikely to change at this point.

I will leave it up to the mods to decide on where to go with this. While my reasoning here was totally legit (unlike 99.99% of otherwise well-intended necropost content that is considered an unnecessary and unwelcome distraction under forum rules) I also understand that sometimes these things don't work out as you'd like 'em to and that this may have been an issue best left undisclosed due to the lack of active support. In this case I'm going to give up completely as without further understanding of what may be causing the issue - and even despite the presence of the required files - my consensus is that it was never meant to be in the first place.
 

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
6,794
Reaction score
4,636
First Language
Dutch
Primarily Uses
RMXP
The necroposting rule doesn't apply to Plugin/Script Releases/Resource Showcase/Project Threads. However, you did double post, so

Edit: Misread the date. Apologies about that :aswt:
 
Last edited:

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,138
Reaction score
13,639
First Language
English
Primarily Uses
RMVXA
I should add that the poster of this thread hasn't been online here since 2016, so odds are high if you want support for this you'll need to create a thread in plug-in support.
 

nephlm

Villager
Member
Joined
May 20, 2019
Messages
7
Reaction score
1
First Language
English
Primarily Uses
RMMV
This is probably a shot in the dark given how old this post is, but would anyone know if there is some way to add conditional statements to the text in this plugin? I want some of the text options to change based on whether I have certain switches turned on or off. Something along the lines of:

<text>
The character's name is John.
if switch.birthday is on
{
birthday: January 15th, 1155
}
if switch.hobbies is on
{
hobbies: soccer
}
. . . . .

For slight changes in text I think it would be inconvenient to make each of these as sub-entries. I can also make separate entries for each possible text combination but that will take a while and then I have to some how have each of the possible entries use a different name. Any help is appreciated.
 

BreakerZero

Veteran
Veteran
Joined
Jul 8, 2018
Messages
853
Reaction score
349
First Language
English (USA)
Primarily Uses
RMMV
This is probably a shot in the dark given how old this post is, but would anyone know if there is some way to add conditional statements to the text in this plugin? I want some of the text options to change based on whether I have certain switches turned on or off.
Based on the current design, I'm not 100% sure if that would be worth the attempt (but don't quote me on that as I've seen cases where my initial analysis is not necessarily on target and then someone comes around and figures it out). Furthermore:

I should add that the poster of this thread hasn't been online here since 2016.
So if you're looking for something beyond what's already included or any ideas for improvement I suggest that you see if someone can analyze what's already here and see what they can do. Plugin requests may be the way to go, but I'm not 100% sure of that (otherwise you're better off explaining this in plugin support, it should be one of those two where you can bring that up).

EDIT: Speaking of blown expectations, my compatibility concerns from before have since been resolved. Only thing now is a rather annoying issue where images don't appear until you switch out from a page with the image and then switch back to said page.
 
Last edited:

SiiOs

Villager
Member
Joined
Oct 13, 2017
Messages
16
Reaction score
4
First Language
English
Primarily Uses
RMMV
Kind of a random post but if anyone is having issues using this in 1.6.2, I found a fix that seems to work for me.

On line 802 change
this._backgroundSprite.bitmap = SceneManager.backgroundBitmap();
to this
this._backgroundSprite = SceneManager.backgroundBitmap();

Been working for me since. Could still create some issues but so far I've had none. Hope it helps some people.
 
Last edited:

BreakerZero

Veteran
Veteran
Joined
Jul 8, 2018
Messages
853
Reaction score
349
First Language
English (USA)
Primarily Uses
RMMV
Kind of a random post but if anyone is having issues using this in 1.6.2, I found a fix that seems to work for me.

On line 802 change
this._backgroundSprite.bitmap = SceneManager.backgroundBitmap();
to this
this._backgroundSprite = SceneManager.backgroundBitmap();

Been working for me since. Could still create some issues but so far I've had none. Hope it helps some people.
If that has anything to do with the image display problem I can test and upload a patch release when I have a chance to do so (which I may have to do off the record in terms of real life relations due to unplanned incidence).
 

SiiOs

Villager
Member
Joined
Oct 13, 2017
Messages
16
Reaction score
4
First Language
English
Primarily Uses
RMMV
Oddly enough I had no issue loading custom backgrounds at all and so I didn't modify that part of the code.

This specifically helps load the blurred background when no custom image was set.
 

BreakerZero

Veteran
Veteran
Joined
Jul 8, 2018
Messages
853
Reaction score
349
First Language
English (USA)
Primarily Uses
RMMV
Fair enough. Any chance based on this where you can check the code in relation to page images? Specifically I have a question about whether or not there is any relationship between this and having images not load until you switch back from another page.

What I mean is that when you open a page reliant on an image that is completely blank, and then you switch to another page that only shows it's text with no image to go with it. Then you switch back to the image-reliant page which now shows the image (and likewise with the mixed content page which now shows its associated image).
 

SiiOs

Villager
Member
Joined
Oct 13, 2017
Messages
16
Reaction score
4
First Language
English
Primarily Uses
RMMV
Just saw one of the other posts. For the other guy who wanted conditional statements, the best bet is to just use the "HideManuelEntry" based on certain switches being on or off. Each map could check for those switches, and you could even hide one entry and have another one on, then switch them both on/off depending on what you want so that only one is showing at a time. One could have more information while one could have less.

Looking at the plugin, it would take a bit of re-writing to accomplish but it would just be better to use the hide/show manual entries.

As for your thing BreakerZero, the line for custom backgrounds is right next to the other one, on line 804 but I'm not entirely sure as to why you're having the problem you are having. I read your posts but just wanted to double check...are you trying to put custom pictures on each page? Multiple pictures? Or just doing a custom background? The code for putting custom pictures on the pages is separate but I haven't touched that either because in 1.6.2 and 1.5.2 they're both working for me.

Edit: In case you were talking about pictures on the page, here's what I have. I only put one but they were working great.
 

Attachments

BreakerZero

Veteran
Veteran
Joined
Jul 8, 2018
Messages
853
Reaction score
349
First Language
English (USA)
Primarily Uses
RMMV
Well, now I have another issue to deal with. Seems that changing the definition that you mentioned has screwed things up with a "parentID of unknown" situation, or at least in my case.
 

Al-Farizi

Lv 87 Warrior
Member
Joined
Oct 2, 2019
Messages
28
Reaction score
1
First Language
English
Primarily Uses
RMMV
Nice window where you got that?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

Imagine every unfunny joke gets a laugh track, and it doesn't top until you genuinely laugh at that unfunny joke.
I miss lockdown already. Since the pubs reopened, there's been nothing but loudmouthed drunks wandering about my neighbourhood.
Twitter is making me embarrassed to be a Persona 5 fan rn
I don't wanna be called out when I say P5R is my favorite game :kaoswt2:
And my first batch of gobbo battlers is up *yay* (images should show now as they first didnt - Just my luck lol)

Forum statistics

Threads
99,555
Messages
966,696
Members
131,187
Latest member
Bibunbun
Top