Install RPGVXACE in Ubuntu

Discussion in 'RMVX Ace Tutorials' started by Peltron, Jul 8, 2012.

  1. Peltron

    Peltron Orange Ventius Leader Veteran

    Likes Received:
    First Language:
    I figured I should share this with everyone else. I do not own ACE yet, so I just used the trial and never activated it, 'cause I didn't want to. I did however try VX and it works fully; played tested it and everything. Also, you must use the latest Ubuntu upgrade, "12.04 LTS". This also allowed me to install VX on Ubuntu as well. Since I have my full copies on Windows, I used trials for this. You could try 11.10, but nothing before that seems to work.

    This is but one way to fix the DRM errors, DirectX errors and sound errors when installing on Ubuntu. It might also go slower than it does on Windows (for me, it runs FLAWLESSLY except when first executing the exe), but if you are desperate, you won't care much I think. But the good news is, each and every Ubuntu update and WINE update makes this more and more possible! For example, CS4 and CS5 are usable on Ubuntu now, though I have not tested it myself.

    Sometimes this doesn't fix it for everyone. It solved it for me, and four other friends of mine. I think I found a "reason" as to why. Sounds cards and PC info. I really don't know how to explain this, but sometimes (I have three Desktops, one of which this didn't work on) PCs in Ubuntu won't accept some of the WINE installations. Though you are welcomed to try installing it else where to see if it can be fixed. Overall though, I've only met two people this didn't work for, three if you count my third Desktop computer.

    Lastly, I hope this was the right place to put this tutorial. I apologize if I erred, moderators and admin team. :(

    Since it worked for VX, this also goes for that. I have not yet tested XP fully, but I will when I get my drive back.


    Okay, the process may seem long and hard, but its not. I have spent all day trying to get it to work in 11.10, but it does not. You must update to the newest Ubuntu. This is a screen shot showing I got it to work, in case others doubt me or something (I once said it was possible, and got chewed out, so I'm being careful xD):

    To update to the newest version, there are many options; 1) there is searching up "Update Manager" by clicking this:


    and then clicking the "Upgrade now" button, or you can click this:


    And then select the updating option.

    Now we need to upgrade the WINE application. If you haven't upgraded to the newest Ubuntu, do it now, restart and continue. Only after that point, unless you wish to try it on 11.10 first, should you continue.

    Open up the Terminal Window (you can search for it in the search bar mentioned earlier) or you can try this shortcut prompt: CRTL + ALT + T

    Now, type the following sudo commands. All of them must be separate! So that means pressing "ENTER" each line. If you worry about typing the sudo commands out yourself, then you can select each line, copy and paste it into the Terminal by right clicking and selecting "PASTE". You will be prompted for your password now.

    $ sudo add-apt-repository ppa:ubuntu-wine/ppa
    $ sudo apt-get update
    $ sudo apt-get install wine
    Once you installed that, we need DirectX; something VERY important to RPG maker games. It is a Windows based native, but it can be run through WINE. But first, we need the latest Winetricks. Open the terminal window again and type the following all as separate sudo commands:

    $ wget
    $ chmod +x winetricks
    $ sh winetricks
    This should bring up the winetricks program. It looks like this:

    Check "Select the default wineprefix" if it isn't already, and then hit okay. Now check the first option, which is "Install a Windows DLL or component" and hit okay once again.

    Another window should pop up with hundreds of options. Search for the following and check them:


























    Plus, the following:

    dotnet20 (MS .NET 2.0); You NEED this file for this to work!

    And make sure you have "gdiplus" checked as well.

    And then hit OK and it will install them all. If you get any errors installing the DirectX, please take pictures of them and provide them, as well as tell me exactly what you did, because this should work.

    Now we need to install TiMidity; a MIDI solving thingy-ma-bob. Open the terminal window again and type:

    $ sudo apt-get install timidity
    And then let it install. You might have to say "yes/y" to continue and you might have to agree to let it install extra stuff. Say yes. Reboot the computer just to be safe.

    When you get back into Ubuntu, its time to start the most important process, I think. Installing all of the RPG Makers. That's right, all of them. You can just use trials though, that's what I did at first, though i later dragged my files from Windows over to continue where I left off with my games.

    First, download RPG VX (Not ACE) and RPG XP and drag them to the desktop. Time to drag ACE to the desktop as well, JUST THE INSTALLERS THOUGH. You might have to extract them. Put them all in folders separately called "RPGVX Setup" and so on.

    Now we need to go to Program files and create a folder called RPG Maker, or put this folder in Common Files, if you are dual booting like me. This will make sure it won't erase the Windows install of the makers or overlap each other and cancel everything out.

    So for example, this is what mine looked like:


    Which is "500GB\programfiles\commonfiles\RPG Maker\" This is important, okay? All of the files must go in the same folder, or this won't work. *Also, it will install under ".wine" folder. The "." makes folders/files hidden. I will get into this on the second post*

    First, we need to install VX, not ACE, so you need to go to Uninstall WINE Software. This won't effect WINE, but its actually the panel to install things through it. I don't know why they decided to call it "UNINSTALL" only, since it does both and more.

    You should see this:

    You see the red boxed thing? That's how you install new things; we'll need to click that.

    But first, take a look at the stuff I boxed in blue. This is how it should look after you are done with everything. Ignore "MSVCRT Redists"; though; but if you want, you can install it just in case (by checking the list I mentioned earlier, or searching it up in Dash Home). Now back to the red; click the "INSTALL" button and navigate to your desktop.

    Here, open up the folder that has the install files for RPGVX, not ACE, and install the ACTUAL MAKER before the RTP. For example, this is what it looks like for me, e.i, where I installed:


    All of it must be inside of RPG Maker folder! Do not make separate folders for ACE, XP and VX!

    So, set up the RPGVX program, NOT THE RTP, to this folder first. Install it and then open up the Uninstall WINE software again, this time we select VX's RTP. We'll install it in the same folder, so do it. If it says "This folder already exists, would you like to install inside this folder anyway?" click yes; do no worry about it. After the RTP is installed, we need to install the trial of XP. *You can install FULL versions if you have them instead of trials*

    Actually, I just realized I couldn't install XP, or at least it doesn't show up, or I forgot if I did or didn't. Just in case, we'll still include it. Do the same steps as above in the same folder. Though, if it asks to erase VX stuff, say no and I guess skip the XP step. However, if it lets you install without erasing VX stuff, good, continue. And then install XP's RTP and if it says "This folder already exists, would you like to install inside this folder anyway?" again, say yes!

    Now that we are passed that, we need to install ACE! Boo-ya!

    Open up "Uninstall WINE software" again if you closed it and click the Install button again.

    This time navigate to the ACE set up folder on the desktop and install the GAME first, not the RTP. Put it in the same folder as VX.

    It shouldn't ask you to merge or replace the normal VX, if so, stop. Something went wrong. If not, continue. Now do the same for the RTP; it might say "This folder already exists, would you like to install inside this folder anyway?" again, if so, say yes.

    If all goes well, BAM, you have ACE installed. To run the game, you should have a desktop shortcut. If that doesn't work for you (give it about a minute to load), go to the install folder and execute the exe of ACE install by right click and running with WINE LOADER. I need to explain a few more things in the next post, but that should be all.

    There you go. It works. Please post your problems, your Ubuntu version, your PC specs and what you did and didn't do.

    Enjoy Linux users! You have a great game maker now!


    ✓ = completed and tested

    [unchecked] = I have not yet tested, will do next

    = failure; does not currently work with WINE's udpate.

    UBUNTU 11.10/12.04 LTS TESTING

    • Laying tilesets down =
    • Play testing =
    • Opening from the "game" exe =
    • Playing around =
    • Text read and imputing =
    • Importing Graphics =
    • Database (Entering, editing etc etc; LARGE update from before, where you couldn't even enter the DB.) =
    • Script editing and script menu =
    • Music import =
    • Playtesting with BGM on map = & (Lets you import, but you can't hear any BGM and when you make a music event, playtest doesn't work. You can't sound test BGM or ME)
    • BGS and SE Testing =
    • Any music on map = (Lets you import, but you can't hear any BGM and when you make a music event, playtest doesn't work.)
    • Anything else I am missing = [unchecked]

    As things are found and checked as either working, sorta working or X for not working, I will continue to find ways to update and fix it, if its possible with the current build of WINE. Each WINE update will be provided as a LOG edit here in this thread.

    Please be patient as this updates with solutions etc etc. It will also help if you privide any other errors you might have had, or if you can tell me what to test and add to the list.


    I have heard that some people did not need to install the other makers to get this to work. You are more than welcomed to do that, if you want. If you find other ways to install RPGVX/ACE in Ubuntu, then please share!
    Last edited by a moderator: Jul 8, 2012
  2. Peltron

    Peltron Orange Ventius Leader Veteran

    Likes Received:
    First Language:
    ============================TUTORIAL PART 2====================================

    When you have everything installed, its time to make shortcuts and find out where everything went. See, when you install through WINE, it doesn't go into "PROGRAM FILES", but through WINE'S own directory. For example, if you followed my guide thoroughly, you should have installed all the makers into a folder called "RPG Makers" which should have been located within "PROGRAM FILES > COMMON FILES > RPG MAKER".

    But you might have gone there, seen the folder and went inside to find it empty right? Well, yes, that's because it is. That's, what I like to call since I don't know the official term, is a "shadow" of WINE'S install. So it is still inside PROGRAM FILES, but not as though you were running Windows.

    For example, for me the install location through WINE was:

    /home/UBUNTUUSERNAME/.wine/drive_c/Program Files/Common Files/RPG Maker/RPGVX.exe

    The "UBUNTUUSERNAME" is your username, so whatever you made it, it will instead be that instead of "UBUNTUUSERNAME".

    Now, after that, you see "/.wine/". That "." before the file tells Ubuntu to "hide" that file and or folder. So, first you need to open the HOME FOLDER on the far left and to the left again, click "HOME". You should only see a few files like Documents, Pictures etc etc.

    Press CTRL + H to show the files. Hundreds of more things should pop up. Don't get adventurous and search through them all, just find ".wine" folder and get inside of it. The folder should be near the button of the scrolling, though it will vary depending on how much stuff you installed in Ubuntu.

    Once inside of ".wine" folder, you should see "drive_c" ("C" might be different for you I think?)" and then "Program Files" and inside of that, "Common Files". Once again, click inside of that folder.

    Now you will see the folder I told you to make called "RPG Maker"; inside of this, it should not be empty. You should see all the RPG makers in here that you installed, including the EXEs and DLLs.

    What we want to do in here is make a shortcut, though it might not work for you, on the desktop. Unfortunately, 11.10 and the newest Ubuntu no longer has that awesome feature where you right click the desktop to make a shortcut (called a "launcher" in Ubuntu), you need to install something and do some codes -- but its really easy.

    Open up the terminal and paste or write this code:

    sudo apt-get install --no-install-recommends gnome-panel
    And then type/paste this code after the install of the above:

    gnome-desktop-item-edit ~/Desktop/ --create-new
    The second code should make this appear:


    Of course, yours shouldn't have that text in it. Here you can give a suitable name for the launcher and in the command field enter "the name of the program and click OK. Though for this, you have to search for the file yourself and then HIT OKAY.

    IF this all goes well, you should have a launcher/shortcut on the desktop. Now you don't have to go to the ".wine" folder to execute the game every time you want to use it.

    This works for everything else in Ubuntu as well.

    And now you can run VX and VX ACE! Look how pretty it looks in Ubuntu!

    In action video:

    Any questions, please post them. If you didn't understand something, or if something isn't there for you, please share and I will try to help. If you are activating your systems and receive an error, check out this thread and do as it says. If they still persist, I will figure out how to get passed it. :)
    Last edited by a moderator: Jul 8, 2012
  3. Psyker

    Psyker Degibeta Team Veteran

    Likes Received:
    First Language:
    Primarily Uses:
    Might have to pick up a copy of RPG Maker VX Ace for my laptop. I've been running Ubuntu on it for about year now and been considering putting Windows 7 back for RPG Maker.
  4. Peltron

    Peltron Orange Ventius Leader Veteran

    Likes Received:
    First Language:
    You should probably test out the trial first before you purchase it to see if it works for you. :)

    Also, updated with an "In action" video of me using it! Hope everyone likes it! Also, if Ubuntu users are wondering, I recorded that video very easily by using Kazam. You can get it by Synaptic Package Manager, or Terminal with this code:

    • sudo add-apt-repository ppa:bigwhale/kazam-oneric
    • sudo apt-get update
    • sudo apt-get install kazam

    For older users, use this code:

    • sudo add-apt-repository ppa:vanhoof/kazam-scratch
    • sudo apt-get update
    • sudo apt-get install kazam

    That will install Kazam. Then you can run it and record all in the matter of minutes! Great for game trailers, tutorial video making and more. ;)

    Ubuntu is amazing! Been using it since 2001-2002!


    I have created a LOG on the first post explaining what I have tested so far and marked as "working" etc etc. Please take a look at the LOG and remember to check it every so often!
    Last edited by a moderator: Jul 8, 2012
  5. Peltron

    Peltron Orange Ventius Leader Veteran

    Likes Received:
    First Language:
    Update I forgot to include the other day:

    Okay! I broke my install of Ubuntu because I goofed, if I did not say that before, so I've been spending this time reinstalling a FRESH install of Ubuntu 12.04, which if you want to do just say so and I can do a tut for that or something. I would advise against this unless you can't boot into your menu anymore because of TiMidity? If you have not yet gone through this tutorial, you should be cautious and aware if you don't already know this, that you should follow by your own caution. I am not making you do this. Just to be safe, back up your stuff!

    The reason I advise against it is because it took me FOREVER to get this new stupid update (okay, she's not stupid, just stubborn!) to install the NET files needed. I finally did it with lots and lots of trial and error and everything installed fine again. I tested the same errors that broke it before when play testing with the two types of music on, and its still there.

    But guess what? I was curious as to why it would play some music and not others so I took a look into the Audio folder for VX, since that's what I have, and I saw that the two types that refused to work were....MID files! I think I can find something that can make WINE and Ubuntu support this type of file and fix the only known problem I have come across. SO MID files don't work or better to be said as "not yet supported", but "ogg" play fine.

    Isn't that exciting? Well, I won't know for sure until I run off with my Ubuntuing. Goodbye for now folks! I hope to bring a change to users of RM. [​IMG]


    I have tested everything I could think of in Ubuntu running RMVX through WINE. I didn't encounter a single problem, unless you count the MIDI problem. See, Ubuntu cannot run MIDI files because its not native to it. That isn't to say its impossible to run MIDIs, because I have and did. There are many ways to getting MIDIs to play in Ubuntu. TiMidity is one of them, and requires a lot of work of editing as I just found out. Unless you were lucky enough to get that TiMidity install to work with MIDIs, of course. I'm just the unlucky one, it seems.

    Well, anyways, I'm still trying to figure out how to edit the config file for TiMidity and everything else to get it to run properly, so I will post the solution as soon as I can, promise. However, don't let this stop you from playing and making Ubunter users. Why? Because there is another simple and quick solution around this temporary MIDI problem.

    Ogg replacement.

    Ubuntu has no problem playing them, and I tested it out and it worked. I went in and converted "Airship.mid" to "Airship.ogg" and imported it. It worked fine! If you watch the video below, please don't think the system runs this game as slow as tectonic plates--IT RUNS FLAWLESSLY! Its just...well, read the video description please! You'll see why it looks slow in the video.

    So, if you are desperate, then just convert all the MID/MIDI files to OGG once you install the game. "How though?!" you might ask? You could do it many ways, but I did it via Ubuntu. Open up the terminal (CTRL+ALT+T) or searching it up in Dash Home, and sudo apt-get install oggconverter. However, I would say open up Software Center and search up "OggConverter" and install it that way. Seems to install things better that way for me, and its easier for the starters of Ubuntu.

    Once you have that installed, go to Dash Home and search it up and then open it. Before you close it, look over at the left to the bar with all the programs/folders on it. You should see OggConverter's logo. Right click it and pin it to the Launcher. This way, you don't have to search for it every time you want to use it, you can just double click it.

    Once you are in OGGC, open up the MIDI file and select OGG as the output, select where you want the convert to save at and then convert. Bam! You are done! ;)

    There is another thing you probably noticed in the videos I presented. The bars, like this, are missing, huh? Well, they disappear for some odd reason when WINE is run. Its not broken and you can easily still "x" off programs etc etc even without them. There are many options, two of which is 1) On the top, when you scroll over it, you should see a line of "file, edit," etc etc. In File, you can exist the programs. 2) To the far left, on your Home DashBoard, you can right click and quit.

    So...currently, unless you have something for me to test and report back on, RMVX (Ace should as well!) works beautifully on Ubuntu now! So Ubuntu users, enjoy! I certainly did fiddling with it in Ubuntu!

    Remember, I will post the solution to the MIDI problem as SOON as I find it out, so keep an eye on this thread, report problems, crashes, questions etc etc and I'll get to it as quick as The Flash. ;)
  6. bassfire

    bassfire Newbie Scripter Veteran

    Likes Received:
    First Language:
    I really hate to necropost, but I'm running Ubuntu 12.04 64-bit and Microsoft .NET Framework 2.0 won't install. It says it can't install on a 64-bit OS.

    However, I went ahead and installed RPGVX anyway and the editor works perfectly, except I can't playtest.

    It gives me 'Failed to initialize DirectX Audio'

    If anyone knows how I can fix this, please help.

    Edit: My solution was to switch to a 32-bit OS. I hadn't realized my laptop had only 2GB RAM (for why that matters, click here.)

    Still, it was a bit wonky to install on Ubuntu 12.04. Here's what you do.

    *NOTE* I did this on a FRESH install of Ubuntu 12.04 32-bit.

    Follow everything the topic post tells you to do. However, do NOT install the following:








    After you have everything else installed, then you can install dotnet 2.0 - it will open up two windows (the folder for dotnet 2.0 and your internet browser) simply download what it says to, and drag it over to the dot net folder. Then go back to winetricks and download the rest of the stuff.

    There was also a problem with gdiplus. Just do the same thing as with the dotnet 2.0 and you'll be golden.

    I have NOT tested RPGVX yet, but I am installing and will report back.

    Playtesting seems to work fine now. As originally stated, the sound does not work. However, I transferred the project onto my PC via flashdrive and you can hear the music perfectly on there.

    I hope that this helps those who are new to Ubuntu and want RMVX/Ace.
    Last edited by a moderator: Oct 17, 2012
  7. Peltron

    Peltron Orange Ventius Leader Veteran

    Likes Received:
    First Language:
    I'm sorry for the lateness! My account (email) got hacked and I haven't been able to access it for a really long time to reset my password for this forum. My best friend hosts my videos for me (I do not wish for a Youtube account--I've been hacked there before, too), so if I never get back again here, please comment on her videos for the Ubuntu showcase! I'll be able to know if anyone has problems because she allows me to use her account! Thank you!

    I wish I could have been here to help. Anyways, to clarify, you did not install dotnet20, or is it that entire list? I'd like to be able to make edits to the main post linking back to users who have self-fixed problems or whatnot.

    And yes, the music will work outside of Ubuntu. However, having events with the music on while game creating will result in a crash or none play while in Ubuntu. Simply converting to OGG (if you don't play to keep switching from Ubuntu to PC) will do the trick. And then, even if you publish your game, everything should be able to still hear. Hmm...I should research that.


    A fresh Ubuntu install usually fixes things. Sometimes installing, especially if updating from an older type, will result in corrupt files.
    Last edited by a moderator: Nov 24, 2012

Share This Page