Status
Not open for further replies.

BrandedTales

StoryTeller
Veteran
Joined
Dec 30, 2016
Messages
203
Reaction score
116
First Language
English
Primarily Uses
N/A
Good evening all -


I hate for one of my earliest posts to be a troubleshooting thread, but I'm stuck and I don't know what else to do to troubleshoot.


I am using RMMV 1.3.4 via Steam.  I have not updated (to my knowledge) since I bought it a couple weeks ago.


I have no active plugins.  


I am using a mix of tilesets including the basic (RTP I think just from my reading), plus some of the FSM "Town of New Beginnings" tile sets.


When I try to launch a playtest, the screen immediately jumps to a black screen and throws a "TypeError undefined is not a function."  F8 does not bring up a Developer Console.  Nor does F12 (saw that posted on a thread somewhere).  I did not have this problem last night.


I've made a few changes since then:  


- I merged a few sprites onto a backup of one of the tilesets I'm using (copying over existing spaces).  Within the editor, it looks fine.  I tried going to a non-merged tileset just to check this; didn't help.


- I've added several enemies and troops.


- I've added several new maps and scripted events.  


- I populated the passage/passability of several items on the FSM tileset which had been set by default on load to all passable.


I'm happy to post any screenshots or try any trouble-shooting recommended, but I'm really at a loss for where to even start.   In theory, I've "only lost a day" but it's a pretty painful day to lose because I normally only get 30-45 minutes a day to work on this (real life), and today was a nice, extremely rare 6 hour block of time while the kids were at their grandmother's.


Any ideas or additional details needed?  Hope you guys know some magic!
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,818
Reaction score
14,979
First Language
English
Primarily Uses
RMMV
You need to get the developer console working, as we need to see where that error is coming from.  I'm not sure why it's not letting you pull that up - I had the same issue once, but it resolved itself without my doing anything (or at least I don't recall doing anything to fix it).


If you create a brand new project and test play without making any changes to anything at all, does it work?
 

BrandedTales

StoryTeller
Veteran
Joined
Dec 30, 2016
Messages
203
Reaction score
116
First Language
English
Primarily Uses
N/A
Yes.  I forgot to mention a fresh project worked just fine.  I also pulled up another project that i had done work on and that worked as well...


So the issue appears localized on this project.  I'll try loading this up on a different PC and see if the developer console works on that one.  Is it possible the developer console only launched when the game has finished initializing? 


I tried a plugin that causes the developer console to launch immediately upon game load, and that did not launch it either.  (I then removed the plugin).
 

BrandedTales

StoryTeller
Veteran
Joined
Dec 30, 2016
Messages
203
Reaction score
116
First Language
English
Primarily Uses
N/A
Additional update:  I have tried to launch on another computer and run into the same issue.


Also, I have been able to successfully launch the developer console on other projects, so it is something about this project that is preventing the launch of the developer console... I'd guess the project needs to at least initialize (get to the title screen) before it can pull up the console.


Any ideas as to what might break the program before it even launches?


Thanks again for any and all support!
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,818
Reaction score
14,979
First Language
English
Primarily Uses
RMMV
If you say you have no plugins, I would grab the brand new project you created, and copy everything from the js folder as well as index.html, and paste it into your current folder.  That will set your scripts back to original, just in case anything weird happened to them.  Then see if it makes a difference.


Out of interest, where do you have your project saved?  In a Windows folder?  If you're using the steam version, I'd disable the cloud saving because that is known to cause problems.


Also, double posting is against the forum rules.  If you need to add more info and yours is the last post, just edit it to add the extra details.
 

BrandedTales

StoryTeller
Veteran
Joined
Dec 30, 2016
Messages
203
Reaction score
116
First Language
English
Primarily Uses
N/A
Apologies.  Will avoid double-posting in the future.


Tried getting clean copies of the js + html.  No luck.


My project is saved in the local user document folder windows share.  Not using cloud saving.


Thanks!
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,296
Reaction score
8,365
First Language
German
Primarily Uses
RMMV
does the error come up before or after the title screen? If it comes after the title screen, do you select a new game or load a saved game?


And when you said no "active" plugins, did you (at some time in the past) try to use a plugin and have only disabled it now, or was there never a plugin in the project?


I'm asking because if that error happens before the title, then it can only be a plugin or a damaged js/html file.


If it comes after loading a saved file, try starting a new game.
 

BrandedTales

StoryTeller
Veteran
Joined
Dec 30, 2016
Messages
203
Reaction score
116
First Language
English
Primarily Uses
N/A
Issue occurred before the title screen.


I will also say that I tried Shaz's advice of replacing the js and index.html file again.  This time success!  I'm not sure what I did wrong the first time I tried (maybe I copied over a backup of the bad ones?), but I'm very glad I tried again, and glad it worked.


Thanks very much both for the advice and support.  Very excited to not have lost my work!
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,879
Reaction score
14,702
First Language
English
Primarily Uses
RMVXA
This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

Thanks, google for putting together a random pixel art Olympics game in your logo that puts everything I've ever done to shame in pretty much every aspect. ;)
Chizuru
chizuru.png


anyway, i just recovered from Covid.
Work's been delayed for a month but now i'm back drawing again.
Ah yes i learned how to make name boxes Im now profeshonal
The snowy mountains in my game are finally done... what a crazy journey.
I participated in the official video event collection!

Forum statistics

Threads
113,610
Messages
1,076,197
Members
147,617
Latest member
G-G-Games
Top