Issues Saving in Android and Browser

KinoCornell

171st Street Games
Member
Joined
Mar 8, 2017
Messages
16
Reaction score
2
First Language
English
Primarily Uses
RMMV
I am attempting to get a Demo of my game deployed for Windows, MacOS, Android, and have it available to stream via Google Chrome. Windows and MacOS work completely fine in all ways.

However, when the game is deployed as an Android app or when it's played via Google Chrome, I cannot get it to save properly. It acts like it saves, but it appears as though the save file is corrupted.

The first screenshot is what I see in the Save/Load menu using Yanfly's Save Core. The second screenshot is what appears when I save and re-enter the Save menu using MV's basic Save functionality, and the third shows that this save file is not being acknowledged from the Title Menu, as "Continue" remains grayed out. The save file itself, when deployed via these two platforms, just corrupts itself somehow or cannot be found by the game.

I am aware that, as an Android app, the game functions basically the same as it would via the Chrome browser, so I'm sure the source of both is the same. But I cannot figure out what it is.

Has anybody encountered this issue and worked around it? Is this common?
 

Attachments

Eliaquim

Hakuen Studio
Veteran
Joined
May 22, 2018
Messages
1,678
Reaction score
1,094
First Language
Portuguese - Br
Primarily Uses
RMMZ
Hi!
I know that the Yanfly Save core engine has an option to change something on the save file... I think it is something related to the name of the file... And also something about saving local or else. I can't remember, not sure. Maybe this is causing the issue?

And also, did you make sure that your deployed folder does not contain any previous save file already?
 

KinoCornell

171st Street Games
Member
Joined
Mar 8, 2017
Messages
16
Reaction score
2
First Language
English
Primarily Uses
RMMV
Hi!
I know that the Yanfly Save core engine has an option to change something on the save file... I think it is something related to the name of the file... And also something about saving local or else. I can't remember, not sure. Maybe this is causing the issue?

And also, did you make sure that your deployed folder does not contain any previous save file already?
I was having the issue whether or not using Yanfly's SaveCore. However, I have pinpointed the issue. It's actually the HIME_SaveTitle plugin that was causing the conflict. So... this thread can be closed.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

GOBBLE GOBBLE! Happy thanksgiving.
Oh no. That moment when you try to fix something you modified in your game, like, a year ago but didn't want to fix then, and you now have no idea what you even did. Me right now, trying to figure out why my gold window is over stretched?
LittlePIGGY wrote on atreyoray's profile.
Where are you TT^TT
We need ARP_InGameManual for MZ
Oh my gosh. Thank you, Macy's! Thank you so much! You have made me very happy!

Forum statistics

Threads
105,552
Messages
1,014,573
Members
137,225
Latest member
Eryndor
Top