Stormhaven

Villager
Member
Joined
Dec 30, 2016
Messages
13
Reaction score
2
First Language
English
Primarily Uses
I've seen a few people have this problem, but there don't seem to be any fixes I've been able to find. Using Yanfly's Item and Equip cores (pretty much confirmed that they're the problem), and the initial armor I set on my actors doesn't go through correctly, and something else is equipped instead. I could work around this if needed, but its an annoying bug that I'd love to fix if possible. I've tested turning off their sub plugins, turning off just one of them, but the bug only goes away if both are off. Anyone have other ideas of what I could try/what the problem is?
 

ThreeSixNine

Veteran
Veteran
Joined
Jan 22, 2019
Messages
516
Reaction score
424
First Language
English
Primarily Uses
RMMV
I think I remember this having something to do with independent items.

Try skipping the initial equips in the editor and handling them through an auto run event on the starting map.
 

Stormhaven

Villager
Member
Joined
Dec 30, 2016
Messages
13
Reaction score
2
First Language
English
Primarily Uses
Yep, that's the other solution. It'll work, it's just a bit clunky. Just wondering if there was a fix for it.
 

Stormhaven

Villager
Member
Joined
Dec 30, 2016
Messages
13
Reaction score
2
First Language
English
Primarily Uses
I. May have fixed my own problem, though its a weird solution. For some reason it starts working if there was another piece of equipment in another slot at some point in the past, even if you remove it, eg I added a helmet to my actor then removed it, and the armor started showing up properly. Don't know why that works, but it does for me at least. If anyone has a faster solution/explanation I'd appreciate it, but that seems to fix the problem. For some reason.
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
6,216
Reaction score
4,195
First Language
English
Primarily Uses
RMMV
Can you explain how this relates to your initial post? You said in the first place the bug was with the wrong items showing up as an actor's initial equipment.

If it's their initial equipment, how can something else be in that slot previously?

I'm confused by either the problem or the solution :stickytongue:
 

Stormhaven

Villager
Member
Joined
Dec 30, 2016
Messages
13
Reaction score
2
First Language
English
Primarily Uses
Can you explain how this relates to your initial post? You said in the first place the bug was with the wrong items showing up as an actor's initial equipment.

If it's their initial equipment, how can something else be in that slot previously?

I'm confused by either the problem or the solution :stickytongue:
I hadn't filled every slot in the initial equipment, just the armor and weapon slots. When I did at least once, even if I then removed them, then the armor showed up correctly. I'm also confused, no idea why that fixed it.
 

eomereolsson

Veteran
Veteran
Joined
Sep 29, 2021
Messages
543
Reaction score
460
First Language
German
Primarily Uses
RMMV
I can offer one possible explanation, though it is just a theory and I havn't actually checked if it is correct. I know for a fact that if an event never existed, there will be no entry for it in the map json. Any attempt to access such an event will yield undefined. However if the event existed at some point and then later got deleted, its entry will be overwritten by a null entry. Any attempt to access this event will yield null instead of undefined.
Maybe the situation is similar for initial equipment and the plugin behaves incorrectly when encountering an undefined value, but not when encountering a null value?
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
6,216
Reaction score
4,195
First Language
English
Primarily Uses
RMMV
I hadn't filled every slot in the initial equipment, just the armor and weapon slots. When I did at least once, even if I then removed them, then the armor showed up correctly. I'm also confused, no idea why that fixed it.
So when you say "removed" you're not talking about removing the equipment from the actor in the game; you're saying that, inside the editor, you would select something for initial equipment, then change it back to none, and that made a difference?
 

Stormhaven

Villager
Member
Joined
Dec 30, 2016
Messages
13
Reaction score
2
First Language
English
Primarily Uses
So when you say "removed" you're not talking about removing the equipment from the actor in the game; you're saying that, inside the editor, you would select something for initial equipment, then change it back to none, and that made a difference?
Yep! I'd assume if it was ingame it wouldn't matter, since the editor is all. I saw a post somewhere saying that if you delete items without replacing them it can cause problems (I'd assume cause they're already equipped). I think that can make it seem that they have nothing equipped, when they do, and that causes a bug. I'm not sure, that's my current theory though.
 

Latest Threads

Latest Posts

Latest Profile Posts

no longer using rm2k3
Don't you hate when you're trying to sleep and suddenly the smoke detector needs batteries? That's exactly what happened to me. Now I'm sluggish and tired after that darn thing started chirping at 11:30 at night. Man I wish I had one of those smart smoke detectors that sends a message to your phone way before it starts chirping.
Interior of a bus, may do more vehicle interiors :kaoswt2:
1670089782219.png
I can hardly believe it is the third day of Christmas and I have yet to put up decorations! Spending my morning cooking breakfast and getting them up.
https://itch.io/s/83641/1-week-sale Do you want a Roguelike game like a turn-based Hades? Get Zodiac Hunters now while it's on sale!

Forum statistics

Threads
127,016
Messages
1,183,213
Members
166,879
Latest member
Drenquire
Top