Khas Advanced Lighting v4.2 Ultra (now with real-time shadows!)

Discussion in 'JS Plugin Releases (RMMV)' started by Khas, Apr 22, 2017.

    Tags:
  1. Rito

    Rito Veteran Veteran

    Messages:
    107
    Likes Received:
    50
    First Language:
    French
  2. JamesRyan

    JamesRyan Game Designer Veteran

    Messages:
    486
    Likes Received:
    154
    Location:
    Vietnam
    First Language:
    Vietnamese
    Primarily Uses:
    RMMV
    I also know this one. But after a memory bug in his Game Upgrade plugin and he gave up making plugins, i have stopped using his plugins.
     
  3. Tuomo L

    Tuomo L Oldbie Veteran

    Messages:
    2,139
    Likes Received:
    1,082
    Location:
    Finland!
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    Sumrndm's is not as good as Yanfly's. Just look at the battle speed options to see for example.
     
  4. Lunesis

    Lunesis Veteran Veteran

    Messages:
    34
    Likes Received:
    6
    First Language:
    English
    I don't have the yep options plugin on my game. The weird thing is I tried the plugin in a new project and point lights crashed the game, but in his demo it all works fine. Maybe if I copied my game folders over to his demo it would work?
     
  5. Tuomo L

    Tuomo L Oldbie Veteran

    Messages:
    2,139
    Likes Received:
    1,082
    Location:
    Finland!
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    Hello, can anyone please help fix this plugin for the Options Core? It's literally CTD'ing the game on startup now. Please don't make me have to choose between this or Yanfly Options core. :rswt2:
     
  6. JamesRyan

    JamesRyan Game Designer Veteran

    Messages:
    486
    Likes Received:
    154
    Location:
    Vietnam
    First Language:
    Vietnamese
    Primarily Uses:
    RMMV
    Better wait for an official fix from @Khas. Currently, i have to leave YEP Options Core behind.
     
  7. Tuomo L

    Tuomo L Oldbie Veteran

    Messages:
    2,139
    Likes Received:
    1,082
    Location:
    Finland!
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    I've already made my game very far with this lightning script in mind. :ysad:
     
    Quickcloud likes this.
  8. Xeronkar

    Xeronkar Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    Fran├žais
    Primarily Uses:
    RMMV
    Hum I'm using both YEP_OptionsCore and KhasUltraLighting without experiencing any problem, are you sure about the faulty script ?
    Also, there is my script order if it can help :

    upload_2018-5-13_5-8-19.png
    upload_2018-5-13_5-8-36.png
    upload_2018-5-13_5-8-50.png
     
  9. JamesRyan

    JamesRyan Game Designer Veteran

    Messages:
    486
    Likes Received:
    154
    Location:
    Vietnam
    First Language:
    Vietnamese
    Primarily Uses:
    RMMV
    Maybe the order of plugins is the matter here? All my Khas' plugins are below YEPs, not like you which only Ultra Lighting is below. I think i'm gonna try again by following your order to see if it works.
     
  10. Skurge

    Skurge What is it that you want of me? Veteran

    Messages:
    977
    Likes Received:
    188
    Location:
    Australia
    First Language:
    English
    I've been doing some bug testing in compliance to the recent MV updates and it would seem that my project crashes when KhasCore 2.0 is turned on (correct order plugins as required)

    When the plugin is turned on, the menu when booting test play has it's speed reduced greatly and even the audio is lagging behind. Upon starting new game the test play crashes with this message.
    "Cannot read property 'blendModes' of undefined"

    The console has this to say in relation to the crash, has anyone got any input on what you might think is wrong or perhaps it's just incompatible with the latest MV update?
    khas core issues.png
     
  11. JamesRyan

    JamesRyan Game Designer Veteran

    Messages:
    486
    Likes Received:
    154
    Location:
    Vietnam
    First Language:
    Vietnamese
    Primarily Uses:
    RMMV
    @Skurge what version of MV are you running? If 1.6.1 (currently in beta) breaks this plugin, i will not update once it is released. For now, 1.5.2 works fine without YEP Options Core.
     
  12. Tuomo L

    Tuomo L Oldbie Veteran

    Messages:
    2,139
    Likes Received:
    1,082
    Location:
    Finland!
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    I tried that, it still crashes as soon as I go to options menu.
     
  13. Xeronkar

    Xeronkar Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    Fran├žais
    Primarily Uses:
    RMMV
    @Tuomo L Do you have a clean version of the plugin ? Or did you made so changes ?
    Also did you plugged other scripts in the options, like the YEP keyboard mapping ?

    I'm using RPG Maker MV 1.5.1, and still no crashes here

    upload_2018-5-14_4-22-4.png
     
    Last edited: May 14, 2018
  14. Skurge

    Skurge What is it that you want of me? Veteran

    Messages:
    977
    Likes Received:
    188
    Location:
    Australia
    First Language:
    English
    Currently 1.6.0 as 1.6.1 won't even show up as an availiable version download for me on steam.
     
  15. Skurge

    Skurge What is it that you want of me? Veteran

    Messages:
    977
    Likes Received:
    188
    Location:
    Australia
    First Language:
    English
    1.5.2 is not compatible and still presents the same error :/
     
  16. Skurge

    Skurge What is it that you want of me? Veteran

    Messages:
    977
    Likes Received:
    188
    Location:
    Australia
    First Language:
    English
    I'm stuck with a problem that won't go away, all my plugins work except for KhasCore that causes a crash and a error message I have no idea what it means. My MV version is currently 1.5.2 as newer versions are too glitchy at this stage to upgrade.

    My Khascore is version 2.0.

    Can anybody here make sense of this for me? I do not understand it at all and the plugin order and everything was working before the new MV version which forced me to revert back.

    error build up.png error build up2.png
     
  17. GaniNix

    GaniNix Villager Member

    Messages:
    9
    Likes Received:
    0
    First Language:
    German / Thai
    Primarily Uses:
    RMMV
    Thank you so much!
     
  18. cedr777

    cedr777 Veteran Veteran

    Messages:
    44
    Likes Received:
    14
    First Language:
    English
    Primarily Uses:
    RMMV
    Anyone know how to change the size of the light for the player?
    I'm using the plugin command: PlayerLantern torch
    but [light_size x] does not seem to work, I want to increase the light size.
    [​IMG]
    I have made it able to toggle the light on and off like a Lantern effect, but I just can't seem to figure out how to make the light bigger.
    [​IMG]
    See, it's still at the default 100 I think? But it seems to work for events though.
     
    Last edited: Jun 17, 2018
  19. Nicke

    Nicke Pure Evil Veteran

    Messages:
    501
    Likes Received:
    358
    Location:
    Sweden
    First Language:
    Swedish
    Primarily Uses:
    RMMV
    In the lighting script there is a preset called "player_lantern". You can change the size in there:
    Code:
        player_lantern: {
            fileName: "lantern",
            intensity: 95, variation: 6, size: 100,
            offset_x: {2: 0, 4: 0, 6: 0, 8: 0 }, offset_y: {2: 0, 4: 0, 6: 0, 8: 0 },
            syncWithDirection: true
        },
     
    cedr777 likes this.
  20. cedr777

    cedr777 Veteran Veteran

    Messages:
    44
    Likes Received:
    14
    First Language:
    English
    Primarily Uses:
    RMMV
    I understand now. You have to make your own custom light for that.
    It worked, Thanks!
     

Share This Page