Large Sprite ☆ Display Fix

Joined
Apr 30, 2012
Messages
215
Reaction score
35
First Language
Spanish
Primarily Uses
i seem to be having a problem when i am using multiples of the same tile. for example rows of seats in a stadium setting.

when there's only one row, no problem. works excellently.

when there's multiple rows, though, it doesn't work. the tile the player is standing on is the same as the one directly above him—is that causing the problem?
Did you tested in a fresh project without other scripts?
 

Nosleinad

Storyteller
Veteran
Joined
Dec 12, 2012
Messages
351
Reaction score
28
First Language
Portuguese
Primarily Uses
Hello,

  At first the script wasnt working for me, because i changed the UpperTerrain = 7 to UpperTerrain = 2. (Line 27), the terrain tag was configured accordingly.

  So could this be a bug thats affecting other devs as well? When i configure both the script and the terrain tags to 2, its not being recognized, but if i configure everything to the default tag (7), the script works again.
 

Fernyfer775

Veteran
Veteran
Joined
Oct 6, 2013
Messages
1,309
Reaction score
809
First Language
English
i seem to be having a problem when i am using multiples of the same tile. for example rows of seats in a stadium setting.

when there's only one row, no problem. works excellently.

when there's multiple rows, though, it doesn't work. the tile the player is standing on is the same as the one directly above him—is that causing the problem?
I seem to be having the same problem here. My only workaround to it was to space out the rows by another tile to avoid having the "star" touching both the character sprite's feet and head, which is what I'm sure the problem is.
 

Random Spaniard

Villager
Member
Joined
Jul 6, 2014
Messages
9
Reaction score
0
First Language
Spanish
Primarily Uses
I have a problem when using this script with Yanfly's battle add-on Visual Battlers. It shows up the next error message:

 

darkelite

Game Designer
Veteran
Joined
Sep 26, 2013
Messages
32
Reaction score
8
First Language
French
Primarily Uses
I have the same problem, my hero is standing in-between a dumpster and the wooden fence (see picture below) and the terrain tag was set to 7 on the top portion of the dumpster and the fence (same row). I'd be grateful if you can fix this, thanks a lot!

http://s28.postimg.org/5r85d0drh/Above.jpg
 
Last edited by a moderator:

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,705
Reaction score
14,529
First Language
Filipino
Primarily Uses
VNM
I have the same problem, my hero is standing in-between a dumpster and the wooden fence (see picture below) and the terrain tag was set to 7 on the top portion of the dumpster and the fence (same row). I'd be grateful if you can fix this, thanks a lot!

http://s28.postimg.org/5r85d0drh/Above.jpg
He would need more information than that!

For example,

1.) does it happen if you test it in a new project with just this script?

2.) What is that tileset's settings?

3.) Can you compile a demo for him to check it out?
 
Last edited by a moderator:

SpikerzZ

Villager
Member
Joined
Aug 21, 2014
Messages
19
Reaction score
0
First Language
English
Primarily Uses
I have an issue, when I put a park bench down, it works fine, but when there is another tile behind it, it doesn't work good.
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
38,243
Reaction score
11,853
First Language
English
Primarily Uses
RMMV
What does "it doesn't work good" mean? Show us screenshots and explain what the issue is. Also state if you are using any other scripts that affect the drawing of sprites or maps (like NeonBlack's Terrain Tags script, to name just one).
 
Last edited by a moderator:

SpikerzZ

Villager
Member
Joined
Aug 21, 2014
Messages
19
Reaction score
0
First Language
English
Primarily Uses
I mean part of the sprites get cut off, I found out that it is when I have textures that I place on 2 differant tiles, for example, when I place the bench on grass and a sidewalk it screws up.

001.png
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
38,243
Reaction score
11,853
First Language
English
Primarily Uses
RMMV
It seems like you don't have the script installed properly, it's not in the right place, or you have another script that's not compatible with it.
 

SpikerzZ

Villager
Member
Joined
Aug 21, 2014
Messages
19
Reaction score
0
First Language
English
Primarily Uses
does the same thing on a fresh game maker thing, I think it is an error with the object being on 2 tiles
 

SpikerzZ

Villager
Member
Joined
Aug 21, 2014
Messages
19
Reaction score
0
First Language
English
Primarily Uses
Here is a screen shot of my script on a fresh game creation with the map copied

002.png
 

SpikerzZ

Villager
Member
Joined
Aug 21, 2014
Messages
19
Reaction score
0
First Language
English
Primarily Uses
Here is my test page, I was wrong earlier, it happends no matter where I place the bench

http://www.gigasoft.ca/games/test.exe

Sorry, it wouldn't let me send the demo here so I uploaded it to my site, is that alloud?
 
Last edited by a moderator:

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
38,243
Reaction score
11,853
First Language
English
Primarily Uses
RMMV
No attachment. Please don't double post.


I suspect you might not be installing the script correctly. Or you've changed your tileset to override the script.
 
Last edited by a moderator:

SpikerzZ

Villager
Member
Joined
Aug 21, 2014
Messages
19
Reaction score
0
First Language
English
Primarily Uses
I do change the 4 way directions a bit, maybe this script can't do that good?
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,705
Reaction score
14,529
First Language
Filipino
Primarily Uses
VNM
Was the terrain tag properly set?

I can't seem to download the file.
 
Last edited by a moderator:

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
38,243
Reaction score
11,853
First Language
English
Primarily Uses
RMMV
If you set the tile to a star passability, it might affect the script. I THOUGHT it was clever enough though to cater for that.
 

SpikerzZ

Villager
Member
Joined
Aug 21, 2014
Messages
19
Reaction score
0
First Language
English
Primarily Uses
Which tile? I have the top of the bench as 7 the bottom 0 but tried it as 7 too than the top star, the bottom though can't be star are it apears abouve me
 
Last edited by a moderator:

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
38,243
Reaction score
11,853
First Language
English
Primarily Uses
RMMV
??? What's 7 and 0? Ace has no priority like XP has. If you're using 0 and 7, that's terrain tags, which has nothing at all to do with something appearing above or below the characters.


You're after passage settings (passage button) which can be X, O or star.


What other scripts are you using? If you're using a terrain tag script that changes the behaviour of the map tiles (like NeonBlack's, though I think that work with regions, not terrains), then it will likely conflict with this one.


You ARE using Ace, aren't you?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 2)

Latest Threads

Latest Profile Posts

I've noticed that the website has changed a lot since I left in August last year...
One of my kitties after a long, tiring day of being adorable.
We have good wifi here now thanks to a guy who had the audacity to tell the Director "Sir, the wifi sucks. Make it faster and increase the bandwidth" in this arrogant tone. The Director is a complete sweetheart so he did just that. So you may see me around often now, being disturbing as usual.
To compensate for me feeling too sick to interact properly, have an old recording of me calming you with Zelda's Lullaby. https://vocaroo.com/jqTcbzdQTw5 :kaojoy:
Finally found someone to make battlers for me. Just wants $50 for a small one. And $75 for a big one. So who wants to help me make a GoFundMe page? Scratch that. How much can I get for a kidney on the black market?

Forum statistics

Threads
93,361
Messages
911,674
Members
122,853
Latest member
Ordan
Top