TheWorldOfCM

Villager
Member
Joined
Apr 30, 2018
Messages
19
Reaction score
8
First Language
Tagalog
Primarily Uses
RMMV
Here Frostorm my skill notetag and sequence config...

skills notetag:

<letbs>
aoe_select: allies
aoe: circle(4)
aoe_options: need_free_cell
sequence: Ally_Jump
</letbs>

<letbs_AI>
type: move
</letbs_AI>

~~~~~~~~~~~~~~~~~~

sequence config:

"Ally_Jump": [
"wait: 60",
"save_entities: Ally_Jump, cursor_ally",
"request_selection: skill(300)",
"call: pre-skill",
"anim: saved(Ally_Jump), 169",
"wait: 40",
"move_to_cell: saved(Ally_Jump), cursor_cell, true",
"anim: saved(Ally_Jump), 170",
"wait: 60",
"call: post-skill"
],

~~~~~~~~~~~~~~~~~~~~~~

What do you think is the problem? My issue is that when I select an ally there's no problem but when I move and put it within the scope..my ally can be placed anywhere in the map even in the restricted areas. What I want is that it can only be placed within the scope.
 

Frostorm

[]D[][]V[][]D
Veteran
Joined
Feb 22, 2016
Messages
2,286
Reaction score
1,924
First Language
English
Primarily Uses
RMMV
Have any of you gotten DoTs to show the dmg popup when it ticks? I'm open to any suggestions/ideas to get this feature working. Thx...

@TheWorldOfCM Ok, I see...the aoe_options: need_free_cell is only referring to when you are selecting which ally to teleport, not where it can teleport to. So the issue is the sequence. Somewhere in here, we will need to restrict the cells you can select to include LoS mechanics.
JavaScript:
"Ally_Jump": [
"wait: 60",
"save_entities: Ally_Jump, cursor_ally",
"request_selection: skill(300)",
"call: pre-skill",
"anim: saved(Ally_Jump), 169",
"wait: 40",
"move_to_cell: saved(Ally_Jump), cursor_cell, true",
"anim: saved(Ally_Jump), 170",
"wait: 60",
"call: post-skill"
],

Edit: Hey guys, guess what? I found out how to force damage popups to show!
Solution: BattleManagerTBS.activeEntity().addPopup();
 
Last edited:

TheWorldOfCM

Villager
Member
Joined
Apr 30, 2018
Messages
19
Reaction score
8
First Language
Tagalog
Primarily Uses
RMMV
Frostorm..so what do you think is the best solution for this? do you have any idea? There is no problem in selecting which ally or enemy can be selected within the scope. The problem is when I try to move the ally or enemy..even with a custom scope or aoe, I can still put the battler anywhere in the map even in the restricted regions (249, 250). That's my problem with the skill.
 

Frostorm

[]D[][]V[][]D
Veteran
Joined
Feb 22, 2016
Messages
2,286
Reaction score
1,924
First Language
English
Primarily Uses
RMMV
Look at this line in the sequence:
"request_selection: skill(300)",
What is skill #300 in your database?

Edit: Actually I think we need to focus on this line instead:
"save_entities: Ally_Jump, cursor_ally",
the format is: save_entities: id, entities, option
so maybe we can add something in the place of "option"...I just don't the correct term for LoS, if it exists. Either that, or we change the entities from "cursor_ally" to something else that accounts for LoS.
 
Last edited:

TheWorldOfCM

Villager
Member
Joined
Apr 30, 2018
Messages
19
Reaction score
8
First Language
Tagalog
Primarily Uses
RMMV
it is a skill for scope..Tile Jump. That's the skill notetag I sent you. Even without it, the issue is still the same. If I can't make it to work, I just have to scrap the skill.

I tested removing the move_to_cell line in the config but I can't move the battler anymore. I don't know what to do anymore.

I may try to inject codes there. Thank you for trying to help me.

edit:

So you mean I should put "save_entities: Ally_Jump, cursor_ally, line_of_sight", ?

The way I understand the code (I'm not a coder) is...
the request_selection line is where you select which ally or enemy to move while the move_to_cell line is when you move the selected ally or enemy.
 
Last edited:

AbstractMan

Forever lost in the Tea Room of Despair
Veteran
Joined
Jun 22, 2019
Messages
76
Reaction score
47
First Language
English
Primarily Uses
RMMV
I would also like to know how to get DoT damage to show. I have been trying to get that up in running for about a year. If i can get that up and running, i will post it here. I have been also trying to get it so that if you highlight over a buff or debuff in your status screen, it will show you informaton.
 

huoixn

Veteran
Veteran
Joined
Mar 11, 2019
Messages
42
Reaction score
4
First Language
Chinese
Primarily Uses
RMMV
My problems have been solved. Have you found and solved some 0.77.2b bugs? Is there an update list to share.
 
Last edited:

UniqueName

Veteran
Veteran
Joined
Nov 12, 2018
Messages
84
Reaction score
14
First Language
Russian
Primarily Uses
Other
hey guys, is there any way to make a skill instant? I have a defend skill with these tags:
Code:
<letbs>
scope: circle(0)
scope_options: include_center
</letbs>
<letbs_AI>
type: support
</letbs_AI>
so players have to choose this skill in the command menu and then click again on the user. That's really slow and annoying.
can i make this skill instant without the scope?
 

Sacrifyx

Veteran
Veteran
Joined
Oct 16, 2012
Messages
147
Reaction score
10
First Language
English
Primarily Uses
RMMV
I have a weird problem here. I have a battle with a lot of characters. Sometimes during this battle, one of the enemies will not disappear when they hit 0 HP. They remain onscreen and able to attack, but all attacks on them do nothing. It doesn't happen every time, and I'm not even sure if it's the same enemy every time.

Also, is there some trick to getting "move_point_plus: x" to work for equipment? I have <letbs>move_point_plus: 8</letbs> in the notebox of a piece of equipment, but it doesn't have any effect at all.
 
Last edited:

Frostorm

[]D[][]V[][]D
Veteran
Joined
Feb 22, 2016
Messages
2,286
Reaction score
1,924
First Language
English
Primarily Uses
RMMV
Guys, I noticed a strange visual bug... Basically, objects/tiles that are supposed to be "over" a character only does so if the map is larger than 17x13 (default size). If a map's width is less than 17 or its height is less than 13, then stuff that normally shows on top of a character is drawn below it instead. Here are screenshots to illustrate what I mean:

Map size greater than 17x13: (40x33 to be exact, but 20x11 shown due to my resolution)
1610958784476.png

Map size less than 17x13: (20x11 to be exact... the "11" makes it count as "smaller" than 17x13)
1610958784477.png
I realized the threshold is 17x13 because I tested it w/ various map sizes. 20x13 had no issues, but as soon as I went down to 20x12, this bug appeared. I run 20x11 for all my dungeon maps, so I really need to get this fixed...

Edit: I noticed the changelog (v0.7d) says this:
*The battlers layer is now correctly below the upper map layer

I'm using v0.77.2b so this should've been fixed. I'm guessing this was an issue in the past, but for some reason, this "fix" only applied to maps larger than 17x13. Does anyone have a version earlier than v0.7d so I can compare the code?

Edit2: Ok, so I went through LeTBS.js and poked around lines 799-839. I decided to change line 816 from this._battlersLayer.z = 4; to this._battlersLayer.z = 3;. This seems to have fixed the issue, however, I have no idea if this would cause other problems down the road...
 
Last edited:

AbstractMan

Forever lost in the Tea Room of Despair
Veteran
Joined
Jun 22, 2019
Messages
76
Reaction score
47
First Language
English
Primarily Uses
RMMV
Hmmm, I've been trying to speed up the frame of some poses in a few of my combat moves, however, every time I attempt it using the frame delay sequence looks like they are locked into the first frame.

This is the sequence I have been currently working with. Is anyone else having this problem?

"Shoot": [
"set_frame: user, atk, 0",
"anim: user, 165",
"wait: 15",
"set_frame_delay: user, -4",
"play_pose: user, atk",
"wait: 9",
"effects: {aoe}_battlers, current_obj, obj_anim",
"set_frame_delay: user, reset",
"wait: 60"
],
 

Sacrifyx

Veteran
Veteran
Joined
Oct 16, 2012
Messages
147
Reaction score
10
First Language
English
Primarily Uses
RMMV
Hey all,
A strange error just started popping up during testing of my first battle (was working perfectly fine until today):
TypeError - this._battler.lastCommandSymbol is not a function.

Haven't made any edits to the plugins, I have made some changes in the database but I can't imagine they'd be causing this. Anyway, screenshot of the console is below, any help would, as always, be greatly appreciated.
 

Attachments

  • Capture.PNG
    Capture.PNG
    41.8 KB · Views: 9

Danielcross

Veteran
Veteran
Joined
Sep 27, 2017
Messages
110
Reaction score
10
First Language
English
Primarily Uses
RMMV
Is there a way to remove the directional confirmation during the end turn phase? I'm doing away with directional damage for my game.

Edit: figured it out, it's an option in the main plugin settings.
 
Last edited:

luizfcr

Villager
Member
Joined
Apr 28, 2019
Messages
26
Reaction score
3
First Language
portugues
Primarily Uses
RMMV
Pessoal, notei um bug visual estranho ... Basicamente, objetos / tiles que deveriam estar "sobre" um personagem só o fazem se o mapa for maior que 17x13 (tamanho padrão). Se a largura de um mapa for menor que 17 ou sua altura menor que 13, então o que normalmente aparece no topo de um personagem é desenhado abaixo dele. Aqui estão as capturas de tela para ilustrar o que quero dizer:

Tamanho do mapa maior que 17 x 13: (40 x 33 para ser exato, mas 20 x 11 mostrado devido à minha resolução)
View attachment 176107

Tamanho do mapa menor que 17 x 13: (20 x 11 para ser exato ... o "11" faz com que seja considerado "menor" do que 17 x 13)
View attachment 176110
Percebi que o limite é de 17x13 porque testei com vários tamanhos de mapa. 20x13 não teve problemas, mas assim que eu fui para 20x12, esse bug apareceu. Eu corro 20x11 para todos os meus mapas de masmorras, então eu realmente preciso consertar isso ...

Edit: notei que o changelog (v0.7d) diz o seguinte:
* A camada de batalha agora está corretamente abaixo da camada superior do mapa [/ ICODE] Estou usando a v0.77.2b, então isso deveria ter sido corrigido. Acho que isso era um problema no passado, mas por algum motivo, essa "correção" só se aplicava a mapas maiores que 17x13. Alguém tem uma versão anterior a v0.7d para que eu possa comparar o código? Edit2: Ok, então fui até LeTBS.js e examinei as linhas 799-839. Decidi alterar a linha 816 de [ICODE] this._battlersLayer.z = 4; [/ ICODE] para [ICODE] this._battlersLayer.z = 3; [/ ICODE]. Isso parece ter resolvido o problema, no entanto, não tenho ideia se isso causaria outros problemas no futuro ... [/QUOTE]

Guys, I noticed a strange visual bug... Basically, objects/tiles that are supposed to be "over" a character only does so if the map is larger than 17x13 (default size). If a map's width is less than 17 or its height is less than 13, then stuff that normally shows on top of a character is drawn below it instead. Here are screenshots to illustrate what I mean:

Map size greater than 17x13: (40x33 to be exact, but 20x11 shown due to my resolution)
View attachment 176107

Map size less than 17x13: (20x11 to be exact... the "11" makes it count as "smaller" than 17x13)
View attachment 176110
I realized the threshold is 17x13 because I tested it w/ various map sizes. 20x13 had no issues, but as soon as I went down to 20x12, this bug appeared. I run 20x11 for all my dungeon maps, so I really need to get this fixed...

Edit: I noticed the changelog (v0.7d) says this:
*The battlers layer is now correctly below the upper map layer

I'm using v0.77.2b so this should've been fixed. I'm guessing this was an issue in the past, but for some reason, this "fix" only applied to maps larger than 17x13. Does anyone have a version earlier than v0.7d so I can compare the code?

Edit2: Ok, so I went through LeTBS.js and poked around lines 799-839. I decided to change line 816 from this._battlersLayer.z = 4; to this._battlersLayer.z = 3;. This seems to have fixed the issue, however, I have no idea if this would cause other problems down the road...


Hello, how are you? I saw in an old post of yours that you wanted to put faces on the status part, you already got it, I have a solution that gives more work is a solution. And I saw that you, managed to change many things in the windows, you would help me to make these changes too.
 

guille1194

Warper
Member
Joined
Mar 3, 2021
Messages
2
Reaction score
0
First Language
Spanish
Primarily Uses
RMMV
Hi guys, sorry but i'm very new with this plugin and i want to know what is the reason to get the next error message.

1614897797689.png
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,133
Reaction score
15,532
First Language
English
Primarily Uses
RMMV
It is saying it can't load that file. Do you HAVE a file called Bandit.png in the img/enemies folder?
 

posfan12

Veteran
Veteran
Joined
Jun 4, 2014
Messages
74
Reaction score
7
First Language
English
Primarily Uses
RMMV
I forgot where to look up the correct plugin installation order. I have yanfly's scripts installed. What order do I add the plugins to Plugin Manager in? Thanks.
 

luizfcr

Villager
Member
Joined
Apr 28, 2019
Messages
26
Reaction score
3
First Language
portugues
Primarily Uses
RMMV
I forgot where to look up the correct plugin installation order. I have yanfly's scripts installed. What order do I add the plugins to Plugin Manager in? Thanks.
Download the demo to see the correct order.
 

posfan12

Veteran
Veteran
Joined
Jun 4, 2014
Messages
74
Reaction score
7
First Language
English
Primarily Uses
RMMV
After updating the Yanfly and LeTBS scripts I get an error when combat starts:

Clipboard-2.png

Don't what the issue is. No other changes have been made.

Also, where can I find a text copy of the error messages? I don't want to post screenshots all the time.
 

Tigrean

Veteran
Veteran
Joined
Dec 31, 2013
Messages
107
Reaction score
7
First Language
English
I'm having two weird issues with this system. First issue is as follows:

When I have LeTBS_Winconditions.js on I get the first error before I even get into the game.

Then when I turn it off I get the second error after completing a standard battle. If I turn the Aftermath plug-ins off the game works fine. Any help would be very appreciated, thanks.
 

Attachments

  • LeTBS_Winconditions.js_error.PNG
    LeTBS_Winconditions.js_error.PNG
    364.7 KB · Views: 2
  • YEP_VictoryAftermath.js_Error.PNG
    YEP_VictoryAftermath.js_Error.PNG
    894.3 KB · Views: 2

Latest Threads

Latest Profile Posts

I've been working on making a simple sprite frame system. And I'm really happy with the progress.
ZAyFw65.gif
Sketching on Milanote the new script of the system I plan to implement for VNMaker. This is making me learning Coffeescript through a crash-course I never thought I would ever take in my meager career as writer, but brings back fond memories when I was forced to learn RUBY for RPGMaker XP back in those years. Oh dear... :LZSooo:
For some reason, I found this is kinda stylist
ready to fall into another development hell...
Mega has been giving me a lot of problems as of late, so I think I'll need to switch to another cloud service. I'm considering Dropbox.

Forum statistics

Threads
117,132
Messages
1,104,834
Members
153,185
Latest member
mattoslf
Top