Luna Engine display Evasion and Critical Rate

KazukiT

Veteran
Veteran
Joined
Dec 7, 2014
Messages
229
Reaction score
214
First Language
English
Primarily Uses
RMMV
I was wondering how would I make my actor's evasion and critical rate appear in the status menu in the luna engine?
 

zerobeat032

Cloaked Wanderer...
Veteran
Joined
Mar 28, 2014
Messages
279
Reaction score
238
First Language
English
Primarily Uses
RMMV
actor.xparam(1) for evasion and actor.xparam(2) for critical... tho they show up kinda weird since they're percentages...

as in I looked at my crit rate normally and it's 7 percent. I looked at it with Luna and it said 0.07. I wouldn't quite know how to go about changing that either unfortunately. I can confirm tho that actor.xparam(whatever xparam number you need) does seem to work.
 

KazukiT

Veteran
Veteran
Joined
Dec 7, 2014
Messages
229
Reaction score
214
First Language
English
Primarily Uses
RMMV
actor.xparam(1) for evasion and actor.xparam(2) for critical... tho they show up kinda weird since they're percentages...

as in I looked at my crit rate normally and it's 7 percent. I looked at it with Luna and it said 0.07. I wouldn't quite know how to go about changing that either unfortunately. I can confirm tho that actor.xparam(whatever xparam number you need) does seem to work.
I tried to input the critical stat and causes my game to crash.
 

Attachments

zerobeat032

Cloaked Wanderer...
Veteran
Joined
Mar 28, 2014
Messages
279
Reaction score
238
First Language
English
Primarily Uses
RMMV
oh um... that's indentation error. that just means something isn't aligned where it's supposed to be. I ALWAYS use Luna files in Microsoft Visual Studio and whenever I make a bad indentation, it'll mark up everything and tell me where I messed up lol. if I were you, I'd copy and paste a different parameter you already have that's lined up and spaced correctly and then just change the wording where needed. I think in your case CRT is in the wrong spot...

xparam.PNG

this worked fine for me and it's lined up right.
 

KazukiT

Veteran
Veteran
Joined
Dec 7, 2014
Messages
229
Reaction score
214
First Language
English
Primarily Uses
RMMV
oh um... that's indentation error. that just means something isn't aligned where it's supposed to be. I ALWAYS use Luna files in Microsoft Visual Studio and whenever I make a bad indentation, it'll mark up everything and tell me where I messed up lol. if I were you, I'd copy and paste a different parameter you already have that's lined up and spaced correctly and then just change the wording where needed. I think in your case CRT is in the wrong spot...

View attachment 151277

this worked fine for me and it's lined up right.
I just put this code in and it doesn't crash the game, however, it doesn't appear in the Status menu.
 

Attachments

zerobeat032

Cloaked Wanderer...
Veteran
Joined
Mar 28, 2014
Messages
279
Reaction score
238
First Language
English
Primarily Uses
RMMV
CRIT.PNG

my critical show's up as such... aka 7 percent. but that's also me just throwing out Agility for the sake of testing and throwing Crit in it's place... if I'm thinking about it actually... maybe it's literally just NOT on the screen. did you adjust anything like the x and y coordinates? or is it just nothing there where it should be?
 

KazukiT

Veteran
Veteran
Joined
Dec 7, 2014
Messages
229
Reaction score
214
First Language
English
Primarily Uses
RMMV
View attachment 151356

my critical show's up as such... aka 7 percent. but that's also me just throwing out Agility for the sake of testing and throwing Crit in it's place... if I'm thinking about it actually... maybe it's literally just NOT on the screen. did you adjust anything like the x and y coordinates? or is it just nothing there where it should be?
I set all the coordinates to 0 and tried setting them at a random number and it still didn't appear.
Stat Box.PNG
I am trying to place it under Speed. Do you think you could only have 6 stats or have you seen a game using Luna with more than just 6 stats?
 

zerobeat032

Cloaked Wanderer...
Veteran
Joined
Mar 28, 2014
Messages
279
Reaction score
238
First Language
English
Primarily Uses
RMMV
Ok, I THINK I've figured it out? you might need to increase the size of the status box itself to fit ANYTHING extra. it doesn't know off the bat you're trying to add anything extra so it needs more room to show it. so I'd increase the height of the menu and see if that helps. that's the only thing I can think of that's being weird at this point.
 

KazukiT

Veteran
Veteran
Joined
Dec 7, 2014
Messages
229
Reaction score
214
First Language
English
Primarily Uses
RMMV
Ok, I THINK I've figured it out? you might need to increase the size of the status box itself to fit ANYTHING extra. it doesn't know off the bat you're trying to add anything extra so it needs more room to show it. so I'd increase the height of the menu and see if that helps. that's the only thing I can think of that's being weird at this point.
I tried to make the box bigger but the stats didn't appear. I also tried to put "CRI" and "Current CRI" at the bottom with all the other components but that crashes the game.
 

zerobeat032

Cloaked Wanderer...
Veteran
Joined
Mar 28, 2014
Messages
279
Reaction score
238
First Language
English
Primarily Uses
RMMV
well crap... I'm kinda stumped here. I'm not entirely sure what's not working on your end of things. especially seeing as I got to work right off the bat. I was wondering if it was my plugins, but I tried it with all of them off but Yanfly's Core Engine because I kept getting a weird error without it that I don't know how to fix. but I had that and Luna on and it showed the critical stat. I'll see if I can add another on tho as I've only just replaced AGI with CRIT and not actually added a new one.

EDIT... so I added CRI to mines and just slapped it under everything else and yeah, I still got it to work somehow... so I'm not sure what's wrong on your end at this point. xparam.PNG
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

How do you cure sleep problem? It has been 7 months and it's 3 AM now..
Darn you, Seals! Why do you gotta be so cute when on land?:kaoluv:
So dragonbones getting laggy xD
I even removed the fingers armatures.

Have to remake this guy after crashing ( corrupted file).
:rtear:

Although limited to only this shop for room decorations, I like this aspect for previewing items.

Forum statistics

Threads
100,837
Messages
980,129
Members
132,487
Latest member
AnthonyDewitt
Top