[Magically Solved] For some reason, "[Action Button] Event" won't trigger

Status
Not open for further replies.

uglywolf

Veteran
Veteran
Joined
Nov 9, 2015
Messages
68
Reaction score
83
First Language
Malay
Primarily Uses
RMMV
Hi, what is going on today? I am having trouble...
I uploaded the attachment, please check it.
(the blue flame is the player starting position)

As everyone knows, Action Button(by default Z key) is one of the options that can trigger interaction with any map event available.

But for some reason, it won't trigger using Action button. Ofc, I still leave the button setting on default keys and properly placed the player on top of it(if set as below characters) before "push to play".

It is running if I set it as "autorun", however... But I do need it to be run by [Action Button]. Can anybody tell me the possibility that can cause this issue?
 

Attachments

  • actionbuttontrouble.png
    actionbuttontrouble.png
    65.7 KB · Views: 44

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
35,808
Reaction score
9,466
First Language
German
Primarily Uses
RMMV
where exactly is the player standing and facing when you press the action button?
when set to "same as character", the player needs to be standing next to the event and facing it in order for the action button to work.
If that doesn't work, something has to have changed the engine and we need to see a screenshot of your plugin manager as well as learning the version numbers of both the editor and the projects core files (which may or may not be identical)

and please, next time don't crop as much away from your screenshots. It is barely visible that this is a one-page-event, and that is important because multipage events have to check for page priority as well.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,715
Reaction score
15,839
First Language
English
Primarily Uses
RMMV
Is there actually an image selected for the event? Is it from the character sheets, or is it from the tileset (or is it just blank)?
 

uglywolf

Veteran
Veteran
Joined
Nov 9, 2015
Messages
68
Reaction score
83
First Language
Malay
Primarily Uses
RMMV
@Andar
Guess I forgot to mention that I've tried all three option from "Below", "Same", and "Above" the characters. All of those gives the same results.

My bad about the screenshot, I am pretty much making a priority for smaller space size. So I tend to do that much. Here is the one I just captured.

This is the actual event, it required several conditions to run. BUT, even though I removed those condition, it still doesn't run if I pick [Action Button] trigger.

The story is, It actually worked quite awhile. But after I find some bug on the actor graphic transparency, I changed the specific lines to make it work again. However, it had nothing to do with the said event because the transparency was run by another event.

However, after I changed that, it happened. I can't run the said even by [Action Button], once again, it does run on [Autorun] mode.

Is there actually an image selected for the event? Is it from the character sheets, or is it from the tileset (or is it just blank)?

It's on a Map, I am not sure what do you mean by tilesets or character sheet. But if I put it as "Below Characters", does count as tileset?
 

Attachments

  • rpgmaker-bug.png
    rpgmaker-bug.png
    155.2 KB · Views: 22
  • rpgmaker-bug3.png
    rpgmaker-bug3.png
    169.8 KB · Views: 22
  • rpgmaker-bug-myplugin.png
    rpgmaker-bug-myplugin.png
    56.9 KB · Views: 23

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
35,808
Reaction score
9,466
First Language
German
Primarily Uses
RMMV
@Andar
It's on a Map, I am not sure what do you mean by tilesets or character sheet. But if I put it as "Below Characters", does count as tileset?
Shaz' is talking about the image property on the left half of your event screenshots.
Doubleclicking there gives you different options to select, sprite or tile for example - and the behaviour of the event will change depending on what is selected there (for example if you select a tile there then that event will gain the tile properties like passability and so on)

however, the real first question is to check if the event even exists when you try to activate it.
Please put any sprite as the image, making the event visible on the map. Then run playtest again.

If the sprite is now NOT visible, then that means that the event has not met the conditions you set for the event page.
If an event has no pages that have conditions fulfilled, then the event does not exist on the map - and you can't trigger an event that does not exist.

Most likely it's the variable - if this is on a new game, all variables start at zero - so unless you have another event on autorun that increases that variable, the condition is not met and the event does not exist - and doesn't react to action button because of this.
 

SwiftSign

Veteran
Veteran
Joined
Aug 5, 2015
Messages
184
Reaction score
45
First Language
English
Primarily Uses
RMMV
You don’t seem to have Yanfly’s core plugin, but are using his message plugin.
 

uglywolf

Veteran
Veteran
Joined
Nov 9, 2015
Messages
68
Reaction score
83
First Language
Malay
Primarily Uses
RMMV
@OnslaughtSupply
*facepalm* I am not sure either you've checked my previous post carefully, or just wanted to increase your post counts...

@SwiftSign
That I do, yes. I try using the core as you might try to suggest, but nothing changes, indeed. Yes, Yes, it doesn't change anything, Yes, Of course, nothing changed, Yes, Right, it changes nothing. OmO#

@Andar
The event is there, it existent. I assure you, because if the player collided with "Same as characters" events without "Through", they won't be able to move from that same spot at all, it also the same if both the "Player" and the "Event" on the same spot.

The other event will make the "Player" become through at first while activating the required switches and variable. After that, it will make the Player's "Through" OFF and the event will end, leaving the "Player" and the "Event" collided on that same spot.

And from my experience, if there is no other event on either four sides of the "Player" which collided with "Same as characters" event, using the action button will trigger that "Same as characters" event instead.

Mark my words: "It worked before, it just won't right after I changed the unrelated event by adding some lines without modifying everything else. I tried I removed the added lines, or even copying the events, and even try copy/cut > delete > paste from and to other map + to making a new map from scratch(reason of why I reply late). However, nothing changed as everything still the same, that it won't trigger by [Action Button]."

I provided a picture which that event had a graphic just in case if you didn't believe my words. And yes, "Action Button" triggered nothing.
 

Attachments

  • rpg-mvevent-exist.png
    rpg-mvevent-exist.png
    221 KB · Views: 15

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
14,187
Reaction score
15,264
First Language
English
Primarily Uses
RMVXA
Events do not mysteriously stop working. If they stop working YOU set something to make them not work. Hence why everyone is suggesting you check your switch and/or your variable. If you want to be sure it is set, pull up the debug menu and see if they are set properly (F9 I believe? Though MV might have added that to a menu now, as I seem to recall seeing it in the menu).

Otherwise I think you're going to have to upload the project so someone can look at it and see why it is not working.

Edit: Before you go that far though, check to see if you can interact with any event on action button/same as player (with no conditions too. So no switches, or variables set too). If you can't then you somewhere turned Through ON for the player, and once you do that you can never interact with another event until you call Through OFF, as Through ON means you pass through everything, even events.
 
Last edited:

OnslaughtSupply

Ssshhh...
Veteran
Joined
May 14, 2017
Messages
730
Reaction score
766
First Language
English
Primarily Uses
RMMV
@uglywolf I was referring to your screen shots because events don't suddenly stop working for some magical and unknown reason, typically it's from an event's conditions not being met. Andar had suggested checking your variable and I had noticed that you had switch set to condition as well. Good luck with your game and if you're going to pass on your frustrations with bug hunting your game good luck getting people to help.
 

uglywolf

Veteran
Veteran
Joined
Nov 9, 2015
Messages
68
Reaction score
83
First Language
Malay
Primarily Uses
RMMV
Thanks @OnslaughtSupply , @bgillisp
But, spare me guys...
:yamero:

Because it's Mysteriously Doesn't Work is the reason why I bother myself to ask here. If you find it odd, so do I, I am not that new to RPG Makers.
As I suspected, you probably didn't carefully check the posts I've made.

Please be noteful that, the first post was provided an information that the event was set "without variables", it still won't run using [Action Button]...

And the second post is the actual event that required the conditions for it to run. While the third post is an evidence that the event was existent, yet with [Action Button] the script won't run.

Let me mention this once again, it will run if set as [autorun] regardless of the conditions being there or not. But I need it to run via [Action Button], not the other "Option"s.

[PS: I've started to get frustrated over here... I am sorry if I accidentally offended anyone by mistake.]
 
Last edited:

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
14,187
Reaction score
15,264
First Language
English
Primarily Uses
RMVXA
One thing about that makes no sense. You say it runs as autorun regardless of the conditions set, but that is impossible by how computers work. I bet if you set it to run if switch 999 is ON it won't run, as odds are very high you have that switch set to off, or if you change the variable condition to >= 9999999999 then set it to autorun.

Also did you check to see if you are on through by accident? As in, did you see if you can activate any other event with no conditions at all? If not, then you set player through a long time ago, and you will have to turn that off else no events will ever work with action button.

If that isn't it you will have to share the project for us to help further, as there is nothing more we can do at this point with the information you provided.
 

uglywolf

Veteran
Veteran
Joined
Nov 9, 2015
Messages
68
Reaction score
83
First Language
Malay
Primarily Uses
RMMV
Nevermind...
It mysteriously worked now, I don't know what's in-and-out or there-and-here of the problem any longer... Since it's already working now. No, I didn't do anything particular, no changes from the last time since all I did was removing, and re-adding the same thing over and over...

It's fine, you don't need to believe what I've experienced...
MODs can lock the thread or do whatever needs to be done here indicating it solved. If such thing as odd as this happens again in the future, I won't be asking here because of twisted logic...

YQDBzTz.png

(Like I said... Even I don't know what is actually happening. This is a computer we are talking about, that I know well as any of you does.)
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
14,187
Reaction score
15,264
First Language
English
Primarily Uses
RMVXA
Hmmm...honestly I suspect a corrupted file then, or a mismatch of versions of core files, which is why I said we'd have to see the project to tell further. If it happens again I'd suggest deinstalling and reinstalling RPGMaker.

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Latest Profile Posts

its_a_random_world.jpg
Well after half a year of health problems (that aren't as bad as before), and playing with UE4 & 5... I realized I should finish this project before working on something else. So I decided to upgrade my randomizer. And really just focus on compromising wherever I can to finish the project sooner rather than later. :kaoswt:
hmmm. an art of mine was removed from reddit, for a reason not even listed.

Forum statistics

Threads
121,890
Messages
1,144,956
Members
160,143
Latest member
Krockhunter
Top