Map saver script error. Help!?

Discussion in 'RGSSx Script Support' started by goldfrappian, Jun 16, 2014.

Thread Status:
Not open for further replies.
  1. goldfrappian

    goldfrappian Villager Member

    Messages:
    12
    Likes Received:
    0
    Location:
    Port Augusta, South Australia
    First Language:
    English
    Hello
    I'm trying to use the map saver script (converted by Yami for RPG maker vx ace but an error message keeps popping up. 
    I have also tried other solutions in the forum such as game_interpreter script but that didn't help either. 
    Any advice would be great.

    error.png
     
    #1
  2. Andar

    Andar Veteran Veteran

    Messages:
    28,418
    Likes Received:
    6,485
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    Please link to the script you're using, no one can help you with the error message alone, we need to see the coding of the script.
     
    #2
  3. Shaz

    Shaz Veteran Veteran

    Messages:
    37,709
    Likes Received:
    11,418
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    I've moved this thread to RGSSx Script Support. Please be sure to post your threads in the correct forum next time. Thank you.


    forcing_battler is not in the default scripts, and I can see no reason why a map saver script would introduce it. Also, Game_Interpreter lien 126 would NOT generate that error, unless you have modified that script or added another one with extra functions for the same class.


    I suspect you have added OTHER scripts, and one of THOSE is the problem. Please list the other scripts you are using and include links to them as well.


    "Trying other scripts" to overcome an existing problem is only going to make it worse.
     
    #3
  4. goldfrappian

    goldfrappian Villager Member

    Messages:
    12
    Likes Received:
    0
    Location:
    Port Augusta, South Australia
    First Language:
    English
    No need for the condescending manner, everyone begins somewhere. SORRY to post in the wrong area.

    The script i used is two comments down. As it was apparently a VX ACE conversion.

    http://www.rpgmakervxace.net/topic/669-map-saver-script-conversion-request/?p=8571#entry8571

    I had used this script before with no problems, but this time i can't tell what i am doing wrong, hence why i posted the question. 

    I deleted the ONLY other script i was using which was the parallax locking script and STILL get an error msg 

    "script 'Game_Interpreter' line 1411: NoMethodError occurred.
    undefined method 'update' for nil:NilClass

    Sorry for the late response, have been at work. 
     
     
    #4
  5. Andar

    Andar Veteran Veteran

    Messages:
    28,418
    Likes Received:
    6,485
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    then please check the "empty" slots in the script editor.


    It had happened several times that someone added a script and forgot to name it, and then it broke his game while he believed there would be no scrip remaining inside his project (one or two weeks ago was the last case of this happening)
     
    #5
  6. Shaz

    Shaz Veteran Veteran

    Messages:
    37,709
    Likes Received:
    11,418
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    *sigh*


    Please don't be so quick to take offense. What I wrote was template text - I type a certain word, the forum software replaces it with what you see. If you read other threads, you will see the exact same message from other mods.


    Does it not matter that I actually spent the rest of the post helping you?
     
    #6
  7. goldfrappian

    goldfrappian Villager Member

    Messages:
    12
    Likes Received:
    0
    Location:
    Port Augusta, South Australia
    First Language:
    English
    Thank you Shaz. I am sorry, and really appreciate your reply. 

    Thank you Andar. I had stupidly missed this.
     
     
    #7
  8. Shaz

    Shaz Veteran Veteran

    Messages:
    37,709
    Likes Received:
    11,418
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    Game Interpreter 1411 is trying to run a Script command that you've got in an event somewhere. Either a parallel or autorun event on the map or in common events, or an event that you've just activated, is trying to do a Script call with <something>.update as a command.
     
    #8
  9. goldfrappian

    goldfrappian Villager Member

    Messages:
    12
    Likes Received:
    0
    Location:
    Port Augusta, South Australia
    First Language:
    English
    Thank you shaz. My problem is solved. :)  

    And again, very grateful for your help. 
     
    #9
  10. Shaz

    Shaz Veteran Veteran

    Messages:
    37,709
    Likes Received:
    11,418
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.
     
    #10
Thread Status:
Not open for further replies.

Share This Page