Map transition and load issues with Yanfly's Grid-Free Doodads

PathosFear

Veteran
Veteran
Joined
Dec 23, 2012
Messages
53
Reaction score
10
First Language
Swedish
Primarily Uses
N/A
So, whenever I load a game or transition from one map to another, "doodads" placed and player party load before the rest of the map, making things look silly, as there are a couple of flowers and furniture in an infinite void of darkness before the rest of the map fades in. Also, for some reason, using the standard save feature (not yanfly's save core), savefiles will not display characters until you load a game and exit back to title menu, at which point they return.

Anyone had this problem and know of a fix?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,776
Reaction score
7,872
First Language
German
Primarily Uses
RMMV
I think there is something wrong with your engine, most likely cause by plugins.
so please give us screenshots of your plugin manager so that we can check what plugins you have installed and in whivch order.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,776
Reaction score
7,872
First Language
German
Primarily Uses
RMMV
your yanfly plugins are in the wrong order, please correct that so that every plugin is exactly in the order given on yanfly's website and then test with a new game (changing that order will invalidate all older savefiles)
 

PathosFear

Veteran
Veteran
Joined
Dec 23, 2012
Messages
53
Reaction score
10
First Language
Swedish
Primarily Uses
N/A
your yanfly plugins are in the wrong order, please correct that so that every plugin is exactly in the order given on yanfly's website and then test with a new game (changing that order will invalidate all older savefiles)

That's odd, I thought I did that a couple of weeks ago when I had problems with another plugin. I'll go over it again then, must have backuped the wrong project (keeping multiple copies in case i eff up). Anyhow, They are in the proper order now, and the problem is lesser now, but still there. Before the doodad's used to load several frames before the map (or at least before the map transition fade stopped playing), now it's just one or two frames, hard to even catch, but it's there :/
 

Hyptosis

Villager
Member
Joined
Dec 20, 2012
Messages
20
Reaction score
33
First Language
English
Primarily Uses
I've been having this same issue, I've checked and double checked to make sure all my yanfly stuff is in order, and I've disable any other plugins.

I found a way to 'hide' this issue using a solid black picture (.png), and using it to 'show picture', 'move picture' (increase opacity) and make my own fake transition fades, but it isn't the solution I like as it doesn't fix the real problem, but it looks nice and allows me to control the speed of the fade in and out for effect.

The only other solution I've found it to turn off the doodad plugin.

Just in case I'm blind, or am misunderstanding the webpage, here is my order of plugins.



It is also worth noting it only happens the first time a map loads. When you reload a map via transition, they load fine. I also just tried turning off every yanfly plugin (or any other plugin by anyone) except the CoreEngine one, and the 2 doodad ones, and it still happened.

I'm wondering if this is a 1.6.1 issue or if I'm missing the obvious, anyway, hope this helps.
 

Attachments

  • yanfly.png
    yanfly.png
    592.9 KB · Views: 7

Latest Threads

Latest Posts

Latest Profile Posts

2021? I still wonder if people still doing MV than MZ more
Seeing a lot more active Ace topics recently, is it making a comeback? :o
0-7, left-to-right, top-to-bottom
As soon as I'm able to get out of bed I'm probably gonna go so hyper from being too cooped up, and burn myself out into another awful flare. lol
It makes me feel proud whenever an RM game does well. Even though I had nothing to do with it.

Forum statistics

Threads
107,627
Messages
1,031,013
Members
139,746
Latest member
Krunga
Top