Miss Sound Effect plays twice for some reason...

Status
Not open for further replies.

zerobeat032

Cloaked Wanderer...
Veteran
Joined
Mar 28, 2014
Messages
348
Reaction score
552
First Language
English
Primarily Uses
RMMV
It just started recently, but for some reason whenever anyone, actor or enemy misses, the miss SE plays twice. I'm not sure what could be causing that. I've edited some stuff in the js files but I saw nothing that would suggest a reason why "miss" would play two times in a row.

EDIT: I think this needs to be moved to Javascript support as I realized a plugin is causing this. YEP BattleCoreEngine... but it's never done this before. I've noticed with Evasion or Miss, it'll double the sound effect, playing it twice over itself. but only with misses or evasions.
 
Last edited:

Dev_With_Coffee

Veteran
Veteran
Joined
Jul 20, 2020
Messages
224
Reaction score
79
First Language
PT-BR
Primarily Uses
RM2k3
Create a new project and gradually add what you have done to your current project.
With each modification, test a battle, add the attributes and levels that guarantee the best chance of "making mistakes".
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
694
Reaction score
370
First Language
English
Primarily Uses
RMMV
If it just started recently, did you add a new plugin or setting recently? Double-check that your plugins are in the order given by the author, especially Yanfly stuff, as that's the most common cause of random glitches.

Otherwise...yeah, it's add one plugin at a time until you figure it out.
 

zerobeat032

Cloaked Wanderer...
Veteran
Joined
Mar 28, 2014
Messages
348
Reaction score
552
First Language
English
Primarily Uses
RMMV
It's just the BattleEngineCore on it's own I've noticed... I turned off everything else and then saw that when an actor or enemy missed... it'd play the miss or evasion SE twice. the only difference I noticed with other plugins on is how wide apart it'd play them. Action sequences made them play wide apart. like one would finish then it'd play again. without action sequences... they'd essentially overlap each other. you'd ALMOST miss it if you weren't paying attention. I looked through out the file and I can't see what would be causing this out of nowhere... especially with it being the only plugin on.

EDIT: I, lol... I found a super silly workaround for the time being. I set miss and evasion sound to none and did the following with action sequences, thankfully I'm not too far with my skills or else copying this would've been a bigger hassle but...

if target.result()evaded || target.result()missed
SE: Whoosh (or whatever sound you want)
end

and it works... silly but effective. I guess I'll close this. but JUST in case anyone else where to every randomly have this issue, I figured I'd post the solution I came up with lol...
 
Last edited:

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
41,861
Reaction score
14,512
First Language
English
Primarily Uses
RMMV

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Latest Threads

Latest Profile Posts

Working on animation. Trying to see if I can apply it meaningfully to my games!
ddwk.png

working on the sprite for Devali <3
My Game Development Livestream

Of course, so, someone had covid at work today and I was exposed to them, so, I'm stuck at home for...TWO WEEKS!

Forum statistics

Threads
110,371
Messages
1,052,703
Members
143,404
Latest member
Ledsoi_Terwa
Top