MOG - Title Multibackground

Discussion in 'RGSS3 Script Requests' started by Kyuukon, Mar 27, 2015.

  1. Kyuukon

    Kyuukon 主人公 Veteran

    Messages:
    2,217
    Likes Received:
    1,075
    First Language:
    Spanish
    Primarily Uses:
    RMMV
    Here is the Pastebin for convenience: http://pastebin.com/mARaCB7A

    Here is the whole script: https://atelierrgss.wordpress.com/rgss3-custom-title-screen-stand-alone-scripts/

    After a few tests I realized that the background waving effect is not working properly. Whenever I configure the script to use it, the game crashes with the following error:

    [​IMG]

    And no, it's not because I miss some graphics. Here is what happens if I place 'g' in said folder:

    [​IMG]
    Even MOG himself commented the line that used the effect out T.T and he won't respond so...

    What I'm asking here is: Is there a quick easy fix to it? The function itself is already written. I'm not very knowledgeable with the Ruby sintax so I'd rather avoid all the trouble of looking it up myself and breaking things up in the way :3

    Thanks! It'd be really cool if this thing worked >o<
     
    Last edited by a moderator: Mar 27, 2015
    #1
  2. Zarby

    Zarby Veteran Veteran

    Messages:
    42
    Likes Received:
    25
    Location:
    Quebec, Canada
    First Language:
    French
    there is a little problem in the script here how to fix it replace line 94 :

          sprite.bitmap.stretch_blt(sprite.bitmap.rect, bb_bitmap(index,data), bb_bitmap(index,data).rect)

    it should fix the 2 errors the script was sending wrong data the letter #4 of the background "g" for you, and the other was not sending data at all causing the other error :)
     
    #2
    Kyuukon likes this.
  3. Kyuukon

    Kyuukon 主人公 Veteran

    Messages:
    2,217
    Likes Received:
    1,075
    First Language:
    Spanish
    Primarily Uses:
    RMMV
    Thanks! It worked :D xD! :rock-left:
     
    Last edited by a moderator: Mar 27, 2015
    #3

Share This Page