Mog_SceneEquip edit please

J-G

Veteran
Member
Joined
Oct 4, 2019
Messages
505
Reaction score
125
First Language
English
Primarily Uses
RMMV
Can someone help me edit Mogs scene equip plugin in. There are some features missing that his other scene plugins have 2020-05-20 16_51_51-Legend of the Shield Hero.png
For example the item description is not movable. So the description saying simple sword shows outside of the description box.
The face icon used cannot be moved either.
The weapon slots can be shifted but the actual weapon, armor, and accessories name cannot be moved. So if the layout moves, the names remain in place, looking weird since they didn't move with it.

So can anyone add.
Face x & y position change
Help description x & y
Weapon x & y change
Shield x & y change
Clothes x & y change
Hat x n y change
Accessory x n y change
Also if x n y is not present from any weapon it will omit it so it won't show.

I would really appreciate it.
 

minnty200

Veteran
Veteran
Joined
May 2, 2020
Messages
52
Reaction score
18
First Language
eng
Primarily Uses
RMMV
Is the face bitmap you are using that exact one in your example? Are you planning to have it show up above/on top of the other windows?
 

J-G

Veteran
Member
Joined
Oct 4, 2019
Messages
505
Reaction score
125
First Language
English
Primarily Uses
RMMV
Yes Im using that one for all my other scenes but want to move it right into that empty space I created between all the window layouts.
I tried seeing if I could on my own by edit the code but haha I didn't understand anything on it.
 

minnty200

Veteran
Veteran
Joined
May 2, 2020
Messages
52
Reaction score
18
First Language
eng
Primarily Uses
RMMV
Hello!! Sorry it took awhile, I was watching netflix while doing it haha.

Your first request for changing the x and y coordinates of the face turned out to be quite the challenge for me haha. I had to create a new function outside of the pre-existing ones for it to actually show on top of all other windows...

I have created two parameters you can play with Bust x-axis, Bust y-axis. The image file name and location has not changed and should still be saved the same. Example: img/menu/faces1/Actor_1

I put it in pastebin... I hope I copied it right! Let me know if there are errors....

-------------------
The other request about the x,y of the description box and the equipment slots was also a bit confusing...
The Parameters are there already but they kind of function differently than you would expect...

Basically, The "Help X- Axis" and "Help Y- Axis" moves both the text description and layout.
"Help layout X-Axis" and "Help Y-Axis" moves the layout in relation of the text description as it's origin point.

E.g. Let's say the text "Simple Sword" was showing up "above" the layout of the description box. To fix it you would move Help x-axis and Help y-axis down to where you desired the text to be lets say x =0 y =516. Then you must adjust Help layout X-Axis and Help Y-Axis in relation to the cordinates of the text"Simple Sword". If you enter 0,0 into the help layout x/y axis variables the coordinates on screen for the description box will be x = 0 +0 and y= 516+0. If you enter 14,-27 into the help layout x/y axis variables, the coordinates on screen for the description box will show up as x=0+14 and
y=516-(-27) when you open it up in a playtest.


This is the same for the slot coordinate variables.
 
  • Like
Reactions: J-G

J-G

Veteran
Member
Joined
Oct 4, 2019
Messages
505
Reaction score
125
First Language
English
Primarily Uses
RMMV
Wow no wonder I was like everything is moving but it wasn't right haha, I'll give it a shot now and let you know what happens. Thanks so much for your help so far

Edit. Okay, it works good, I can move it about, opacity of layer is odd though. Things I couldn't see in my editor because opacity was low were visible during game test now lol but that's fine. I simple edited image and made sure it was cleaned up.
The move for description was helpful. Thanks

Only issue is that there is huge lag when I'm in the equip scene now. Now sure why though.
 
Last edited:

minnty200

Veteran
Veteran
Joined
May 2, 2020
Messages
52
Reaction score
18
First Language
eng
Primarily Uses
RMMV
Only issue is that there is huge lag when I'm in the equip scene now. Now sure why though.
Hmmm... I'm still learning Javascript, so there might be an optimization error I made. I'll see if I can figure it out tommorow. x.x
 
  • Like
Reactions: J-G

J-G

Veteran
Member
Joined
Oct 4, 2019
Messages
505
Reaction score
125
First Language
English
Primarily Uses
RMMV
Okay thank you so much!!
 

minnty200

Veteran
Veteran
Joined
May 2, 2020
Messages
52
Reaction score
18
First Language
eng
Primarily Uses
RMMV
Does the lag happen when you switch between characters in the status scene? Or just in general when you open up the status scene?
 

J-G

Veteran
Member
Joined
Oct 4, 2019
Messages
505
Reaction score
125
First Language
English
Primarily Uses
RMMV
Pretty much as soon as I open it

Even crashed my driver a few times
 

minnty200

Veteran
Veteran
Joined
May 2, 2020
Messages
52
Reaction score
18
First Language
eng
Primarily Uses
RMMV
I can't seem to replicate the error, when I try it on my side it doesn't seem noticeably different to me compared to the original MOG script...


I'm trying to make a separate function in the code that will update the bust image when you switch characters. But since it's lagging when you initially open the scene, i'm a bit stumped as to what is causing that... x_x
 

J-G

Veteran
Member
Joined
Oct 4, 2019
Messages
505
Reaction score
125
First Language
English
Primarily Uses
RMMV
It tends to happen more heavily when trying to equip and unequip. Like everything slows down and if I don't exit fast enough everything crashes.
 

minnty200

Veteran
Veteran
Joined
May 2, 2020
Messages
52
Reaction score
18
First Language
eng
Primarily Uses
RMMV
Okay I spent a lot of time trying to figure out what was causing the lag X_X. I still wasn't able to replicate the error on my side, so I was basically working blindly thinking about things that might be able be the problem. I think maybe that the sprite is being constantly uploaded, so I tried to fix that x.x....


Hope it improves it somehow..

EDIT: If it doesn't work still, I can maybe give it another shot and try something else. >_<
 
Last edited:
  • Like
Reactions: J-G

J-G

Veteran
Member
Joined
Oct 4, 2019
Messages
505
Reaction score
125
First Language
English
Primarily Uses
RMMV
Thank you I will give it a shot here in about an HR or 2. As soon as I tested I will edit my post and like yours lol

Edit.
So behavior was slightly better but it still begins to build lag and eventually it crashes rpg engine.
 
Last edited:

J-G

Veteran
Member
Joined
Oct 4, 2019
Messages
505
Reaction score
125
First Language
English
Primarily Uses
RMMV
Bump

edit:
Okay I spent a lot of time trying to figure out what was causing the lag X_X. I still wasn't able to replicate the error on my side, so I was basically working blindly thinking about things that might be able be the problem. I think maybe that the sprite is being constantly uploaded, so I tried to fix that x.x....


Hope it improves it somehow..

EDIT: If it doesn't work still, I can maybe give it another shot and try something else. >_<
This is what i meantequip scene mog.png
 
Last edited:

minnty200

Veteran
Veteran
Joined
May 2, 2020
Messages
52
Reaction score
18
First Language
eng
Primarily Uses
RMMV
Okay I fixed the image problem. I'll just give you the snippet here.

Please replace the function Update Floating FaceSprite to as follows:
JavaScript:
//==============================
// * Update Floating FaceSprite
//==============================
Scene_Equip.prototype.updateActorSprite = function() {
     this._actorSprite.bitmap = ImageManager.loadMenusFaces1("Actor_" + this._actor._actorId);
};
Secondly I think I messed around with the column sizes to fit the resolution of my own game. There is a function called max Cols (near the end of the code) I believe that was at 2 in the original MOG_Script. try tinkering with that to see if that helps with the squished lettering.
 

J-G

Veteran
Member
Joined
Oct 4, 2019
Messages
505
Reaction score
125
First Language
English
Primarily Uses
RMMV
Awesome. As soon as I'm done cloning my drive I'll give it a go. About the max cols, should it be higher then 2?
 

minnty200

Veteran
Veteran
Joined
May 2, 2020
Messages
52
Reaction score
18
First Language
eng
Primarily Uses
RMMV
The window length for the equip slot is something I wasn't able to figure out, I have the same issue in my game but I decided to just leave it. =(
 

minnty200

Veteran
Veteran
Joined
May 2, 2020
Messages
52
Reaction score
18
First Language
eng
Primarily Uses
RMMV
Awesome. As soon as I'm done cloning my drive I'll give it a go. About the max cols, should it be higher then 2?
The lower the number I think the better. I have mine at 4 because I have a larger window to work with, so I can manage having the window divided by 4, if you have a smaller window I think its better to have it at a lower number like 2.
 

J-G

Veteran
Member
Joined
Oct 4, 2019
Messages
505
Reaction score
125
First Language
English
Primarily Uses
RMMV
Ohhh okay and I actually found a possible solution to the window highlight thing. Not sure if it can be inserted with in the plugin in itself or if it's best as a stand alone

Don't worry about taking long. I just appreciate all your help!
 

minnty200

Veteran
Veteran
Joined
May 2, 2020
Messages
52
Reaction score
18
First Language
eng
Primarily Uses
RMMV
If you get around to trying it, let me know if it works for you!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts


:3c here's a thing i made a while while while back
Tried mochi for the first time. It's quite nice. Has a pleasant smell and taste, and is nice and chewy.
made a bio for the protag in my project!
Beggar : "I haven't eat for days..."
Kid : "Just do crime! You will get daily necessity for free in prison~"

Forum statistics

Threads
99,159
Messages
962,458
Members
130,726
Latest member
Milan1311
Top