MogHunter's Battle Hud with VE Damage Pop-up

Discussion in 'Javascript/Plugin Support' started by dragonx777, Mar 13, 2018.

    Tags:
  1. dragonx777

    dragonx777 Veteran Veteran

    Messages:
    39
    Likes Received:
    2
    Both plugins (Mog_Battle Hud and VE Damage Pop) work fine separately. Without the Battle Hud, the damage pop plugin works as it should. Since updating the BH to v4.0 (as per Mog's website and newest demo), the VE plugin no longer works. I've tried rearranging the plugins, turning off all non-essential plugins and still cannot get it to work. I like the way the damage pops show (much better than default), but can't get it to work properly. I started a new project as well with just these scripts (along with VE Basic Module) and the damage pop worked on the enemy, but not on the actor.

    Any help would be greatly appreciated.
     
    #1
  2. Kwerty

    Kwerty Veteran Veteran

    Messages:
    185
    Likes Received:
    109
    First Language:
    English
    Primarily Uses:
    N/A
    Strange,

    -- General note - if you want VE Damage Popup to work, you should definitely use VE Basic Module, it is listed by Victor as a required plugin for all his other plugins to function.

    -- Try this first -
    Use Victor Basic Module + VE Damage Popup -- no other plugins. After a test does the Damage Popup work for you on actors/enemies?

    If it's still not behaving correctly When switched on and activated, it suggests that it could be your settings in your VE Damage Pop plugin that are at fault (simple fix), so check they are correct..

    Alternatively and IMO, less likely...It could be the latest update from Mog has created a conflict.

    I am using, in this order..
    VE Basic Module V1.23
    VE Damage Popup V2.04
    Mog_battlehud V3.6

    And Damage Pop Up works just fine..!
     
    #2
  3. dragonx777

    dragonx777 Veteran Veteran

    Messages:
    39
    Likes Received:
    2
    I'm using Mog_battlehud V4.0. Do you have a copy of the 3.6 that you could send me? I have the plugins in the same order and having the same issue. The other issues that I found with V3.7 and V4.0 are that the digits on the hud don't roll and the current TP doesn't show up.

    Damage to Enemy
    upload_2018-3-13_12-15-57.png

    Damage to Actor
    upload_2018-3-13_12-16-28.png

    Plugins Used
    upload_2018-3-13_12-17-57.png
    upload_2018-3-13_12-18-22.png
     
    #3
  4. dragonx777

    dragonx777 Veteran Veteran

    Messages:
    39
    Likes Received:
    2
    Strangely enough, when I tried the same setup in an older project, it worked fine. When I changed the positioning of the Hud on the old project with the same parameters as my current project, it broke. I can't figure out what's going on with this. It may be the v4.0 but I have no way of testing another version.
     
    #4
  5. dragonx777

    dragonx777 Veteran Veteran

    Messages:
    39
    Likes Received:
    2
    Found another version on an older copy with v3.7. Worked fine. Updated to v4.0. Worked fine. Changed the layout position. Didn't work. o_O
     
    #5
  6. Craig

    Craig Veteran Veteran

    Messages:
    47
    Likes Received:
    65
    First Language:
    English
    Primarily Uses:
    RMMV
    Try moving SRD_SuperToolEngine to the very top, and all your VE and MOG stuff to right below the YEP_X_BattleSystemATB. If that doesn't work, you can try the SRD_BattlePopupCustomizer instead of the VE version. I have not been having any problems with it.

    Unrelated, and may not be an issue for you, but the PrettySleekGuages plugin was causing a weird issue with EXP in my game, so just double check and make sure it isn't causing any issues!
     
    #6
  7. dragonx777

    dragonx777 Veteran Veteran

    Messages:
    39
    Likes Received:
    2
    Still not working.

    As far as the PrettySleekGauges, mjshi, the creator, updated my plugin for it to work. I can send you it if you like @Craig.

    I guess at this point, I'll need someone to make the two compatible. Victor Sant responds eventually, and I've posted the bug to his site. I also sent an email to Mog and waiting for a reply. But, if someone knows of a quicker fix that can handle this for me, that would be great. I'm trying to get a demo out this week to some testers.
     
    #7
  8. Craig

    Craig Veteran Veteran

    Messages:
    47
    Likes Received:
    65
    First Language:
    English
    Primarily Uses:
    RMMV
    Then I would definitely recommend the SRD_BattlePopupCustomizer. Hopefully you can achieve the same effect that you are looking for, and it actually work, lol!

    Neat that you got the PrettySleekGauges to work! Thanks for the offer, but I found something else that is working well for me!
     
    #8
    dragonx777 likes this.
  9. dragonx777

    dragonx777 Veteran Veteran

    Messages:
    39
    Likes Received:
    2
    It's not as nice as VE, but it works. I'm not sure what the difference is, or why it works, but, hey, it works. Thanks @Craig. With the Mods permission, I would like to keep this open to see if someone can fix this as I would prefer VE for my final product. I really like the rolling digits and that it shows 0 damage (SRD does, but it glitches), but it's not necessary. If the Mods feel that this is resolved, then I'm fine with them closing it.
     
    #9
  10. Kwerty

    Kwerty Veteran Veteran

    Messages:
    185
    Likes Received:
    109
    First Language:
    English
    Primarily Uses:
    N/A
    You can always put out a request in classifieds for a scripter to fix the compatability issue you are experiencing.

    It’s not likely Victor or Mog will do it for you. But shouldn’t cost much for someone to fix this for you I imagine :)

    Good luck in your project
     
    #10
  11. dragonx777

    dragonx777 Veteran Veteran

    Messages:
    39
    Likes Received:
    2
    I may try that later, but in the meantime, I'll leave it as is. Thanks. I consider this resolved for now and the thread can be closed.
     
    #11
    Kwerty likes this.

Share This Page