Mando Jetii

Veteran
Veteran
Joined
Dec 15, 2016
Messages
39
Reaction score
4
First Language
English (US)
Primarily Uses
RMMV
I am using a number of Yanfly plugins. The relevant ones that I'm using are Battle Core; Action Sequence Packs 1, 2, & 3; and Animated Side-view Battlers. I don't think Animated SV Battlers is affecting it, but it might be.


I'm getting this odd error while using action sequences: I set the user to use the "swing" motion while using a sword skill, but although the weapon appears right, the character performs the "skill" motion instead. I don't know if this has been asked before or not, and it is a somewhat minor issue as it took me a while to even notice it, but it is still a problem because if a player notices it, it will make the game look unprofessional.


Here are the note tags of one of the skills that I've noticed the problem on:


<Target Action>


      move user: target, front base, 4


      face user: forward


      motion swing: user


      perform action


      motion wait: user


      action animation: target


      wait for animation


      action effect: target


      death break


</Target Action>


<follow action>


      perform finish


</follow action>


To recap the issue, the sword is appearing as it should but the SV actor sprite is using the "skill" motion instead of the "swing" motion, causing the sword to float next to the actor's hand instead of being gripped in it.


ActionSequenceError.png
 
Last edited by a moderator:

ashikai

Veteran
Veteran
Joined
Jun 2, 2015
Messages
456
Reaction score
343
First Language
English
Primarily Uses
N/A
Can you share the SV spritesheet you're using? Just so we can rule out any issues with the graphic layout. You could also try using motion attack:user  in place of swing just to see if that still uses skill. Can you also post a screenshot of the skill in the database?
 

Mando Jetii

Veteran
Veteran
Joined
Dec 15, 2016
Messages
39
Reaction score
4
First Language
English (US)
Primarily Uses
RMMV
Can you share the SV spritesheet you're using? Just so we can rule out any issues with the graphic layout. You could also try using motion attack:user  in place of swing just to see if that still uses skill. Can you also post a screenshot of the skill in the database?

Here is the image file. It was created using the character generator so there shouldn't be any issues, and I already checked and the animations are placed in the right order.


I just tried your suggestion of using "motion attack: user" instead of "motion swing: user" but the result was the same.


As you can see in the screenshot, I'm porting over VX Ace skills into an MV test project. I actually first noticed the animation error when testing Radiant Blade, but I chose to show Aura Blade's note tags because Radiant Blade required some funky notation in order to work with the "All Enemies" target scope. Both skills are showing the same error, and both use the same motion notation.


Ace-Actor1-1.png


ASError_SkillsDatabase.png
 
Last edited by a moderator:

Mando Jetii

Veteran
Veteran
Joined
Dec 15, 2016
Messages
39
Reaction score
4
First Language
English (US)
Primarily Uses
RMMV
Still no luck finding a solution. I'm really hoping that Yanfly sees this thread and can give me an answer. I discovered today that I was missing the Skill Core plugin, but problem is still occurring with the plugin installed. I'll keep testing to see if I can find a solution. The real question is: is there a problem with how my project or skills are set up or is this an issue within the plugin itself? I'm going to try a new project with all of the plugins ordered according to Yanfly's plugin list to see if this corrects the issue.
 

ashikai

Veteran
Veteran
Joined
Jun 2, 2015
Messages
456
Reaction score
343
First Language
English
Primarily Uses
N/A
Did you make sure that the sword type weapon is set to swing in the database? Cuz I forgot once and it drove me CRAZY.


Also try changing that Skill's Type from SPECIAL to Normal/none see if that changes things.
 

Mando Jetii

Veteran
Veteran
Joined
Dec 15, 2016
Messages
39
Reaction score
4
First Language
English (US)
Primarily Uses
RMMV
So I tried a new project and the problem persists. I'm starting to think it is just a problem with the plugin.

Did you make sure that the sword type weapon is set to swing in the database? Cuz I forgot once and it drove me CRAZY.

The sword is set to swing by default. I double-checked when I saw your post and it is set to swing.

Also try changing that Skill's Type from SPECIAL to Normal/none see if that changes things.

I'll give that a try. The problem with that is the player can't access skills that don't appear in a category (unless the skill replaces their default attack).
 
Last edited by a moderator:

Mando Jetii

Veteran
Veteran
Joined
Dec 15, 2016
Messages
39
Reaction score
4
First Language
English (US)
Primarily Uses
RMMV
So I tried ashiki's suggestion about changing the type and I used Yanfly's Weapon Unleash plugin to create weapons that allow the characters to use the skills as their default attacks.


ASError_SotaFixed.png


As you can see, it worked this time. I don't know if it was because of the type or if it was because it was replacing the default attack though ^_^;;


I'm going to experiment a little more. I want to check to see if there is a way to set the default motion for a skill type in the database.


Update:


Yah, like I figured, the database only gives you the ability to set motions for weapon attacks and to set skill types to use the "chant" motion instead of the "skill" motion. I even tried re-setting the sword to "swing" and that didn't affect the skill. If there is an easy fix for this, Yanfly probably knows it, but I can't figure it out.
 
Last edited by a moderator:

ashikai

Veteran
Veteran
Joined
Jun 2, 2015
Messages
456
Reaction score
343
First Language
English
Primarily Uses
N/A
I've run into similar things a couple times, but I've been using Yami's sideview battler plugin do create custom sprite sheets/motions and I haven't had a problem since. Dunno what the root issue is though.
 

Mando Jetii

Veteran
Veteran
Joined
Dec 15, 2016
Messages
39
Reaction score
4
First Language
English (US)
Primarily Uses
RMMV
I've run into similar things a couple times, but I've been using Yami's sideview battler plugin do create custom sprite sheets/motions and I haven't had a problem since. Dunno what the root issue is though.

What is the plugin called? My version of MV came with some of Yami's plugins and I want to know if I already have it or if I need to find it on the internet.
 

ashikai

Veteran
Veteran
Joined
Jun 2, 2015
Messages
456
Reaction score
343
First Language
English
Primarily Uses
N/A
Tis this one: 
 

Mando Jetii

Veteran
Veteran
Joined
Dec 15, 2016
Messages
39
Reaction score
4
First Language
English (US)
Primarily Uses
RMMV
I found it.


So how did you get it to fix the motion issue? I've tried putting '<Sideview Battler Motion: swing, 8>' in the actor's note-box but it's still giving me the 'skill' motion with the floating sword. I want to make use of MV's weapon sprite system so that I can have characters equip different weapon types, so just putting the weapon on the actor's sprite sheet won't work unless I change the actor graphic for each weapon type.

I've figured out how to use the weapons with Yami's plugin. I can fix the problem IF I set the character's "skill" motion to the "swing" motion's index, but that will only work as long as the character uses "swing" motion weapons; if I made an actor that can use, for example, a whip or a gun (like Indiana Jones), the actor would be stuck either using the "thrust" motion with gun skills or the "missile" motion with whip skills. The only fix would be to create a generic "weapon" motion (and name it "skill") and modify the weapon sprites to all work with the same motion.

I've just encounter another minor problem: the "wait" motion isn't being recognized and instead is defaulting to "walk" (which has three identical frames making it look like it isn't animating). This is a minor issue as there won't be any negative affects if I just set the "walk" motion to index 1. But, if there is a fix for this, I'd like to know.


...Or so I thought. I just set "walk" to index 1 and it is still doing the same thing.
 
Last edited by a moderator:

ashikai

Veteran
Veteran
Joined
Jun 2, 2015
Messages
456
Reaction score
343
First Language
English
Primarily Uses
N/A
Walk is the default for Yami's plugin. If you don't have something defined in the actor/class box, then it'll play the walk animation instead.


TBF, I'm using non-RTP battlers/sheet setups which doesn't use the weapon animations so beyond battler motions I'm not gonna be much help and it may not be a plugin that you actually need. 


This thread on the other hand:




Might be exactly what you need. The first post talks about your issue. Give it a shot.
 

Mando Jetii

Veteran
Veteran
Joined
Dec 15, 2016
Messages
39
Reaction score
4
First Language
English (US)
Primarily Uses
RMMV
I tried to update my comment earlier but the server was down.


I figured out that the problem was more than just defaulting to "walk". When I changed "walk" to index 1, the "wait" motion still showed index 0, frame 1 (or frame 0 if it starts at 0). I'm not sure what's going on here. Like I said, if there is a known fix, I'd like to know. I'll look at that discussion you linked, see if that helps.
 
Last edited by a moderator:

Mando Jetii

Veteran
Veteran
Joined
Dec 15, 2016
Messages
39
Reaction score
4
First Language
English (US)
Primarily Uses
RMMV
Here is a download link for my test project: Sideview Battle Test. This project uses Yami's plugin to correct the original motion error but has a new error where the "wait" motion isn't playing right. Harold is the only character using Yami's plugin, the others just use default sprite sheets. Therese is still displaying the original motion error that I'm having with Yanfly's Action Sequence plugins.
 

Mando Jetii

Veteran
Veteran
Joined
Dec 15, 2016
Messages
39
Reaction score
4
First Language
English (US)
Primarily Uses
RMMV
Might be exactly what you need. The first post talks about your issue. Give it a shot.

That thread is where I got the basis for my animation. The fist post uses essentially the same animation code that I use. I will import it to my project just to see if it works.


Update:


I tried making a skill by copying the default attack, adding the code from Blue001's thread, and changing the damage equation. It didn't work; Therese is still showing the "skill" motion while using the skill.
 
Last edited by a moderator:

Mando Jetii

Veteran
Veteran
Joined
Dec 15, 2016
Messages
39
Reaction score
4
First Language
English (US)
Primarily Uses
RMMV
@Mando Jetii Hello, first I'm going to say you don't need to double post only edit your original post, you make the higher ups look at us funny.


I'm going to make a guess and say that all of your skills have this particular part in the action sequence?



<whole Action>
move user: forward, 32, 4
motion attack: user
perform action <-------------This one
motion wait: user
action animation: target
wait for animation
action effect: target
death break
perform finish
</whole action>


If this is the case?



Problem Solved! Thanks emelian65!
 
Last edited by a moderator:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,506
Reaction score
8,144
First Language
German
Primarily Uses
RMMV
@Mando Jetii, please avoid double posting, as it is against the forum rules. You can review our forum rules here. Thank you.


If you want to answer several people, use the @username function or the multiquote (the plus button).


If you want to add something and your own post is the last one, please edit that post.
 

Latest Threads

Latest Profile Posts

100 degrees here (38 degrees C) god I need ac
I wish I can work faster on my game. But I don't want to get burned out. :(
I've been working on something on and off for a few years now, and I've been reluctant to share any details on the project before I had anything playable because I did not want to generate hype only for the project to go back on hiatus. That being said I believe what I'm working on is very unique and pushes the boundaries of what RPG Maker projects can be. Bold claims, I know but just wait.
Happy Mother's Day to all the moms :)
Create Anime Art w/ AI, Tall Sprites with Aurora, Customize Variable Display | RPG Maker News #34

Forum statistics

Threads
111,207
Messages
1,059,265
Members
144,461
Latest member
Rookie
Top