Movie section bugged

Discussion in 'RPG Maker MV' started by umbraqueen, Oct 24, 2015.

  1. umbraqueen

    umbraqueen Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    english
    made a simple event to proc a movie in the game....

    the file was in ogg format even tried mp4 format but the game couldnt load it at all... it just skipped it

    is there a way to fix this or im just bad at it? at this point everything is possible.... XD
     
    #1
  2. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,553
    Likes Received:
    14,237
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Check if your mp4 is in h264
     
    #2
  3. umbraqueen

    umbraqueen Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    english
    yes it is converted it with VLC media player without any issues and it is not working
     
    #3
  4. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,553
    Likes Received:
    14,237
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    PM me your Mp4 file~
     
    #4
  5. umbraqueen

    umbraqueen Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    english
    my video is way to big to be able to transfer it to you... its 80 mo 

    5 min straith of video
     
    #5
  6. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,553
    Likes Received:
    14,237
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    80mb? I can download that

    Upload it in mediafire/something and I'll look into it w
     
    Last edited by a moderator: Oct 24, 2015
    #6
  7. umbraqueen

    umbraqueen Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    english
    XD you will have to help with that.... i never uploaded something in my entire life lol
     
    #7
  8. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,553
    Likes Received:
    14,237
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Ah...

    OK, register in mediafire.com. Press upload to upload your file and then it will give you a link. Give that link to me :)
     
    Last edited by a moderator: Oct 24, 2015
    #8
  9. umbraqueen

    umbraqueen Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    english
    ok i got the link 

    <MEEP>
     
    Last edited by a moderator: Oct 24, 2015
    #9
  10. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,553
    Likes Received:
    14,237
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Thanks. Since it's weekend in Japan I can't get back on this soon if it's an issue with KDKW but hopefully I can fix it tomorrow if it's nothing major.
     
    #10
  11. umbraqueen

    umbraqueen Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    english
    oki thanks for the help :D
     
    #11
  12. Lantztech

    Lantztech Villager Member

    Messages:
    17
    Likes Received:
    1
    Location:
    Earth
    First Language:
    English
    I am having a similar issue. I have an MP4 file I have converted to OGV and MP4 - H264 encoding. I have placed all 3 files in the Movie folder. Sometimes, it will list and display the movies and let me select one. But when I try to run the Event nothing happens. Then when I recheck the event and try to select a new movie, they all seem to have disappeared from the drop down menu for movies. Yet the files are still in the Movie Folder - It's just not displaying them in the software drop down menu.
     
    #12
  13. marcelox

    marcelox Painfully Clueless Veteran

    Messages:
    86
    Likes Received:
    14
    Location:
    San Diego, CA
    First Language:
    English
    Hi,

    In case you haven't found the solution to this problem, it's a strange one but check this out. Get a movie converter, I'm using 'Any Video Converter" - just be careful when installing it. It will try to install 3 additional pieces of software, but if you read before you click, then all three additional softwares will not be included. Focus on unchecking the checkboxes in 2 different parts of the installation, that's how you tell it to not install anything you don't want. It's the standard practice for all free software, they make their money from the free software by having other software install with it, however they (almost always) make it possible to just install the thing you want and nothing else.

    PAY ATTENTION WHEN INSTALLING, SERIOUSLY!!! <---Nobody wants misc software installed on their PC, nothing good comes from it.

    ok, back to the movies not playing issue, put the video file you want (drag and drop) into the converter and have it convert to .webm format, while you are at it, you might also want to convert the original video to the mp4 format as well. VERY IMPORTANT, make sure you pick the quality that you want your video to be in. For me, clarity is much more important than filesize. So pick the best possible for PCs and depending on android/iphone limitations, you may have to reduce the quality (man that would suck.) Remember, better quality takes longer to convert, go have a cigarette while it converts, you've earned it. ;)    (Before I get a new hole ripped into me, I'm a non-smoker of cigars and cigarettes. lol)

    Depending on what system you want to put your game in, it will require one of the two video formats (and I think some may require both, for some reason that's beyond my understanding)

    So now you have a .webm and a .mp4 version of the video you want to use in RPG Maker MV. Take both of those files and put them in the movies subfolder of where you are saving your game, probably something like

    C:\Users\YOURUSERNAME\Documents\Games\YOURGAMENAME\movies

    Now go into your game and setup whatever you were trying to do with a movie. What I did to test it was just to put a tower on the overworld while in map mode, right click on the tower while on event mode, the pick New (or Edit) and then in the Contents section I right clicked on it and picked new. Once in the new window, I went over to the tabs part above the window (Numbers 1 + 2 + 3 on the top of the window called Event Commands) and picked the number 2. Then I clicked the last option on the second row called "Play Movie..." and from there the movie name of the .webm file is there, click on it and bam, you have an event (which you should configure to your liking) that will play a movie file.

    It will only recognize the .webm file, not the .mp4 nor .ogg (or was it .og) - occasionally the gamemaker will mess up and let you pick non-.webm files, but that doesn't work out. The videos will simply not work. You must have the .webm file in there. Also, limit the name of the video, because the window where you pick the video is small so long names only show the beginning of it. With my naming method, all the videos had the same name, made it a pain to work it, renaming them to 2-3 words each should be an easier way to work with files that have a very long yet similar filenames.

    Hope this helps.

    -

    Update: While this does work, there is a problem that you can't skip the videos and the game remains fully playable while you watch the video, so be careful to not move around when viewing the cutscenes. What I did was put a few 999 frame waits to last exactly the length of the video so as soon as it ends, I get control again (and not 1 second early/late on the timing, took a lot of testing to get it just right.)
     
    Last edited by a moderator: Oct 29, 2015
    #13
    terwilliker likes this.
  14. ultramooz

    ultramooz Warper Member

    Messages:
    1
    Likes Received:
    0
    Location:
    Paris, France
    First Language:
    french
    Yes, me too  I have the exact same problem. Movie event not working with .ogg files, and files disappearing and appearing in the movie event selector menu without any reason.

    I tried many different encodings and couldn't make the movie work until I tried Marcelox suggestion and tried with a .webm file. The file was listed in the movies panel and it actually played with a click of the event. This is puzzling and is looking like a bug... From what I read in the forum and the manual I thought RPGMaker only accepted .ogg files - confusing !
     
    #14
  15. Deoxys Kirby

    Deoxys Kirby Villager Member

    Messages:
    14
    Likes Received:
    2
    First Language:
    English
    I can't get a movie to work either! It appears in the editor, but when I playtest, it never shows up!
     
    #15
    VassBros likes this.
  16. Coopziana

    Coopziana Veteran Veteran

    Messages:
    115
    Likes Received:
    43
    First Language:
    English


    Yes I'm having this issue as well, got it to show in the "Play Video..." section, added the files, nothing happens! Has anyone found a solution to this?
     
    #16
  17. marcelox

    marcelox Painfully Clueless Veteran

    Messages:
    86
    Likes Received:
    14
    Location:
    San Diego, CA
    First Language:
    English


    Ummm, I did, like months ago, scroll up slightly and I explained (in detail) how to do this (and I mean a ton of detail, to the point where it's spelled out in such a descriptive manner, that it leaves nothing to do but follow the steps of converting and placing in the game. Not sure how it's possible to explain it in a more user-friendly manner, it basically holds you hand the entire process...)


    This issue has long since been resolved, shouldn't this topic be closed?
     
    #17
  18. Coopziana

    Coopziana Veteran Veteran

    Messages:
    115
    Likes Received:
    43
    First Language:
    English
    Yes, to which I followed step by step exactly as you explained (before I posted) and it doesn't work... Hence my post!
     
    #18
  19. mystic0

    mystic0 Freeman Member

    Messages:
    25
    Likes Received:
    15
    Location:
    Seattle, WA
    First Language:
    English
    Primarily Uses:
    RMMV
    I'm working on the indie game competition and this bug is still occurring. I rendered with Adobe Premiere CS 5.5 on Windows 10 x64 using the H.264 video and AAC+Version 2 audio codecs. I copied the file to the folder and nothing shows. I used VLC player and converted the file into WEBM with H.264 and Vorbis audio, it was good to go. I'll leave these instructions how to convert file formats for anyone who needs to know. I thought I might need both file formats (one for PCs and one for mobile), but you only need the WEBM format.
     
    #19
    Marquise* likes this.

Share This Page