Movies don't always play in full screen.

Status
Not open for further replies.
Joined
Jul 9, 2013
Messages
6
Reaction score
1
First Language
English
Primarily Uses
My game is currently using movies at key moments in the game.  While playing the game in full screen on my home computer (a tower, not a laptop), the movies play perfectly and are incorporated into the game just as I'd want them.  However, when playing the game in full screen on a laptop, the video does not play (it just shows black) while the audio plays properly.  The only way I can get the movie to play on the laptop is when it is windowed mode.  I'm sure it has something to do with monitor settings and such, but since the rest of the game runs fine in full screen on any platform, I was hoping there was a way to get movies to conform to that same spacing without needing to mess with computer display settings.  I'd instruct players to play the game in windowed mode if they are unable to see the movies, but that just seems unprofessional, given that the windowed mode is tiny on most displays.  Any help on this matter would be greatly appreciated.

Oh, and some technical specs that might be of importance:

-I'm running the game in 640x416 for a widescreen look.

-The videos are also 640x416 resolution, as are all title screens and full framed images.

Thank you for your time^^
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,062
Reaction score
6,697
First Language
German
Primarily Uses
RMMV
There is a problem with the overlay setting of your computer's graphic card. Such a thing was really common a dozen years back when the computers were lacking the power to easily display videos - modern graphic cards and drivers should have no problem with that, but it might be that some optimization for 3D has disabled the overlay mode of your driver.

Basically to speed up video display, the programs write the video data directly into the graphic cards RAM, bypassing the regular window screen (which stays black).

Your graphics driver for some reason hasn't detected this direct streaming and failed to access it, retaining the data from windows screen RAM.

It works in windowed mode because in that mode, the data needs to be send to the window-API - you can't overlay only part of the screen with that option. So in windowed mode, the data gets copied into the windows screen and from there to the graphic card (which is slower than the overlay with direct streaming).

So the bug depends on the hardware and the drivers of the computer (as you've also seen by the fact that it does work on another computer).

Edit: Try updating the drivers and check their settings - there isn't much more that you could do. Depending on the manufacturer of the graphics card this can be easy to change or difficult - ATI/AMD is much better at video control than the other manufacturers.
 
Last edited by a moderator:
Joined
Jul 9, 2013
Messages
6
Reaction score
1
First Language
English
Primarily Uses
Thanks for the response.  That makes a lot of sense.  However, the laptop in question isn't any older than 2 years or so, and it's running Windows 7 with up to date drivers.  I'm not sure I can fix it on the computer's end.  You're absolutely right about windowed mode and why that works.  Is there a way to make windowed mode larger?  On a 1080p monitor or larger, the window doesn't even consume 1/4 of the screen.  I remember older RPG Maker software having this feature (RM2k3 had two window sizes, for instance).
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,062
Reaction score
6,697
First Language
German
Primarily Uses
RMMV
In that case it might be the driver configuration - all current graphic cards support overlay, but it might be disabled to speed up 3D or certain other functions.

If you can tell me what graphic card it is I might be able to point you to the correct configuration option.

One additional question: do you have an external display added to the notebook or do you display it on the integrated one only? Dual-screen-settings can also mix up the overlay...
 
Joined
Jul 9, 2013
Messages
6
Reaction score
1
First Language
English
Primarily Uses
Aha! You totally hit the nail on the head.  I kinda feel stupid now.  I was having the problem whilst dual monitoring it with a TV.  I tried it by itself and the video displayed perfectly.  I don't know if there's a way to give it support for dual-monitor setups but I didn't really intend for that to begin with.  Thank you for mentioning that; I completely forgot that was a variable.^^;
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,062
Reaction score
6,697
First Language
German
Primarily Uses
RMMV
With dual-display, the maximum possible is having the video overlay on the primary screen. Having the video overlay work on both screens would require two overlay areas, and I don't know of a (non-specialized) graphic card that has that feature (it would require a total of four screen RAM areas, and that's rare outside of special and expensive multi-monitor cards).

And depending on the graphic card and the available RAM even that overlay on primary might fail, especially as a lot of notebooks use shared RAM instead of dedicated RAM for the graphic...
 

Celianna

Tileset artist
Global Mod
Joined
Mar 1, 2012
Messages
10,532
Reaction score
5,539
First Language
Dutch
Primarily Uses
RMMV
Good job figuring out the problem Andar.


This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.
 
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Brother made thumbnails for my Lets Plays. He's a swood dude.
Since I'm getting so busy (the fact that I'm often here is due to the fact that this is my procrastination #1 destination), I'm trying a new system where everyday I dedicate 30 minutes to my personal game project. That way it won't fall into the abyss.
In today's seminar:
Presenter: In the past, there was a saying, "One who has tuberculosis is doomed for life." But now-
Everyone: *starts coughing in unision*
Gosh... Today seems too much like a good day to do nothing....

I need to keep myself focused...! :kaoback:

Forum statistics

Threads
93,699
Messages
914,744
Members
123,300
Latest member
jamssi
Top