MV 1.6.2 random map lag spikes

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
419
Reaction score
281
First Language
English
Primarily Uses
N/A
Hey guys!

I am curious about 1.6.2

Does the frame rate randomly bug out sometimes? (instead of a solid 60, will go up and down 60 to 45 or so, almost in a perfect rhythm. Fixed if you stay in a menu long enough or just change maps)

After this, it will be a rock solid 60 until you change map and it may randomly occur, no matter the map, big or small.


I didnt experience this at all in 1.5.2...... overall the 1.6.2 performance is better.... minus the random lag spikes.
 

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,290
Reaction score
11,694
First Language
English
Primarily Uses
RMVXA
[MOVE]RPG Maker MV[/MOVE]
This could be caused by a range of reasons and we will need more details to discover why it is happening.
 

jkweath

Goes Fast
Veteran
Joined
Sep 21, 2016
Messages
331
Reaction score
522
First Language
English
Primarily Uses
RMMV
Unfortunately I don't have a solution, but I wanted to chime in and say I have the exact same problem. I haven't made a thread about it yet because it's such a vague issue that could have any number of reasons why it happens.

Have you tried making a blank project or just disabling all your plugins and seeing if the lag spikes still happen?
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,418
Reaction score
14,146
First Language
English
Primarily Uses
RMVXA
I ran into this issue when I tested your demo, the world map was where it started for me. I was a steady 52 FPS until then, then the world map would drop to 36 FPS and stay there. If I went to the menu it would go back to 60 FPS then drop back to 36 FPS about as soon as I left it.

I'd check your plug-ins. Too many plug-ins will cause your game to lag regardless of what you do. common culprits are lighting plug-ins, as those tend to lag badly, especially on bigger maps.
 

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
419
Reaction score
281
First Language
English
Primarily Uses
N/A
Hey guys!

Well KG was using 1.5.2 which had NW.js 12.

I updated the KG to 1.6.2 which uses NW.js 29 yesterday.

Performance was much better.... but I experienced the above problems. PLUS (NEW PROBLEM) sometimes during battles the frame rate would seriously tank to the point of being unplayable!

After some testing..... I pinpointed the main culprit. It was yanflys Core Updates and Desktop Optimization (YEP)

After I disabled this (since it says it helps up to 1.6.1 and not 1.6.2) I decided I would test with this off..... since I disabled this, battle tanking completely stopped, and the map frame rate tanking happened MUCH less frequently and much less harshly. The game also seemed to stabilize much faster.

Don't get me wrong I use a ton of yanfly stuff, and he does some great work. I just dont think the above script should be used on 1.6.2 and later.

Anyone else aware of scripts that would compromise performance?
 

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
419
Reaction score
281
First Language
English
Primarily Uses
N/A
I figured out the last part of the problem:


KG was on version 1.5.2 so I updated it to 1.6.2 (Just update to 1.6.2 its stable, awesome, and great... not 1.6.1 though, that's why I waited)

It effectively updated the NW.js from version 12 to 29.

Suddenly the game was running BEAUTIFULLY! A solid 60 frames all the time, across the systems that had a hard time running it before!

However.... randomly, for no apparent reason.... the frame rate would fluctuate from 40-50 frames on map changes. No matter how big or small..... If I changed the map, or went into a menu, it stopped. This drove me crazy because I wanted to optimize the game as much as possible across all systems.

I finally figured out the problem today. I eliminated this random lag spike... I just shut down CHROME!

I knew Chrome shared resources with RPG maker MV but that was ridiculous! I shut it all the way down lol and BAM..... beautiful 60 frames, complete with faster load times!!

Anyways I hoped it helped someone out there, because I have spent many a day checking, testing, and updating every script I could to isolate the problem..... today I shut down chrome... and bam.... fixed.

Yes, so what happens is that Google Chrome has a shared Cache that it calls upon NWJS runs on Chromium, which is a version of Chrome that's stripped down, however, it uses the same cache for data since Chrome's browser stuff is such a hog, it ends up making this cache massive sometimes, it's also why you'll notice that chrome sometimes is running on like 9gb of ram for no reason.

Anyways happy RPGing everyone!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Say, does anyone know any other indie game development forums? Progress on my uni survey has been a little slow, so I wanna look into posting it around a bit more.
Due to the bullies' resurgence on Facebook and Twitter against my friend (and I since I defend), we've decided to move over to tumblr to try to obscure our presence, where we might finally be at peace working on games. If anyone wants my/our game's tumblrs to follow lmk. :kaojoy:
Is there anyone need help with anything except art and music?
is Gotcha Gotcha Games Inc. = KADOKAWA CORPORATION? I haven't found this topic yet, Want to know for credits on my game. Thanks.

Forum statistics

Threads
104,303
Messages
1,005,402
Members
135,824
Latest member
uniteditcare
Top