MV: Profile error occurred during playtest/game play - NW.js

Status
Not open for further replies.

bazrat

Pixel Game Maker MV
Veteran
Joined
Oct 15, 2018
Messages
243
Reaction score
187
First Language
English
Primarily Uses
Other
When I go to playtest my game (ive tried several different projects, including new project to see if it did it still) when the playtest pops up it pops up with this alert message:

"Profile error occurred
Your profile can not be used because it is from a newer version of NW.js.
Some features may be unavailable. Please specify a different profile directory or use a newer version of NW.js."

I tried taking screen shot but its too small in the picture, sorry. What is NW.js file and what does it mean? I can still play the game, I just have to click OK everytime to get that window off.

Ive tried this fix https://steamcommunity.com/app/683760/discussions/1/2595630410189816847/#c2595630410191528351 and it did not work, same message.

I have also exported the game, same message when I play the exported game.

Lastly, I have uninstalled and reinstalled MV. Any more ideas?

Couple things I did recently, few hrs ago (prior to this problem) I installed VS code and git-scm. I'm not sure if those programs would have done anything?
 

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,953
Reaction score
12,501
First Language
English
Primarily Uses
RMMZ
Tech Support is for when you cannot get the engine to run.
[move]RPG Maker MV[/move]
 

Poryg

Dark Lord of the Castle of Javascreeps
Veteran
Joined
Mar 23, 2017
Messages
4,196
Reaction score
10,905
First Language
Czech
Primarily Uses
RMMV
It means that at some point you or other users of your computer have installed/downloaded and launched a higher version of NWjs than RPG maker MV uses. It's a completely irrelevant message though and nothing bad happens, since for important settings there is a package.json file inside the folder.
I see this message all the time ever since I downloaded NWjs v.0.30, but no actual errors occur.
 

bazrat

Pixel Game Maker MV
Veteran
Joined
Oct 15, 2018
Messages
243
Reaction score
187
First Language
English
Primarily Uses
Other
It means that at some point you or other users of your computer have installed/downloaded and launched a higher version of NWjs than RPG maker MV uses. It's a completely irrelevant message though and nothing bad happens, since for important settings there is a package.json file inside the folder.
I see this message all the time ever since I downloaded NWjs v.0.30, but no actual errors occur.

So there is no way to remove this? Im glad its not an actual issue but I would rather a clean looking startup of a game.. can I just delete the nwjs folder Ive found in localapps and it will stop? I uninstalled VS code and gitscm since this post to try and revert back to way it was but no luck
 

Poryg

Dark Lord of the Castle of Javascreeps
Veteran
Joined
Mar 23, 2017
Messages
4,196
Reaction score
10,905
First Language
Czech
Primarily Uses
RMMV
can I just delete the nwjs folder Ive found in localapps and it will stop?

You can try, it shouldn't hurt. But I have never really tried to get rid of the popup, so I don't know if it actually gets rid of the popups.
 

bazrat

Pixel Game Maker MV
Veteran
Joined
Oct 15, 2018
Messages
243
Reaction score
187
First Language
English
Primarily Uses
Other
You can try, it shouldn't hurt. But I have never really tried to get rid of the popup, so I don't know if it actually gets rid of the popups.

FIXED: for anyone else needing this:

-i went to %LOCALAPPDATA%/
-i deleted nwjs folder
-i went into User Data/Default folders
-deleted Web Data and Web Data-journal files
-play tested MV game with no pop up message!

after i play tested i went back to localappdata and saw a new NWJS folder appeared as well as a new Web Data/Web Data-journal

thanks Poryg for help
 

JohnOminae

Villager
Member
Joined
Mar 13, 2012
Messages
28
Reaction score
30
First Language
English
Primarily Uses
Other
To clarify Bazrat's steps (thanks for figuring this out, but your steps weren't super clear) for Windows 10 users (Highly suggest shutting RPG MV off before doing this stuff and back up projects, etc.):
  1. Go to your app data folder in Windows (C:\Users\[Your Username]\AppData\Local). If you can't find it, make sure you can see hidden folders.
  2. Delete the folder "nwjs".
  3. Go inside the folder 'User Data". Then go inside the folder "Default". Look for the files "Web Data" and "Web Data-journal". Delete these two files.
  4. Launch MV and play test.
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

DamageEvil_1.png added!
index.php

I have a very strong feeling my internet will be hurricane'd, forcing me to work exclusively on my projects. Wish me luck y'all.
Figured I should probably put my badly written RMMV plugins on GitHub or something, idk.
I've been working on plugins to make it easier to incorporate Persona 3's Once More batsys into MV games. One makes it so you can have states automatically applied to the target and/or user when their hit crits or targets a weakness... I could use testers for it, though. Maybe I'll make a thread in the JS Plugins In Development board about it?
Whenever I'm feeling down I like to watch Bardic Inspiration by Deerstalker Pictures
on youtube. Because 'my mockery is Vicious.' It's funny and catchy like the flu.

Forum statistics

Threads
125,615
Messages
1,172,289
Members
164,723
Latest member
Jobiia
Top