My project won't start

Cosmic Architect

Architect of Worlds
Veteran
Joined
Nov 22, 2014
Messages
39
Reaction score
7
First Language
English
Primarily Uses
N/A
I've looked through dozens of forums, and I still can't find a topic on this. I apologize because there probably is one, but I've really put some effort into finding it and have not. My issue is that one project(my main one xo) will not start the actual game. Both playtesting and trying to run the game.exe have only resulted in the window opening black screened and my command prompt(when playtesting), but it closes too fast for me to read anything besides "RGSS301.dll". I tried trading that file out for another one, and removing it, but removing it results in an error box saying that is it missing(I thought it might not be reading it, so that disproved that).

Finally, I ran it in administrator, and I think I might have found the source of my issue. It says that windows can not find the game.exe(which I also tried exchanging for a working one). Can someone please help me?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,059
Reaction score
6,696
First Language
German
Primarily Uses
RMMV
The basic solöution in this case should be to make a new project and copy the game.exe from that project into your damaged project.


If that doesn't work, then either the original game.exe has been damaged and you need to reinstall Ace, or you're doing something wrong in your project (like wrong data in the ini files)
 

Cosmic Architect

Architect of Worlds
Veteran
Joined
Nov 22, 2014
Messages
39
Reaction score
7
First Language
English
Primarily Uses
N/A
The basic solöution in this case should be to make a new project and copy the game.exe from that project into your damaged project.

If that doesn't work, then either the original game.exe has been damaged and you need to reinstall Ace, or you're doing something wrong in your project (like wrong data in the ini files)
I appreciate the quick reply, but I'm afraid I've already tried getting a game.exe from another game.(that does work) All my other games work, so I think it's not an issue with Ace itself, but I could be wrong.(Unless you mean that would fix the issue in the project somehow?)

I included a screenshot of my data, I didn't see any files I believe to be alien, but I wouldn't know for sure it I were right.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,059
Reaction score
6,696
First Language
German
Primarily Uses
RMMV
Please don't use a game.exe from another game - use one from a new project made just for this.


I also don't see that screenshot in your posts, please check again.


One additional idea: have you checked if the game.exe has been blocked by your antivirus software? There is one commonly used antivirus that has blacklisted the game.exe several times in the past, and then you need to whitelist it to prevent it's deletion the second it's launched.
 

Cosmic Architect

Architect of Worlds
Veteran
Joined
Nov 22, 2014
Messages
39
Reaction score
7
First Language
English
Primarily Uses
N/A
I tried using a game.exe from a new game, it didn't work ether :(

I'll try posting it again, I don't know why it didn't work...

That was a good suggestion, but, after looking into it, my antivirus software does not blacklist programs. It does quarantine them, but it was not under quarantine.

I've isolated the problem to a script... I know this is kinda complicated, and you might not know enough about these scripts... But these are the ones I used, in case you can find a conflict. I'll try to help figure it out in the meantime by isolating an individual script.

+All luna engine scripts(sorry... It would take a really long time to list them all ml)

+YEA Compatible(to let me use yanfly scripts)

+YEA battle revival/item Fix

+Skip title screen

+Fullscreen++

+Yanfly core

+yanfly Save engine

+Yanfly Battle engine

+Yanfly message system

+System options

+Jet path finding

+glalv's Move route extras

+keyboard input

+auto untint

+Extend Timer functionality

I know it's a lot... I'll try to find the conflict.

 

edit: I think I found the problem. The crash occurs due to "KGC Bitmap Extension" somehow. It is under requirements in for Luna engine though, so I'm afraid to just remove it... I'll try redownloading it. I'll feel stupid if this works xD
 
Last edited by a moderator:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Can't wait for the next Sonichu
Birdhouses are usually made of wood. Birds typically live in trees. Trees are wood. Birdhouses are made of birdhouses.
He just discovered cellphones...

(I don't know why am I drawing so much these days...)
In medieval times, a common way to eat food was upon edible plates, which were made of bread, called trenchers.

Forum statistics

Threads
93,670
Messages
914,448
Members
123,260
Latest member
ft371pta
Top