Ginyakki

Warper
Member
Joined
Aug 24, 2020
Messages
4
Reaction score
0
First Language
English
Primarily Uses
RMMZ
So, I've encountered a very strange bug with the MZ Character Generator. Basically, I originally modified both the TV_Body_p01 and the TV_Body_p01_c female body parts png file, then later in the generator I noticed that this caused the transparency of the image to no longer work, even though the actual png I placed in the folder was transparent (this is referring to TV_Body_p01, not TV_Body_p01_c, as this last one is not transparent by default.).
This is a screenshot of the bug:

So, I decided I would just stop trying to do this, and decided to instead create a new clothing part to accomplish this same result (and I knew that adding new clothing parts did work without any problems because I had already done it before), so I went and replaced those png files with the original ones.
Except, that didn't work. The actual body part did change back to the original, but the background was still a non transparent white color. So I decided to delete these files and then verify the integrity of the files (I have the Steam Version), and after that it downloaded the missing files. But that still didn't work. So I then uninstalled MZ and reinstalled it again, and it still didn't work, for some reason it still has that white background.

Does anyone have any idea what happened and how I could solve this?
 

mlogan

Global Moderators
Global Mod
Joined
Mar 18, 2012
Messages
15,936
Reaction score
8,859
First Language
English
Primarily Uses
RMMV

I've moved this thread to MV Support. Please be sure to post your threads in the correct forum next time. Thank you.


What program are you using to modify the parts?
 

Ginyakki

Warper
Member
Joined
Aug 24, 2020
Messages
4
Reaction score
0
First Language
English
Primarily Uses
RMMZ
Thank you for the reply. I used Asesprite at first. Then I noticed this bug happened, so I tried doing the same with Clip Studio Paint, but the same problem happened, then I tried it with Krita and again the same problem happened. That was when I decided to revert back to the original files like I said, but the bug persisted.

Is there a way to reset MZ to its factory settings? I noticed after reinstalling it that it kept the dark theme that I was using previously, so it must save some engine settings somewhere, does anyone know where this is saved, or if there is a factory reset button? I couldn't find it anywhere.
 
Last edited:

Rugman

Veteran
Veteran
Joined
Jun 11, 2020
Messages
263
Reaction score
77
First Language
English
Primarily Uses
RMMV
It would seem that your thread was mistakenly moved to the mv forums.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
41,894
Reaction score
14,526
First Language
English
Primarily Uses
RMMV

Oops! Moving to MZ Support.

 

jfbeute

Warper
Member
Joined
Feb 28, 2021
Messages
3
Reaction score
1
First Language
English
Primarily Uses
RMMZ
A word of warning here.

While checking if other tabs worked in the Character Generator I created additional directories within the directory structure it uses and copied some files there. After making changes to these files I noticed the Character Generator actually read both files (as they had the same name but existed in different directories) and merged the result on the screen. Once I removed the extra directories the problem was resolved. So make sure you don't have extra directories in the tree.
 

Ginyakki

Warper
Member
Joined
Aug 24, 2020
Messages
4
Reaction score
0
First Language
English
Primarily Uses
RMMZ
A word of warning here.

While checking if other tabs worked in the Character Generator I created additional directories within the directory structure it uses and copied some files there. After making changes to these files I noticed the Character Generator actually read both files (as they had the same name but existed in different directories) and merged the result on the screen. Once I removed the extra directories the problem was resolved. So make sure you don't have extra directories in the tree.
That actually worked, thank you! I had created another folder where I kept other files and backups, after I moved the folder elsewhere it all went back to normal.
 

Latest Threads

Latest Profile Posts

Yesterday I went to get some new jeans for my new job... and discovered I'm a plus size. I'm planning on dieting so I can get back to where I was before 2020. I decided on a Japanese food diet because the recipes I can cook at home are both low-calorie and delicious.
Did you ever had the wish to become a carpenter?
:kaojoy:Here comes a better driver AI. I sent some monks to pacify angry car drivers who previously just run over people without any consideration of life.
(Sorry, no English version of the video this time.)
Another character battle theme

Forum statistics

Threads
110,499
Messages
1,053,784
Members
143,596
Latest member
phantomgalaxy
Top