(MV Version only) Do you think canvas fall-back for this plugin is neccesary?


  • Total voters
    38
  • Poll closed .

Shora

Veteran
Veteran
Joined
Apr 12, 2020
Messages
36
Reaction score
73
First Language
Vietnamese
Primarily Uses
RMMZ
Alrite so: I'm having troubles setting up a parallel process with the command "Set Map Ambient". Basically, if I try to create a new parallel event which will change the Map Ambient, when I add "Erase Event" at the end, the command will not execute. I cannot leave the event always running in the background because it also contains other events that need to only execute once. Is this wanted or is it a bug? :v

UPDATE: The command works if I add it twice. It's weird but I can work with it, since I mostly use a big common event for lighting.
I think the solution to your problem is just adding a timer command (for 1 tick) instead of two set ambient commands. If that still haven't worked, i will try to find the issues and fix it. I'm currently have to go for a break for my personal issues, so it will take time. Nevertheless, i will try to fix it as soon as possible, as well as update a quick fix for the save/load things. Thanks you for reporting :)
Is there a reason why "help" is empty? Or where can I get the plugin commands for MV?
The major reason is that the plugin is in-complete, and there are feature that will be added/removed in the future. The minor reason is that currently i don't have enough time to write a new Help for the current version, but at least there is a old Guide for you that i wrote quite some time ago :). Some of the feature like range/rotation doesn't work be cause of it removal, but i think the rest are good. If you encounter any problem, just feedback here :).
I have updated the MV plugin commands in the above thread, although it not that much :c. Take a look at it, and feel free to suggest anything new :)
 

VaiJack8

Veteran
Veteran
Joined
Sep 21, 2016
Messages
49
Reaction score
29
First Language
Italian
Primarily Uses
RMMZ
I think the solution to your problem is just adding a timer command (for 1 tick) instead of two set ambient commands.
Yes, it actually works with my 240 frames commands. Thanks for the reply by the way, and take your needed time ^^
 

VaiJack8

Veteran
Veteran
Joined
Sep 21, 2016
Messages
49
Reaction score
29
First Language
Italian
Primarily Uses
RMMZ
Ok so I'm having a little lag issue in my World Map, in which there is a parallel process that updates a variable every 1 frame (it's a fast forward time event). I demonstrate it in this video: no other active plugins, only Shora Lighting.


As you can see, the game starts lagging very bad after few seconds, but the lag eventually decreases when I stop. Here's my parallel process:

2021-10-16 01_17_41-ID_002 - Event Editor.png

It only runs when the player moves.

If this issue is inevitable (I know it's very hard to control lag when parallel processes are involved) I can abandon the idea of using the light inside the world map. But I felt like I had to report this. The plugin is amazing in any case :v
 

fizzly

Veteran
Veteran
Joined
Mar 23, 2012
Messages
1,061
Reaction score
690
First Language
Polish
Primarily Uses
RMMV
Wow, just wow.... can't wait to test it out!
 

Daisukiuwu

Warper
Member
Joined
Oct 22, 2021
Messages
1
Reaction score
0
First Language
Español
Primarily Uses
RMMZ
Uhmm~~ hi! i have a question, only u can use that... interface in the first video/screenshot? where u modifie (sorry, bad english) the color, range and etc
 

Shora

Veteran
Veteran
Joined
Apr 12, 2020
Messages
36
Reaction score
73
First Language
Vietnamese
Primarily Uses
RMMZ
Hello everyone, long time no see :). After finished my personal works now i'm finally have time to continuing develop this plugin again xD.
Wow, just wow.... can't wait to test it out!
Thanks for your compliment! :) Have you test it out?. Dont hesitate to feedback bug and needed change~
Ok so I'm having a little lag issue in my World Map, in which there is a parallel process that updates a variable every 1 frame (it's a fast forward time event). I demonstrate it in this video: no other active plugins, only Shora Lighting.


As you can see, the game starts lagging very bad after few seconds, but the lag eventually decreases when I stop. Here's my parallel process:

View attachment 203957

It only runs when the player moves.

If this issue is inevitable (I know it's very hard to control lag when parallel processes are involved) I can abandon the idea of using the light inside the world map. But I felt like I had to report this. The plugin is amazing in any case :v
Hmm..., this behavior is really weird. I will try to simulate this in-game and find out the reason :c, maybe there're something to do with the engine mechanics. Thanks for reporting anyways :).
 

fizzly

Veteran
Veteran
Joined
Mar 23, 2012
Messages
1,061
Reaction score
690
First Language
Polish
Primarily Uses
RMMV
Wanted to try this, but looks like it's incompatible with VisuStella plugins.
 

VaiJack8

Veteran
Veteran
Joined
Sep 21, 2016
Messages
49
Reaction score
29
First Language
Italian
Primarily Uses
RMMZ
Wanted to try this, but looks like it's incompatible with VisuStella plugins.
Wait what. I'm using VS and I got no issues. What is that doesn't work?
 

fizzly

Veteran
Veteran
Joined
Mar 23, 2012
Messages
1,061
Reaction score
690
First Language
Polish
Primarily Uses
RMMV
Wait what. I'm using VS and I got no issues. What is that doesn't work?
Hmm, I have "Unexpected token { in JSON at position 836", I'll try to figure out which plugin made that, then (if not VisuStella).
 

VaiJack8

Veteran
Veteran
Joined
Sep 21, 2016
Messages
49
Reaction score
29
First Language
Italian
Primarily Uses
RMMZ
Hmm, I have "Unexpected token { in JSON at position 836", I'll try to figure out which plugin made that, then (if not VisuStella).
That usually happens when you didn't put the config files or the PNGs in the right folders. Check if everything's at the right place.

Also, make sure you copied over the default lights into the plugin parameters. They're not there when you first install the plugin.
 

fizzly

Veteran
Veteran
Joined
Mar 23, 2012
Messages
1,061
Reaction score
690
First Language
Polish
Primarily Uses
RMMV
That usually happens when you didn't put the config files or the PNGs in the right folders. Check if everything's at the right place.

Also, make sure you copied over the default lights into the plugin parameters. They're not there when you first install the plugin.
Tried with checking the config file, didn't changed anything, just clicked everything and accepted it, now I have "Cannot read property '_baseTexture' of undefined" error. I have no idea what's going on :( I have "lights" folder in img/picture with the files.
 

VaiJack8

Veteran
Veteran
Joined
Sep 21, 2016
Messages
49
Reaction score
29
First Language
Italian
Primarily Uses
RMMZ
Tried with checking the config file, didn't changed anything, just clicked everything and accepted it, now I have "Cannot read property '_baseTexture' of undefined" error. I have no idea what's going on :( I have "lights" folder in img/picture with the files.
Make sure you copied over the default lights and custom ones in the plugin parameters.
 

Shora

Veteran
Veteran
Joined
Apr 12, 2020
Messages
36
Reaction score
73
First Language
Vietnamese
Primarily Uses
RMMZ
Ok so I'm having a little lag issue in my World Map, in which there is a parallel process that updates a variable every 1 frame (it's a fast forward time event). I demonstrate it in this video: no other active plugins, only Shora Lighting.


As you can see, the game starts lagging very bad after few seconds, but the lag eventually decreases when I stop. Here's my parallel process:

View attachment 203957

It only runs when the player moves.

If this issue is inevitable (I know it's very hard to control lag when parallel processes are involved) I can abandon the idea of using the light inside the world map. But I felt like I had to report this. The plugin is amazing in any case :v
Just found out the bug is because of my code repeatly check for player light on map/player refresh, which for some reason happen every frame and cause a bottleneck. I'm working on change the way found player lighting so it won't be any more problems. I have already finished the save/load functionality fixes, so both of this will be included in the next small update.

Tried with checking the config file, didn't changed anything, just clicked everything and accepted it, now I have "Cannot read property '_baseTexture' of undefined" error. I have no idea what's going on :( I have "lights" folder in img/picture with the files.
I believe one of the most common bug is actually because of your plugin settings, especially each light settings. Have you fill in ALL the blank options, even the one you not needed? I haven't test it with other plugins yet, but i don't think that will be a problem, except that other plugin is a light/shadow etc plugin. You can try to create a new project with this plugin first to test it out instead of instantly merging with your old project. If you still encounter the same problem, feel free to DM me though forums/discord, i won't hesitate to help you :)
 

fizzly

Veteran
Veteran
Joined
Mar 23, 2012
Messages
1,061
Reaction score
690
First Language
Polish
Primarily Uses
RMMV
Make sure you copied over the default lights and custom ones in the plugin parameters.
Thanks guys, It was because of the blank field in Light/Default, reference field was empty, I typed "default" like in demo and it works.
 

Decinbr

Veteran
Veteran
Joined
Mar 20, 2015
Messages
267
Reaction score
41
First Language
brazil
Primarily Uses
These lights And shadows are above pictures?
Beacause I use pictures as layers on maps.
 

Shora

Veteran
Veteran
Joined
Apr 12, 2020
Messages
36
Reaction score
73
First Language
Vietnamese
Primarily Uses
RMMZ
These lights And shadows are above pictures?
Beacause I use pictures as layers on maps.
Before you asked it was under the pictures, so i just fixed it. Now it draw the light above picture (actually, above everything), so it should work perfectly with parallax picture for now. It still need to be tested though. I will try to upload the update version as soon as possible :)
 

Decinbr

Veteran
Veteran
Joined
Mar 20, 2015
Messages
267
Reaction score
41
First Language
brazil
Primarily Uses
Before you asked it was under the pictures, so i just fixed it. Now it draw the light above picture (actually, above everything), so it should work perfectly with parallax picture for now. It still need to be tested though. I will try to upload the update version as soon as possible :)
Thanks so much
 

Shora

Veteran
Veteran
Joined
Apr 12, 2020
Messages
36
Reaction score
73
First Language
Vietnamese
Primarily Uses
RMMZ
Version 1.3 beta released. The update can be downloaded from the itch.io page as a separate .js file from the demo, since i haven't done many change to the demo yet so it would be inconvenience to redownload all the project again.
Change-log:
- Change the code structure to handling save/load functionality (aka fix my past suckness). Thanks @Shiko for the feedback.
- Fix some bugs include @VaiJack8 report of fps drop when changing game variables each frame.
- Get the light layer to draw above the upper layer (everything), intended to use with parallax mapping, as suggest from @Decinbr. Still need tested though (I don't know how to do parallax mapping).
This is a small update since i came back to plugin coding after my personal issues, just fixing feedbacked bugs and adding suggested feature. I'm pretty demotivation now so i hope eveyone can give me more feedback and suggestion :) I really appreciate that <3.
 
Last edited:

VaiJack8

Veteran
Veteran
Joined
Sep 21, 2016
Messages
49
Reaction score
29
First Language
Italian
Primarily Uses
RMMZ
Heyyy

First of all, thanks for the update, the lag has now disappeared.

Sadly I must report another bug. I'm using a weather plugin by Mog (you can find it here in the demo project). It worked fine with the 1.2b version but now it makes my game crash every time I start a battle. Here's the console log.

2021-11-05 11_32_29-Window.png2021-11-05 11_32_38-Window.png

Also, there is another bug when I try to enter a place with a different weather condition while I hold the light:

2021-11-05 11_36_42-Window.png
2021-11-05 11_36_53-Window.png

Thanks in advance.

EDIT: I know this is not a bug but a compatibility issue, so if you cannot fix it I will understand. Thank you anyway.
 
Last edited:

Decinbr

Veteran
Veteran
Joined
Mar 20, 2015
Messages
267
Reaction score
41
First Language
brazil
Primarily Uses
Version 1.3 beta released. The update can be downloaded from the itch.io page as a separate .js file from the demo, since i haven't done many change to the demo yet so it would be inconvenience to redownload all the project again.
Change-log:
- Change the code structure to handling save/load functionality (aka fix my past suckness). Thanks @Shiko for the feedback.
- Fix some bugs include @VaiJack8 report of fps drop when changing game variables each frame.
- Get the light layer to draw above the upper layer (everything), intended to use with parallax mapping, as suggest from @Decinbr. Still need tested though (I don't know how to do parallax mapping).
This is a small update since i came back to plugin coding after my personal issues, just fixing feedbacked bugs and adding suggested feature. I'm pretty demotivation now so i hope eveyone can give me more feedback and suggestion :) I really appreciate that <3.
Thanks for your goodness
 

Latest Threads

Latest Posts

Latest Profile Posts

since all my maps are hand drawn... I admit, I super envy those who can make the tileset's work. I'm garbage at mapping, but slightly less bad at just drawing my own areas. plus it's easier to draw my own sprites than edit others to look like my characters.
Guys, I made a trailer! And, I also launched the Steam page! If you would like to support the game, please Wishlist it :ahappy: ->
working on some tilesets _ノ乙(、ン、)_

CIBl8xT.png


Oq8WKHX.png
aww man, color hex code #C4C4C4 doesn't work for the tint value in this scene I need something darker, which stinks just because I liked that one it was my favorite plastic explosive three times...#696969 (nice) should work better (WHY IS MY BRAIN LIKE THIS)
Tell it to me straight, doc. If I've been trying to piece together a "shorter" game to learn stuff outside of game jams... am I just running away from my WIP? :v

Forum statistics

Threads
117,284
Messages
1,106,132
Members
153,469
Latest member
CPGPPC
Top