Neither MV or MZ are running correctly, even after unistalling/reinstalling...

Status
Not open for further replies.

zerobeat032

Cloaked Wanderer...
Veteran
Joined
Mar 28, 2014
Messages
359
Reaction score
588
First Language
English
Primarily Uses
RMMV
Yesterday, I noticed MV was running extremely choppy and the sound was distorting. I think the sound issue is fixed, but it's still running terribly, even with a fresh project. Oddly, the same thing is happening with MZ. they're both running with massive frame dips and lag. I can't figure out what's going on at all. I've tested thing on my computer but now I'm suspecting it's just these. I've tried reinstalling and the results are the same. Though... I tried VX Ace and it runs completely fine at 60 FPS.

My computer updated itself recently and unfortunately I can't rollback anymore if that's what the deal is. But ever since, I've had issues here and there. But as of yesterday, MV and MZ just don't run well at all... even in empty projects. I'm definitely at my wits end trying to figure out how or why this is happening. If anyone has ANY ideas, I'm all ears.
 

Soulrender

Jack Of All Trades
Veteran
Joined
Jan 12, 2019
Messages
994
Reaction score
581
First Language
Poland
Primarily Uses
RMMV
I would try standard routine:
- Graphic Driver update/downgrade
- Motherboard Driver update/downgrade
- NET Framework / Visual Redistributable update/downgrade
- Antivirus Scan (Full)
- Remove all unsued applications (some of them might run in background)
- Scan for malwares
- Check temperatures of components (GPU, CPU, Disk)
- HDD defragmentation (don't do it if you have SSD disk installed)
- Scan for registry errors

If all that above will not work, then... Reinstall windows.
 

zerobeat032

Cloaked Wanderer...
Veteran
Joined
Mar 28, 2014
Messages
359
Reaction score
588
First Language
English
Primarily Uses
RMMV
I would try standard routine:
- Graphic Driver update/downgrade
- Motherboard Driver update/downgrade
- NET Framework / Visual Redistributable update/downgrade
- Antivirus Scan (Full)
- Remove all unsued applications (some of them might run in background)
- Scan for malwares
- Check temperatures of components (GPU, CPU, Disk)
- HDD defragmentation (don't do it if you have SSD disk installed)
- Scan for registry errors

If all that above will not work, then... Reinstall windows.
I'll try the ones on here that I haven't already... thanks for the suggestions.
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,789
Reaction score
14,589
First Language
English
Primarily Uses
RMVXA
Select restart computer, and let it do its thing. Sometimes things get garbod in memory and a restart fixes that.

And be sure it is restart, not shutdown. Shutdown won't help here.
 

zerobeat032

Cloaked Wanderer...
Veteran
Joined
Mar 28, 2014
Messages
359
Reaction score
588
First Language
English
Primarily Uses
RMMV
It apparently seems to have fixed itself??? I need to keep testing to be sure it's definitely ok. all I even did differently was I forgot I had Community Basic Plugin.. I added it and magically everything is working? I don't trust it quite yet. The only other thing is I had shut off my laptop because I thought I accidently deleted an important driver. If Things persist in the current direction, I'll close the thread. but I'd like to check as much as I can first since it really started working out of nowhere.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,164
Reaction score
14,654
First Language
English
Primarily Uses
RMMV
So this is games you create and play via Test Play, not the editors themselves?

I doubt adding that plugin changed anything, but if you want to test it out, you could just remove it and see if the problem starts happening again.
 

Soulrender

Jack Of All Trades
Veteran
Joined
Jan 12, 2019
Messages
994
Reaction score
581
First Language
Poland
Primarily Uses
RMMV
All I can say, anything can happen, recently i started to struggle with BSOD (blue screen of death) it occurs in MV games when closing game (doesnt matter wich title, every single one) and also in AAA games, but when Opera is open. When opera is closed everything is ok. So I would also check applications using internet connections or even disable connection to internet and check how it will work
 

zerobeat032

Cloaked Wanderer...
Veteran
Joined
Mar 28, 2014
Messages
359
Reaction score
588
First Language
English
Primarily Uses
RMMV
So this is games you create and play via Test Play, not the editors themselves?

I doubt adding that plugin changed anything, but if you want to test it out, you could just remove it and see if the problem starts happening again.
Yeah it wasn't the editor, basically anytime I play tested the game was running horribly. I'm still not sure what was going on as it seems to have fixed itself? I'm not sure how though, but I guess the problem is solved. and yeah, I turned off the plugin and it wasn't that. it's just magically working fine again.

What's weird is it was effecting MV and MZ. I tested a sample project for MZ and it was running pretty rough. But as of now, both are fix. I'll have this closed.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,164
Reaction score
14,654
First Language
English
Primarily Uses
RMMV

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.



I wonder if maybe you had something else running on your computer at the time. I remember an indie gamer telling how he'd been working on his game and it was all going smoothly, then all of a sudden it was really slow and jittery. He started undoing all of his recent changes, one by one, to try to identify what it was he'd done to cause it, to no avail. After a couple of hours he was really getting frustrated, decided this needed his full attention, so turned off his music player so he could focus completely. As soon as he turned it off, the game started running smoothly again.
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

Not that I have any use for them, but Humble Bundle has a new RPG Asset Bundle available for those interested. You can find it here. Happy asset hoarding. :LZSwink:
Tired of just doing mobile. Now you can Play the game in ur Browser! https://bigmala-productions.itch.io/rpg-forever
I managed to fix my car at last... :biggrin:

I'm proud of what I have achieved with my project. Don't mind with the Spanish, Ill add more languages.

Forum statistics

Threads
111,282
Messages
1,059,893
Members
144,584
Latest member
gillfigno
Top