No debug tools when playtesting.

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
Hello something started happening recently that's very frustrating. When play-testing the debug tools no longer appear either in the menu or by pressing f9! I'd appreciate if someone could tell me what's going on as this makes debugging a LOT harder!
 

Aloe Guvner

Walrus
Veteran
Joined
Sep 28, 2017
Messages
1,628
Reaction score
1,121
First Language
English
Primarily Uses
RMMV
Some questions:

1.) Do you have RPG Maker MV through Steam?
2.) If it's on Steam, do you have the properties set to "Auto-Update"?
3.) Are you able to open the F9 debug menu in a new project?

If all are yes, your issue is that the RPG Maker MV editor upgraded to version 1.6.1 but you didn't update your project.

 

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
Ah ok that was it .. Must have missed the update ..
 

Aloe Guvner

Walrus
Veteran
Joined
Sep 28, 2017
Messages
1,628
Reaction score
1,121
First Language
English
Primarily Uses
RMMV
OK, glad that you got it worked out! I would recommend disabling the auto-update through Steam, it can help save you some headache when these updates happen --> and you'll be able to choose whether to update or not, and do it on your own terms.
 

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
Hey I'm actually over the moon. Since updating my game's performance issues have been fixed. Mostly my game ran fine but when handling large groups with all spells or other animation or image intensive sections it would often freeze up. Today there is no lag. Everything runs smooth! So I'm thankful the issue showed up and forced me to update XD. Thanks for letting me know too!
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,054
Reaction score
7,976
First Language
German
Primarily Uses
RMMV
Then your project probably had a very old core - there have been memory leaks and performance issues up to 1.3, but beginning 1.4 all the defaults engines memory leaks were found and fixed...
 

Aloe Guvner

Walrus
Veteran
Joined
Sep 28, 2017
Messages
1,628
Reaction score
1,121
First Language
English
Primarily Uses
RMMV
@Andar That is possible, but it is not the only possibility. MV v1.6.1 comes with nw.js v0.29.0 which is bundled with Chromium 65, so the upgrade to the Javascript engine itself may be a significant factor in the performance improvement.
 

Latest Threads

Latest Profile Posts

AeroPergold wrote on LUKElcs's profile.
Its-a me, Pergold from Gamejolt!
I added footstep sounds to our content that I posted in a previous thread. I was unable to edit the post, so if you're interested, see below.

DOWNLOAD LINK

I've started working on rpg maker again, and I can see a lot of improvement from when I was 13. I still have a long way to go, but I'm proud that I've gotten this far.
Animated Title screen is by SharkerrBlue(SB)
I am using the Nightmare Land pack.
I just can't walk to the store for lunch without walking past people smoking. It not only smells bad, it's probably poisoning me. I'm afraid I'll eventually have to be hospitalized. I can't take another path because there's too much traffic and drivers in the plaza are reckless sometimes. I almost got run over once, even after looking both ways.
RyanYe wrote on whtdragon's profile.
Your art works about Wyrvens and Dragons are sooooooooo cooooooooool~! I like them so bad
Can you create more? like Archangels, Devils, Titans, Cyclops!!

Forum statistics

Threads
108,811
Messages
1,039,658
Members
141,258
Latest member
Faxion
Top