OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
867
Reaction score
1,001
First Language
Finnish
Primarily Uses
RMMZ
@OcRam How can I check that? In the console log? I'll check asap but can't reach my pc today.
Sorry for the late answer (summer holidays).

I think one way would be to enable "Debug" mode in parameters and check if "_gameJustLoaded -flag set to true" appears to console log (F8) after load.
 

HalcyanStudio

Eniko Ghosts of Grace Dev
Veteran
Joined
Mar 16, 2012
Messages
1,031
Reaction score
712
First Language
Dutch
Primarily Uses
RMMV
@OcRam No problem, will check it out. I also have a weird issue that i can't open the console log so i'll have to look into that as well (I have a feeling that it's a mac related issue, luckily I also have a windows laptop). Anyway, i'll get back to you asap :)
 

Radlerdani

Veteran
Veteran
Joined
Dec 24, 2016
Messages
66
Reaction score
14
First Language
German
Primarily Uses
N/A
What a incredible Plugin!
Thanks for your work.
 
Last edited:

Radlerdani

Veteran
Veteran
Joined
Dec 24, 2016
Messages
66
Reaction score
14
First Language
German
Primarily Uses
N/A
Got an Issue. After the battle my BGM from the overworld dosent come back again.
I figured out why - my battle theme start over the Troop Event with a commentary. Seems like it overwrite my BGM from the Map. (its the YEP_BattleBgmControl Plugin)

If i delete the commentary out of my troop event - and the maker plays the default battle music - it works. After the battle my overworld music comes back.

If i disable the OcRam Audio EX Plugin and the battle theme start over the commentary, everything is also fine. My overworld BGM comes back like it should be.

EDIT:
Fixed it.
Place the OcRam_Audio_EX Plugin ABOVE (!) the YEP_BattleBgmControl.
The BattleBgmControl Plugin dosent do much, so you can put it far down on your plugin list.
 
Last edited:

VaiJack8

Veteran
Veteran
Joined
Sep 21, 2016
Messages
51
Reaction score
40
First Language
Italian
Primarily Uses
RMMZ
Heyyy

This is a great plugin, I think it's essential for every project. But is there a chance it could be made compatible with MZ + FOSSIL? xD As of now, it gives me this error.

Thanks in advance.


UPDATE: I didn't notice you made this available for MZ, too. Thank you so much! I'm gonna try it out a little bit and maybe I'll buy the license in a few months, as soon as I decide what kind of project I wanna do. Thanks again br0 <3
 

Attachments

  • 2021-09-28 13_40_40-Window.png
    2021-09-28 13_40_40-Window.png
    15.1 KB · Views: 2
Last edited:

LMPGames

Veteran
Veteran
Joined
Nov 15, 2017
Messages
63
Reaction score
30
First Language
English
Primarily Uses
RMMV
Running into a couple of issues.

First, the plugin is fading out the BGM for the map as soon as the audio start playing and it is prevent the audio from resuming after battle.

I have tried putting the plugin at the end of the load order and at the beginning, but this issue is still happening.


Second, I am getting this error when testing with the BGM volume option turn to 0:

OcRam_Audio_EX.js:1308 Uncaught TypeError: Failed to execute 'linearRampToValueAtTime' on 'AudioParam': The provided float value is non-finite.
at WebAudio.fadeTo_OC (OcRam_Audio_EX.js:1308)
at WebAudio.<anonymous> (OcRam_Audio_EX.js:1322)
at WebAudio._onLoad (rpg_core.js:8309)
at WebAudio.<anonymous> (rpg_core.js:8198)
 

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
867
Reaction score
1,001
First Language
Finnish
Primarily Uses
RMMZ
Running into a couple of issues.

First, the plugin is fading out the BGM for the map as soon as the audio start playing and it is prevent the audio from resuming after battle.

I have tried putting the plugin at the end of the load order and at the beginning, but this issue is still happening.


Second, I am getting this error when testing with the BGM volume option turn to 0:
Thank you for the message,

At least BGM 0% bug has been fixed in v2.10 and latest version is v2.11 try updating plugin. If it helps in these issues.
 

Oks

Villager
Member
Joined
Sep 10, 2021
Messages
8
Reaction score
3
First Language
French
Primarily Uses
RMMV
Hello, any idea why the weather bgs are not working in battle? Only thunder is working.
Without the plugin, it works fine with your others plugins (Time, Weather, Light).
Just tried on a new project & your demo project, no weather sound in battle.
 
Last edited:

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
867
Reaction score
1,001
First Language
Finnish
Primarily Uses
RMMZ
Hello, any idea why the weather bgs are not working in battle? Only thunder is working.
Without the plugin, it works fine with your others plugins (Time, Weather, Light).
Just tried on a new project & your demo project, no weather sound in battle.
Thank you for the message,

Are all plugins up-to-date and in correct order? Check https://ocram-codes.net for correct order (MV section if MV is used)
 

Oks

Villager
Member
Joined
Sep 10, 2021
Messages
8
Reaction score
3
First Language
French
Primarily Uses
RMMV
Thanks for the reply.

I have them is this order: Time - Audio - Weather - Light. MV 1.6.1 and all plugins up to date.

Last night i have tried everything during 6 hours. Couldn't find a solution.

I found another plugin for the sound but would prefer use your Audio plugin, its way better.
 

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
867
Reaction score
1,001
First Language
Finnish
Primarily Uses
RMMZ
Thanks for the reply.

I have them is this order: Time - Audio - Weather - Light. MV 1.6.1 and all plugins up to date.

Last night i have tried everything during 6 hours. Couldn't find a solution.

I found another plugin for the sound but would prefer use your Audio plugin, its way better.
Plugin order is correct and so are versions. And I actually managed to replicate this (something has been changed in updates to prevent BGS1/2 playing in battles). I will get back to this after I have made the fix.

Thank you for the report!

EDIT: @Oks

Ok - The fix is now done in OcRam_Audio_EX (MV v2.12) and it's released (OcRam_Audio v1.03 MZ will be released later). Thank you again for the report!
 
Last edited:

Oks

Villager
Member
Joined
Sep 10, 2021
Messages
8
Reaction score
3
First Language
French
Primarily Uses
RMMV
I just tried it, works perfectly fine now.
Thanks for the quick update.
 

Rakon

Warper
Member
Joined
Feb 11, 2020
Messages
4
Reaction score
0
First Language
German
Primarily Uses
RMMV
The Setup for the togglable audio ON/OFF event does not work for me...
I have all your plugins in the correct order like at your website and at the bottom of my plugin list.

the bgs continues to play even if I switch to another eventpage.
Do you have any tips what I´m doing wrong?
 

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
867
Reaction score
1,001
First Language
Finnish
Primarily Uses
RMMZ
The Setup for the togglable audio ON/OFF event does not work for me...
I have all your plugins in the correct order like at your website and at the bottom of my plugin list.

the bgs continues to play even if I switch to another eventpage.
Do you have any tips what I´m doing wrong?
Thank you for the message,

BGS continues until it's stopped or cleared. Below is example from my demo project (it's torch with fire crackle BGS and it's stops when light is put out).

audio_s1.png
audio_s2.png
 

Rakon

Warper
Member
Joined
Feb 11, 2020
Messages
4
Reaction score
0
First Language
German
Primarily Uses
RMMV
Thank you very much!^^
 
Joined
Jul 15, 2012
Messages
51
Reaction score
8
First Language
Swedish
Primarily Uses
RMMV
Problem: The torch bgs sound only starts if I interact with the torch. How do I make it autoplay at startup or upon enetering the map?
Se pictures below for my settings.

Thanks in advance <3

plugin list.png

plugin settings.png

event settings.png
 

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
867
Reaction score
1,001
First Language
Finnish
Primarily Uses
RMMZ
Problem: The torch bgs sound only starts if I interact with the torch. How do I make it autoplay at startup or upon enetering the map?
Se pictures below for my settings.

Thanks in advance <3



Thank you for the message,

It seems you have disabled autoplay (that 'false' after 'pan').

Code:
<aex:d:15+0:0:pan:true>

And if plugin parameters default 'pan' is on and default 'forced play' is true then this should do same as above (please remember that if plugin parameters are adjusted later on it will effect all omitted values):
Code:
<aex:d:15+0:0>
 
Joined
Jul 15, 2012
Messages
51
Reaction score
8
First Language
Swedish
Primarily Uses
RMMV
Thank you for the message,

It seems you have disabled autoplay (that 'false' after 'pan').

Code:
<aex:d:15+0:0:pan:true>

And if plugin parameters default 'pan' is on and default 'forced play' is true then this should do same as above (please remember that if plugin parameters are adjusted later on it will effect all omitted values):
Code:
<aex:d:15+0:0>
Thanks! Will try it <3
 

Latest Threads

Latest Profile Posts

So I kinda came back and learned how to mod other RPG Maker games so... Hello everyone!
Captura-de-pantalla-475.png
Version 1.0.1 done! Now finally free time... oh
Capture.PNG
I'm Really proud of how my game over screen looks!
UldJFr1.png
I felt inspired by a piece of art I saw. So I made this.

Wanderer Doge.png

Thought i'd be cool to have like a company introduction. Check it out!

Forum statistics

Threads
123,278
Messages
1,155,433
Members
161,674
Latest member
Luxheo
Top